AI Suite won't install? O.o

Hi all. So I have an ASUS Crosshair IV Formula and my brother was telling me to get on the AI Suite to check out this thing that apparently charges iPhone at 3x the normal rate (idk cause I couldnt get AI Suite). But anyways... I went to the ASUS website and downloaded it but then it gave me an error when trying to install it. My brother has it on his PC. (He has the ASUS Crosshair V Formula) and I'm aware that we don't have the same mobo but he assured me that it said it worked for the IV also. Anyone know what I'm talking about?
7 answers Last reply
More about suite install
  1. You need the new version 2.
  2. Make sure all windows updates are current also.
  3. "The model does not support this application"

    Same msg I got before when trying to install.
  4. Did you install the latest amd chipset drivers.
  5. Pretty sure I did that already. I can try again though to be sure.
  6. Nothing has worked. I've come to the conclusion that maybe it just doesn't work with my mobo.
Ask a new question

Read More

Asus Formula Brother Motherboards