Motherboard power light is on but system will not boot (PSU fine)

Problem description: I've just purchased a new mobo, RAM, processor and SSD. I've put all the components together with my old graphics card and PSU and am trying to get it to work. However, when I switch the power supply on, the motherboard light comes on, but the power button does nothing.

Attempted fixes: I've tried taking everything out of the computer one component at a time (sound card, graphics card, all but one stick of RAM) and disconnecting all non essential items, tried powering the computer on by touching the pins with a screwdriver, taking out and reseating the motherboard, disconnecting and reconnecting all the PSU connectors.

Recent changes: Yes - a lot of new hardware.


Operating system: None currently installed on the SSD, but will be 7 x64 Pro.

System specs: OCZ Stealth XStream 600W PSU, Intel core i5-2400 3.10GHZ, Asus P8P67, Kingston HyperX 1600MHz DDR3, ATI Radeon 4870, OCZ Vertex II SATA2 90GB SSD.

I have Googled and read the FAQ: Yes - google suggests that this may well be a PSU problem. Was hoping for some other suggestions before I replace the PSU, as it was working fine the previous day with my old system.

UPDATE: Have tried the PSU with my old motherboard again and it worked. Worrying.
2 answers Last reply
More about motherboard power light system boot fine
  1. Hello Boyotbh;

    The FAQ suggests assembling the parts outside the case (bread boarding) and testing.
    Have you done that yet?
    Do you have a standard HDD you can test in place of the SSD?
  2. You could also try a bootable CD.
    Make one with OS included which you can load from the CD or even a USB thumb drive.
    Ubuntu Desktop Linux (Try it from a CD or USB stick)
Ask a new question

Read More

Homebuilt Motherboards Systems