Sign in with
Sign up | Sign in
Your question

Catalyst Control Centre wont open

Last response: in Graphics & Displays
Share
June 4, 2011 9:17:48 AM

Ive been having this problem for about 2 weeks now and I still havent been able to find a solution that works. At first, every time I start up my computer I get the error message: Catalyst control centre host application has stopped working. I then applied a windows update and an ATI driver update. CCC worked for 1 day then stopped working again. Now Ive tried reinstalling all my graphics drivers, uninstalling them and clearing all remnants before reinstalling. I still cannot solve the problem. Any help would be appreciated.

I am running on Windows 7 Home Edition 64-bit
CPU Specs:
Asus P6E SE Motherboard
Intel Corei7 920
Ati Radeon HD5970
6 GB RAM

Thanks in advance for any help you can provide

More about : catalyst control centre wont open

June 4, 2011 6:08:57 PM

Download crap cleaner http://www.piriform.com/ccleaner

Download the latest AMD driver from AMDS website, place on desktop for ease of access. www.amd.com

Reboot in safe mode. (f8 at restart)

Uninstall CCC, and anything ATI related

Delete any old downloaded drivers

Run Crap cleaner

Restart, run the latest downloaded driver for AMD

Might have to restart again.

That should install the driver and software properly. If you are still having trouble, make sure you have the latest DOTNOT software. (i think the latest for windows 7, is 4.0)

m
0
l
June 4, 2011 6:13:21 PM

wait you can't see catalyst control or manage to open it right? well i had the same problem when i was using ATI/AMD but what i did was unistall all the ATI Drivers and i used Driver Cleaner pro to delete everything from ATI...Then i went to AMD to download the newest driver it worked and it started showing the Catalyst control again...
m
0
l
!