Sign in with
Sign up | Sign in
Your question

Poor SSD Performance and non-functional Wireless Car

Last response: in Systems
Share
August 8, 2011 6:08:24 AM

Hi Guys. This is my current rig:

CASE: Thermaltake Level 10 GT
CPU: Intel CPU Core i7 975 Extreme Edition
Cooler: Noctua DH-14
Monitor(s)/Displays: Samsung Syncmaster BX2440 x 3, Sony Bravia KDL-5500 40"
RAM: Corsair Dominator DDR3 Triple Channel 6GB
Motherboard: ASUS P6X58D-E
Graphics Card: XFX HD6990
SPEAKERS: Logitech Z5500 5.1 SURROUND SOUND
Network Adapter: ASUS PCE-N13
Hard Drive: OCZ Agility 3 120 GB
Hard Drive: Seagate Momentus XT 500 GB
Hard Drive: Seagate 1000 GB 7200 RPM x 2
Optical Drive/s: LG BluRay Writer, Pioneer DVD Writer
Power Supply: Silverstone 1000W
Software: Microsoft Windows 7 pro 64bit

I upgraded (or so I thought) from a Rampage II Extreme cause i wanted the Agility to be functional on the new motherboard. As I have not overclocked the old one at all, I decided to go for this motherboard model over the next Rampage, which was much more expensive.

Things that started to not function anymore was the OCZ Agility 3. It has absolutely poor performance. We are talking about 190/90 read/write results on CrystalDiskMark, and also some stuttering issues as well sometimes during games like Supreme Commander on the intro screen. Also, the startup times for Win7 is crap. Almost like a minute and a half. The Seagate HDD 7200 RPM was faster than this. Programs aren't as responsive as they should be when opening after the system has booted and ready.

The things that I tried to do first to troubleshoot this problem.

1. Went into BIOS and made sure that it was set to AHCI mode. After this I went and prioritised the boot drive to the SSD. This did nothing, and even though I changed it to AHCI Mode, the boot priority menu still states that it is in IDE mode.

2. Went into Win7 to set it into AHCI mode anyway in Regedit. The "start" value is set to 0 from 3, and this still did nothing.

3. I went to msconfig and cut the delay time to startup. this also did nothing.

4. I made sure that the X58 chipset drivers were updated. In fact, this is where ASUS failed, the drivers on their website are not the latest one, I actually have a more recent version already on my system.

5. Updated Marvell Controllers. I went into the device manager and made sure the Controller was the latest one. I had to download it manually and then force it to update, it is now the one that is current as of 17 of March 2010.

6. I thought the computer might be confused with all these drives at the startup, so I disconnected all of them save the SSD. This still did nothing.

Any advice on this issue? I have a feeling that I have not truly set the SSD to AHCI mode.

*Both the SSD and Hybrid SSD are connected to the SATA 6.0 GB/s connectors.

Also, finally, when I had a PCE-N13 on my Rampage II Extreme in the same room, it worked sweet. The connection was as strong as my PS3. But now that I've connected it in this motherboard, it hardly connects at all and cannot download at all times. What gives? I've also updated the drivers. I'm at a loss.

Any help would be much appreciated, I pictured my upgrade to be much more of a dream than this.
a b B Homebuilt system
August 8, 2011 6:22:30 AM

Hmm, Looking at your config., I noticed that you have only one SSD drive installed. However, this comment, "*Both the SSD and Hybrid SSD are connected to the SATA 6.0 GB/s connectors", suggests that you have two SSD's configured/installed. What do you mean by that? Did you partition the SSD as two drives and your using one as OS boot drive and the other as something else or do you actually have two SSD's?
m
0
l
August 8, 2011 6:28:08 AM

Hi! OK I'll clarify that by saying that they are merely connected to the two only available SATA 6.0 GB/s ports on the motherboard labeled in white on the ASUS P6X58D-E motherboard.

First connected drive is the true SSD, the OCZ Agility 3 120 GB with the OS installed on it.

Second is the Seagate Momentus XT SSD Hybrid 500GB Drive I use for things like games and huge applications I want to run fast but are not crucial to running on a full-blown SSD. I have not made them run in a RAID config or anything (I do not know how to), as I know that the Hybrid SSD cannot be RAIDed.

Neither are partitioned.
m
0
l
Related resources
a b B Homebuilt system
August 8, 2011 4:20:30 PM

Ok, my mistake, I assumed that the Seagate Momentus Drive was a Mechenical hard drive since I didn't see it on Newegg in the hard drive or the SSD section. Found it this time.

If I had that problem you described I would first suspect the OCZ Agility as being defective. However, try swapping the cables on the SSD's to see if it improves. Also try using the 3Gb/s ports for the SSD's. You won't see a big difference between using the 6 Gb/s vs. the 3Gb/s ports since SSD's are extremly fast anyway(although there is a difference).

Only othe thing I can think of iseither the OCZ Agility SSD is defective or possibly the Marvell controller is not intended to be used with the boot drive.
m
0
l
a b B Homebuilt system
August 8, 2011 4:23:35 PM

Edit: BTW Most drives come partitioned right out of the box so I'm assuming that you meant that you didn't repartition and format the drives?
m
0
l
a b B Homebuilt system
August 8, 2011 5:14:14 PM

(1) Download and run AS-SSD. DO NOT run the benchemark, just open the program. In upper left you will see what driver is being used and if the partition aliingment is OK. For best results I think the driver should be msahci (for the marvel controller). Make sure it is NOT pcide. Note for SATA III on intel controller it should be iaSTor. Partition alignment should show "green OK".

(2) You may need to download and run the OCZ toolbox and do a secure erase and then reload win 7. This can be probmatic - (A) you need a system with a bootable drive and the SSD must 1. Have ALL partitions deleted and 2. must not be the boot drive. Alternative is to use a bootable Linix disk. Need to hop over to OCZ forum for details.

Comments. I have two Agility III drives. My take is thay are Plug-&-PRAY and the box should contain a warning "Buyer Beware". They can be very probmatic depending on system and system configuration. Take a look at newegg satisfaction ratio - One of the poorest!!! http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Less probmatic - Marvel based SATA III SSDs. They are slower in Benchmarks, but when it comes to day-to-day operation there is little difference. My Agility III worked in SB Asrock Z69 Exterme4 using the Intel Sata III controller. The 2nd one would NOT even install on a SB Notebook. Had NO problems installing a M4 SATA III SSD in laptop.

Added:
@ JKatwyopc - Very few drives come patitioned (I say Very few as there may be some rare exception). Partitiong and formating is done (A) duriing winows installation and/or using Windows disk management.

There is VERY little advantage in putting a SATA III HDD on Sata III. The ONLY benifit is in burst rate. Also when you install the operating system on the SSD, leave the HDD DISCONNECTED until after windows has been installed..
m
0
l
August 9, 2011 3:34:05 AM

I just did a couple before I started the topic anyway:

First in the Intel Controller, at SATAII:

http://imageshack.us/photo/my-images/691/benchmarkssdin...

Second back in the original spot in the SATAIII Marvell Controller:

http://imageshack.us/photo/my-images/696/benchmarkssdma...

This is after the update of the firmware which someone else has recommended, seemed to do nothing for it though.

There. New Benchmarks. These seem to be worse though.

in the Marvell Controller:

http://imageshack.us/photo/my-images/194/benchmarkssdma...

In the Intel Controller:

http://imageshack.us/photo/my-images/703/benchmarkssdin...

Now for the ATTO:

The one on the left is the Intel one (despite the description, I forgot what I had it in) and the one on the right is the Marvell controller.

http://imageshack.us/photo/my-images/846/comparisonb.pn...

Seems a bias for read or write depending on which controller I use.

Its a sad day when my laptop beats out my PC with newer gen hardware. I've seen benchmarks which take it closer to the 500 mb/s mark for read or write. I would be happy with around 400. But damn man my scores are way lower. I do not know why.

Also, take note, even though i went into bios and changed all settings to AHCI mode, when I try to configure it, none of the drivers were detected. Also, when I select my drive for the boot priority, there is a prefix for the Agility 3 which says IDE. Dunno why. I set all to AHCI mode, and it still does this despite that.

m
0
l
!