Sign in with
Sign up | Sign in
Your question
Closed

(SOLVED)HELP, Wireless issue from hell

Last response: in Wireless Networking
Share
January 14, 2011 5:04:01 AM

Strangest wireless networking issue I have ever seen.

I need help, and I think I need a Jedi Master of networking to solve this problem.
I have tried updating drivers, and testing different adapters and routers. This issue is not logical and it does not make sense.

I have a brand new laptop that will not connect to my wireless router.

Specs:
Laptop – Acer Aspire 7741G-7017
Wireless NIC – Atheros AR5B97 mini pci card
Router – Linksys WRT54GL v1.1
OS Windows 7 home premium

Trouble shooting Information gathered:
7 other wireless devices can connect to the router.
The laptop cannot connect in Safe Mode with Networking support.
The laptop cannot connect even if encryption/security is turned off.
I tried using a different router, Linksys WRT120N, And it will only connect if the encryption is turned off.


If I use a different wireless adapter, (Asus USB-N13) it will connect to the WRT54G router, And it works fine with or with out encryption.

If I boot the Laptop with a Knoppix DVD The Atheros adapter will connect to the WRT54G router. And it works fine with or with out encryption.

So the problem only happens in Windows, but windows works fine if I use a different a different adapter. But I know the adapter works, because it will connect in Linux. And the adapter has even worked in windows, but only with a different router that has encryption disabled.
Anonymous
a b F Wireless
January 17, 2011 10:25:22 PM

Possibly, the driver you are using in Windows doesn't work. Try a different one -- preferably from the Acer site or, failing that, from Atheros.

Possibly there are resource issues -- check Device Manager to see if adapter is recognised or whether it is yellow flagged as faulty.

Sorry if you have tried all these but, logically, it's where I'd start.
Score
0
February 1, 2011 9:14:23 PM

SOLVED :D 

First off i would like to thank all of you for looking at this issuse and for the advice everyone gave.
I tried removing and reinstalling the drivers and installing 3 different versions of the drivers. Again nothing helped and this was a very frustatinbg issue.

Just an FYI Acer's Technical support was pretty lowsy, but the tech's at Microsoft were amazing.

I actually stumbled on to the resolution by accident.

I opened the properties of the Atheros AR5B97 adapter, and on the advanced tab there is a properties section with several items. One of which says " 802.11 Bluetooth High Speed " I changed this to Disabled.

And now it connects just fine. Again I am not sure why this fixed it, I do not own any bluetooth devices nor have every tried to use/configure bluetooth.

I could be way off, but it seems like the Atheros adapter was trying to connect using bluetooth, and after it failed, it did not try to connect with 802.11 b/g/n or what ever.

So to sum up, if you happen to have an AcerAspire 7741G-7017 laptop that uses an Atheros AR5B97 Mini PCI adapter, and you are running Windows 7, And you are trying to connect to a Linksys WRT54GL router, And it just will not connect...Try disabling the bluetooth high speed option in the advanced section of the adapters properties.

Thanks again,

David
Score
0
Related resources

Best solution

May 6, 2011 11:59:15 AM

The solution David provided also works with an Acer Aspire 5253-BZ65 using Atheros AR5B97. We have another
Acer Aspire 5253-BZ65 that came with a Broadcom mini pci adapter and it never had any problems. I noticed that
The Atheros had defaulted to "bluetooth high speed - Enabled" while all the Broadcom values were set to "Auto".
The Atheros has 7 properties that you can change to either enable or disable. The Broadcom has 28 properties that
you can change to "Enable","Disable" or "Auto".

Thanks to David for figuring this out. Now we can keep our laptop:) 
Share
June 16, 2011 8:21:35 PM

I have an Acer Aspire 5253 and could not connect to the internet. I had McAfee Virus Protection installed, after trying a few other options I disabled McAfee and it worked. McAfee blocks the internet. I downloaded AVG and do not have any issues now. If you're having trouble accessing the internet try disabling your virus protection & try again. If it works consider buying AVG as it will not block the internet connection.
Score
0
June 27, 2011 2:01:59 PM

Best answer selected by drabney.
Score
0
August 16, 2011 4:22:03 PM

Just got Acer Aspire 5552 and spent all afternoon trying to figure out why I can see my neighbours' routers but not mine! Same wireless adaptor, different router (Netgear), same problem.....and same solution! Disable bluetooth in adaptor settings and network appears within seconds!! Thanks all, wouldn't have guessed this in month of Sundays
Score
0
a b F Wireless
August 16, 2011 9:09:11 PM

This topic has been closed by Area51reopened
Score
0
!