Closed Solved

ASRock Z77 Extreme 4, no video, new build

I just put together a new computer. I turn it on and it all boots up, no error messages. Fans are on, heatsink spinning, HDD seems to be running, but there is NO VIDEO. I started with the video card installed. I tried taking it out and putting it back. I even tried moving it to another slot. Nothing. I tried just using the onboard graphics. I tried using DVI, VGA, VGA with DVI adapter. I tried all inputs. I tried clearing CMOS using the i/o port button. Any help or input would be greatly appreciated. Thanks!

-ASRock Z77 Extreme 4 MB

-i5-3570K 3.4ghz CPU

-EVGA GTX 560 GPU

-WD Blue 750 GB HDD

-PC P&C Silencer 750 power supply
8 answers Last reply Best Answer
More about asrock extreme video build
  1. Got any memory in there???
  2. Got it figured out.. thanks
  3. bassman3927 said:
    Got it figured out.. thanks


    What did you do??
  4. So, what was wrong with it bassman3927?

    It can help others with same problem : ))
  5. Best answer
    The 8-pin plug to the mother board wasn't seated all the way... :/
  6. Cool : )
  7. Best answer selected by Nikorr.
  8. This topic has been closed by Nikorr
Ask a new question

Read More

ASRock Motherboards