Printer to USB weirdness

Something weird is happening...probably due to my stupidity, but here goes:

I recently built only my 2nd pc ever. Build components are

Asus P8Z77-V LK
i5-3570
EVGA GTX 560
Corsair Vengeance 16GB
WD Black 1TB
Antec 1100
Win7 64bit

Build works great and I'm really happy with it. I have an oooold HP Laserjet 1100 that I want to direct connect to the new build, but this M/B doesn't have the parallel connection. So, I bought a parallel to usb cable.

First try on connecting the usb cable into one of the usb slots on the back resulted in no printer being recognized. In the Devices and Printers dialogue box something labeled a "IEEE-1284 Controller" is listed, but no printer. Thought it was a driver issue, but discovered that Win7 contains the necessary driver for this old printer, so nothing new to download.

Went to have dinner and came back and for some reason decided to plug in the usb to one of the front usb slots. Amazing!!! The printer was recognized, the driver was found through Windows Update (happened automatically) and the printer works.

That is great news, however, I don't like that I have a usb cable permanently sticking out of the front of my machine plus I really don't understand why it works from the front slot but not from one of the back slots. Yes, I tried every one of the back slots with no joy.

Any thoughts on this one?

Thanks.

Clay
3 answers Last reply
More about printer weirdness
  1. Are your front ports USB 2.0 and the open back slots USB 3.0? If so, move another USB cable in the back to free up a USB 2.0 port. Also, make sure the necessary USB 3.0 drivers are loaded as well.

    Good luck!
  2. Great question. Should have clarified this at first. Have both usb3 and usb2 slots on the rear and on the front. Tried connecting in all slots (usb3 and usb2). Was only successful when plugged into either of the two front usb2 slots. None of the usb3 slots worked (front or back) and none of the usb2 slots on the back worked. I'm guessing there is some kind of connection issue, but I've inserted a flash drive into all my usb slots and they all seem to be working...just for some reason most of them don't recognize this printer.
  3. That is, indeed, very odd. Could also be a grounding issue. Are you having any issues with any other devices plugged into the back of your rig? Make sure the ATX I/O plate doesn't have any little aluminum tabs sticking into any of your ports.
Ask a new question

Read More

Asus USB Printers Motherboards