Sign in with
Sign up | Sign in
Your question

HD4850 working at x4 link width instead of x16

Last response: in Graphics & Displays
Share
June 7, 2011 8:23:35 AM

Well, as the topic says.. my graphic card is been running at x4 link width even tho I'm pretty sure it should work at x16...

I've been looking for an answer everywhere but every thread about this problem has been solved and none of those solutions worked for me...

some of those were:

-set the power options to high performance. didnt work

-Make sure it is in the dedicated upper PCIE 2.0 x16 slot. And it is.

-Make sure the other PCIE 2.0 x16 slot isn't being use. And it isn't.

-Uninstalled everything from ATI/AMD from my computer and reinstall the latest drivers.

- Flashed my BIOS to the latest version available.

Then I decided to get a second opinion, ( I knew it was running at x4 because of CCC ) and both CPU-Z and GPU-Z told me the same.. that I was running my GPU at x4 when the max available was x16.

I just don't know what else to do, I also went into my BIOS and look for anything that would let me set or force the link width, but there was nothing.


my specs are:
Windows 7 64bit Ultimate
GA-MA78G-DS3H rev 2.1
Phenom 9550 2.2GHz @ 2.6GHz
2x2GB OCZ Platinium DDR2 1066mhz
Gigabyte HD4850 512mb

I'll glady accept any comments or suggestions on what do to :)  (PLEASE HELP ME)

Thanks in advance.
a c 169 U Graphics card
June 7, 2011 9:13:02 AM

Try updating your BIOS.If it didn't help,then probably your motherboard is defective.
Can you test the card in another system ?
m
0
l
June 7, 2011 9:49:47 AM

Yes I will as soon as I get a chance.
m
0
l
June 7, 2011 2:54:13 PM

Check the manual of your motherboard and also download the online instructions.

My motherboard needs single card gpus to be connected to the bottom slot and a placeholder to be put into the top slot for 16x.
m
0
l
!