Sign in with
Sign up | Sign in
Your question

Help with sabertooth z77

Last response: in Motherboards
Share
August 8, 2012 11:11:28 PM

I recently built a new build with a sabertooth z77, intel i7 2700k, 8gb corsair ram, a sapphire 7970 and some HDD and ssd. It worked fine until one time in the motherboard menu I changed the settings to high performance, from default. I saved and rebooted and ever since then it hasn't POSTed, and my monitor doesn't turn on, just stays on standby. There's a red light indicating a problem with the graphics card but I don`t know what. It turns it self pf after about 15 secs and reboots and does it all over again. I tried taking the graphics card out and running on the in built in graphics card in the CPU but that won't work either. I've taken it to pieces a couple of times and put it back together but no change.

Anyone have any idea what's going on?

Is there a way to reset my motherboard and might this help?

More about : sabertooth z77

a c 717 V Motherboard
a b U Graphics card
August 8, 2012 11:24:07 PM

Start with a proper Clear CMOS, unplug the PSU for 5 minutes then move the CMOS Jumper for 5+ seconds and then back again, plug the PSU in and try again; see - http://www.youtube.com/watch?v=rdHH9KrceR0 If it posts then for now boot into the BIOS press F5 (Load Optimized Defaults) and F10 Save & Exit = yes.

If the PC is still stuck in some form of Standby then hold the Power switch for 5-10 seconds or if needed the Reset button. If the LED still gets stuck on 'red' then I'd re-seat both the 24-pin & 8-pin from the PSU.

Let me know.
August 8, 2012 11:42:15 PM

You beauty! Worked a treat. Thanks alot
Related resources
a c 717 V Motherboard
a b U Graphics card
August 8, 2012 11:54:56 PM

Cool! :sol:  And you're more than welcome!
a c 717 V Motherboard
a b U Graphics card
August 8, 2012 11:56:51 PM

IF you have an XMP memory kit then AI Overclocker -> XMP and Profile 1 should load by default, F10 Save & Exit = Yes. Then you'll be running optimized.
September 10, 2012 9:13:09 PM

My Sabertooth Z77 still doesn't POST. Tried clearing CMOS, updated the bios with the crashfree button and a USB thumbdrive. Still no sign of life.
!