Sign in with
Sign up | Sign in
Your question

Dataram RAMDisk Uninstall/Troubleshooting

Last response: in Memory
Share
August 9, 2012 8:44:04 PM

Howdy,

Okay, I have had issues before with this, but after my fresh install of Windows 7 Pro, thought I'd give it another try.

Operating System: Win7 Pro 64-bit
Program Install Directory: "C:\Program Files (x86)\RAMDisk"
First Attempt *.img Directory: "D:\RAMDisk\RAMDisk.img" (1st Extended Partition on Main Drive)

Full System Spec's:
================================
-- Mainboard: Gigabyte | GA-MA78LM-S2H | NB: 780G | SB: SB700 | BIOS Version: F11
-- CPU: AMD | Athlon II X4 630 | 1.425V
------ 2812-ish MHz (stock) / (O.C.'d to) 3500-ish MHz | FSB (O.C.) 250MHz (200MHz stock)
------ * Overclock just to get RAM timings corrected and stable.
-- RAM: OC-Z Technology | 2x2GB @ 500MHz (under clocked; times correct) | 1066MHz (stock; timings with MB incorrect)
------ 2.1V (Recommended) | Manual input of +.3V = 2.1V
------ Timings: 5-5-5-15
-- Video: Gigabyte | ATi Chipset | Radeon HD 5450 | GV-R545-1GI | 1GB DDR3 at 550MHz *ALL STOCK, NO OVERCLOCK*
-- HDD's: 3 Total | 500Gig [ 1 Primary & 4 Extended Part. ] | 320Gig [ 3 Extended Part. ] | 160Gig [ 3 Extended Part. ]
------ 500 Gig: Western Digital (WD5000AADS-00S9B0) Firmware 01.00A01
------ 320 Gig: Western Digital (WD3200AVJS-63B6A0) Firmware 01.03A01
------------ [Jumper setting: Power Up In Standby]
------ 160 Gig: Maxtor (STM3160215AS) Firmware 3.AAD
------------ [Jumper setting: Limit to 1.5GB/s]

Now, that was WAY more information than probably necessary; however, if you see something I could improve feel free to comment on that as well.

Situation:
================================
>> Installed Dataram RAMDisk; followed instructions seen on this OC-Z Forum Topic; however, after installation I was only allowed 2724MB in size.
------ (Location trying to use was HD1's 1st Extended Partition) So, I went ahead and started it after the settings were as instructed; however, my being dumb and all... I closed after it took what seemed like an eternity to "Verify driver install".

>> So, realizing how stupid this was to do, I got even dumber and tried to just uninstall the program. Which after doing that and rebooting, I noticed my Windows was saying my RAM usage was all the way up in the lower 90-97% range.

>> I then got mad, which is always the best way to problem solve, eh? I looked up the user manual which said to delete RAMDisk.sys found in system32\drivers folder.
------ Unable to find any RAMDisk.sys file. I instead deleted RAMDiskVE.sys, rebooted. No change in RAM usage readings.
------ Okay, so I used Windows Search to find any listings of "ramdisk" and found files in system32\DriverStore\FileRepository I was able to get rid of 1 of the 2 folders listed; however, one is still on my system... (ramdisk.inf_amd64_neutral_*HEX CODE*)

>> RAM usage was still through the roof a bit, so I turned to regedit and searched for ALL instances of "ramdisk".
------ I one by one deleted any instances I could find without Windows saying "Hey this could be bad <insert reason>" So, traces of it are still in the Registry.

So, I then went ahead and re-installed it, tried starting it and get the error that there is may not be enough memory; system log said that it was unable to Allocate Disk Memory, yadda yadda. Well, checked the RAM usage and it was back to the same thing. My next idea was...

Using Revo Uninstaller: I went and downloaded Revo (which if I remember correctly there was a waay better one I have seen someone suggest here before), just to see what traces it could find of it, which were just the Program Files folder and what was in it, useless.

So, here's where this long windedness comes to an end and I ask what all does RAMDisk do upon installing and loading driver, that would be stopping it from working ever again? Every time now that I try to install it my RAM usage jumps up around the end of it to ridiculous readings.

So, I'd like to use more recommended settings, but I also want to get this folder off my computer... I guess I could use a Linux Live CD, but any ideas as to getting this COMPLETELY off, all system changes and all? * Only 1 System Restore point which is from today and does nothing, it was created by Revo Uninstaller.

Any responses/ideas appreciated, gonna go start Verifier.exe and see what happens. :)  Thanks!

EDIT: Oh also there are quite a few instances of it in Windows\winsxs(\Manifests ; too).
a c 146 } Memory
August 9, 2012 9:01:20 PM

Install it again.

Go to disk management and see if the disk is there, u need to format it, use FAT32.
m
0
l
August 9, 2012 9:48:44 PM

Speedy Gonzalez over here, haha. :ange:  I will try it that way, so unformatted is NOT the way to go? Are there any other more preferred fully functional programs out there? I could've sworn I used to be able to get the RAMDisk to about 4 Gigs I think...

Also, don't remember it EVER taking so long to verify driver the last time I used this... It almost seems stuck... I'll go eat or something and let it sit here in the meantime, see what happens.

* Also, after doing what you said... I clicked "Load and Save" and left it defaulted, but when I click back to the settings everything is disabled and looks like "Unformatted" got checked? Also, currently RAM is sitting at 2.91GB pretty solidly (89% usage).
m
0
l
a c 146 } Memory
August 9, 2012 9:49:34 PM

Unformated will not show up in explorer.
m
0
l
!