Sign in with
Sign up | Sign in
Your question

New RAM not showing in task manager?

Last response: in Memory
Share
August 10, 2012 12:48:06 PM

Well basically, I installed another 2GB stick on top of my old 2GB making 4GB.

Anyway task manager says it only has 2GB on CPU-Z and everything else like DXDIAG says I have 4GB...


I mean surely if task manager isn't picking it up, it means that 2GB isn't being used or something, I'm confused
a c 347 } Memory
August 10, 2012 12:55:39 PM

Open the Resource Monitor as shown below and post the following:
Hardware Reserved
Available, Total & Installed

Q - What MOBO?
Q - What CPU?
Q - What RAM? ; please provide links to each stick/kit <or> screen shots of 'SPD' tab from CPU-z.

My initial assumption is the sticks are incompatible with each other and the BIOS disabled one or more sticks to prevent errors or your MOBO is using an exorbitant amount of RAM for an iGPU.

August 10, 2012 1:00:26 PM

well from the looks of it it says I have like 2.8GB, I am using windows 7 32bit, but surely I should have like 3.4GB, not 2.8?

Related resources
August 10, 2012 1:02:02 PM

Oh sorry, I'm using some OEM 2GB 333.3mhz RAM and then I just installed
1 dim of 2GB DDR2 800Mhz Kingston value RAM
August 10, 2012 1:05:47 PM

Why is edit disabled... really?

Further more:
DXDIAG seems to be showing that 1GB of the RAM is being used for my graphics card... that I don't want...

How could I put it back as system memory, I don't want some crappy extra 1GB ddr2 memory on top of my DDR5 gpu lol
August 10, 2012 1:08:41 PM

This might seem silly, but I've had issues with this before with client's computers and I resolved it by simply refreshing the Windows Experience Index.

With that being said, your resource monitor seems to be detecting everything correctly and shows that more than 2048MB are actually being utilized, thus the new stick seems to working despite the fact that task manager doesn't recognize it.

I believe Vista/Windows 32-bit versions also will report the full 4096MB as shown by your screenshot, but will only truly utilize 3.5~ like you had said.

I hope that helps some!
August 10, 2012 1:13:25 PM

Kind of confirms what I thought, don't suppose you know how to stop 1GB of it being used on my GPU?

Maybe then it will detect the full 3.5 instead of 2.8?
a c 347 } Memory
August 10, 2012 1:19:12 PM

iixwh3l4nxii said:
well from the looks of it it says I have like 2.8GB, I am using windows 7 32bit, but surely I should have like 3.4GB, not 2.8?

/DXDIAG seems to be showing that 1GB of the RAM is being used for my graphics card... that I don't want...
http://i46.tinypic.com/vh72i8.png

Okay all of the RAM seems to be working, and the majority of the RAM as I thought is being used in BIOS for the iGPU.

Simple, boot into the BIOS and change the iGPU Memory to something less then Save & Exit = Yes. Also, with a 32-bit OS you'll only be able to access between 3.0GB to ~3.5GB of RAM; this is an OS limitation. There are Apps that can recapture that loss but I really don't recommend them.
August 10, 2012 1:21:37 PM

To be honest I'm not sure, if you don't have a discrete/dedicated video card with its own memory, that sharing will likely be dictated at the hardware level. If that is the case, it will likely be located within your BIOS.

Someone else may know something I don't though so don't take that as the end all.
a b } Memory
August 10, 2012 1:21:59 PM

You cant stop the 1GB of addressable memory being shadowed by the gpu, all system memory is counted in the 32bit 4GB limit including graphics ram.

the only way around this is to upgrade to a 64bit copy of windows.
a c 347 } Memory
August 10, 2012 1:30:19 PM

The vast majority of the 1282 MB is dictated in the BIOS as 'iGPU Shared Memory' since you didn't list your MOBO I have no way of telling you exactly -- since every MOBO's BIOS is different and can call it something else.

Again. boot into your BIOS and change the value. IF again IF you have a Discrete GPU and your monitor is connected to it then use the lowest value e.g. 32MB~64MB and/or Disable if it's and option, and then in the Device Manager Disable the iGPU and reboot. This will reduce the shared iGPU memory to it's lowest possible value.
August 10, 2012 4:00:41 PM

No I do have a dedicated GPU, I use an ASUS GT 440 @ 1GB DDR5.

Anyway thanks for the help in general guys and I'll look into that bios thing.
a c 347 } Memory
August 10, 2012 4:10:23 PM

Duh what?! The ASUS GT 440 is a Discrete GPU. Discrete GPU means you've added a GPU vs iGPU being built in. :) 
a c 347 } Memory
August 10, 2012 4:14:08 PM

BTW - connect the monitor to the 'ASUS GT 440' otherwise it's sitting there doing nothing but burning electricity...
!