Sign in with
Sign up | Sign in
Your question

New build problems - hoping for advice

Last response: in Systems
Share
August 12, 2011 2:11:44 PM


Kit:
Gigabyte GA-Z68AP-D3 http://www.gigabyte.com/products/product-page.aspx?pid=...
Intel i7 2600K (using onboard graphics, not a discrete card)
Crucial C300 128gb SSD
8gb Kingston Value Ram
Windows7 Ultimate x64

System is running at standard speeds, not overclocked.
Main problems relate to:
Horrendous wake up times from sleep/hibernate
AHCI sata settings in Bios
Instability

I don't use this machine for gaming hence no graphics card and for the most part it's pleasingly fast but there are problems with it. The only 'tweaks' I have done are to allow all the cores/memory to be used when booting (through boot>advanced in msconfig), but the problems existed before that.

Firstly, this AHCI thing. Initially I did not realise this setting was necessary to get the full benefit of using a fast SSD as a boot disk and to enable the use of the TRIM function in Win7 so I had installed windows with it on the default of IDE, then found out about it afterwards. And also found that aside from a possible reg tweak to get round it, you can't change it once the OS is installed.

So I reinstalled the OS after enabling AHCI in the bios, expecting things to be slightly better all round. Not noticed any improvement I must admit but I have now got problems. When I plugged in the rest of my HDDs (normal Sata HDDs, not SSD like the boot drive) after getting the new OS up and running with AHCI enabled, it seems to go into a loop whereby I get the POST screen, then a message where I think the drivers install for AHCI (or something - sorry to be vague but the message is partly off screen and I cannot adjust it to see fully - only happens in AHCI mode though). Next it says "Loading operating system", then I hear a click from the piezo speaker and the pc reboots. It keeps on doing this loop.

So it seems as if AHCI does not like me having my other drives plugged in for some reason but as I understand it, having SSD boot and HDD additional drives is the most common setup people go for in general so this seems odd.

Second issue is that if I try to use Sleep mode, the machine won't resume. It just won't power up from the power on button.
To make it boot after putting it asleep I have to remove the power cord from the back then reinsert it and then boot.
I get the "Windows resume loader" screen then and it asks if I want to do a restore. Not sure about hibernate yet, although I notice after this failed sleep resume cycle that hibernate seems to have disappeared from the shutdown menu!

There is a gigabyte utility for quick boot which affects both the OS and the Bios somehow, and I have tried this set off and on but it doesn't seem to do much either way.
My laptop uses the same OS, is a much lower spec than this and resumes in 3 seconds, so why is it taking around a minute for this much more powerful machine to do the same?

I seem to recall a program that helps trace the boot process and show how long each bit takes, in order that causes of such problems can be investigated a bit better, but I can't recall the name. Boot something or other I think. Would that be worth trying, or would it not be suitable for a sleep cycle as opposed to reboot?

Third issue is crashes. I do a fair bit of video editing and often have many files open at the same time so when I build a machine this is one test that I like to do.
I've been trying this with between 6-10 small video files (mix of mpegs/avis), and they will play for a little while (a minute or two perhaps) then the machine freezes.

I've had task manager running when this happens and the cpu isnot even breaking a sweat when it crashes, and with tons of memory to spare, and also checked that cpu temperatures can be as low as 30C when it happens too.
That being the case I can't fathom why it would be doing this.

Sorry if any of these things are obvious or noobish stuff to you guys.
I've been building and fixing PCs for about 15 years now, but other than the odd bios setting and sometimes a bit of windows optimisation I don't usually tweak them that much in terms of performance once they're running satisfactorily. It's a while since I've built a new system so I'm a bit unfamiliar with some of the stuff I'm seeing in the bios on this new one.

Any help with these issues would be gratefully received thanks!
a b B Homebuilt system
August 12, 2011 2:31:22 PM

Try to isolate the problem to the SSD. If you have a spare sata drive (even old small one) then copy OS over to the spinning drive and see if system gets better. Do you have most recent firmware on the crucial drive and the MB ? Is your win 7 maintenance current -- that's where your ACHI device driver comes from. A new win7 install might not have all service. I'd also cross post over at crucial.

(I tried sandforce based F120 in thinkpad, never got it stable. I switched to slower intel 320, no problems.) Not sure if the crucial drive has known sleep problems, the intel does (power consumption) and the sandforce did (problems coming out of sleep, problems with time to init drive coming out of power off).

ACHI mode should be the normal operating mode with modern sata drives even without ssds. It is required (i think) to get the benefits of Native Command Queuing which helps spinning drives too.



m
0
l
August 12, 2011 7:43:14 PM

Thanks for the suggestions. That's very helpful.

When I get home later I'll check everything is up to date. Pretty sure the SSD has the latest drivers if nothing else.

I'll be pretty upset if it transpires that the SSD is source of sleep issues though since sleep is what I mostly use.

Good idea re' trying another drive. Will try to find one.
I'll say what's what once I've tried all this but thanks for the suggestions.
m
0
l
Related resources
a b B Homebuilt system
August 12, 2011 7:46:47 PM

aside: You may find that you can hibernate and come out of hibernation as quick as you can go into and come out of sleep with the SSD. For some things it's scary fast.
m
0
l
August 13, 2011 9:20:13 AM

Valid point yes.

Well I've made progress I think.
It wouldn't hibernate at all or sleep properly as it was refusing point blank to wake up.
This made me wonder if there was a PSU issue since it's a call from the power on switch/mobo to tell the PSU to wake up and it wasn't happening.

So I took a closer look and noticed that it smelled a bit that ominous smell of hot electronics! Swapped it out and things seem a bit better now.

Not quite there yet though. The hibernate works well but wakes up by itself so I'm guessing some wake on lan thing in the bios or in gigabyte's apps is responsible.

Sleep is similar, although it basically wakes straight up the very instant it goes off, but at least it is coming back up!

Any common causes for these symptoms other than wake on lan?
m
0
l
August 13, 2011 9:26:48 PM

Now I'm really getting somewhere!

Eventually after trying a ton of things that others were finding as sleep/resume problems (like wake on lan/allow device to power on settings etc), I found it seemed to be the drivers for my wireless mouse as I downloaded a new set and the problem has been fixed.

Sleep is almost instant, and resume takes about 2 seconds. Jackpot!


So the main problem now that I have is this issue with video.
What happens is that the machine locks up/hangs/freezes if I play more than a few video files at once. I tend to use mediaplayer classic from a Klite codec pack for watching or monitoring video files.

So I start one playing then gradually open more & more files, then it tends to be once I get to maybe 6-8 videos running (and CPU is hardly even moving at this point!) and the system hangs and needs a full reboot.
Nothing useful is saved into Event Viewer.

I've got the latest graphics drivers that I could find for the Intel HD graphics 3000 (part of the i7 cpu), and barely any resource is being used when this happens, so why is it fine with one or two files but not once it has a few more running?????

Really appreciate help with this one. If I get this fixed I'll be very happy with this new build!! :) 
m
0
l
August 14, 2011 8:09:45 AM

Think I found the issue at last. I tried a different output codec in media player and it seems to have done the job.

It was set on "EVR Custom Pres**" and I changed it to system default.
With this codec I had 13 videos running to test it and not a hint of bother (did this a few times), whereas with the EVR codec it was crashing the machine once I had half a dozen videos running, even though there was barely any resource being used.

Unscientific I know, but I tried swapping back & forth a few times and each time with EVR it crashed, but ran fine with default codec. EVR was actually the one that was set as default following installation of the klite 64 bit pack, so while I have no idea why it is a problem, I can imagine it might catch others out. Hopefully they'll find this post in a search and it may help.

Thanks for your suggestions anyway tsnor - system is behaving very well now after replacing PSU, updating mouse drivers, and sorting this codec.

I still can't get AHCI working right but the machine is running really well and actually boots faster anyway since it's not sticking the drivers on each boot so I can live with that. :) 
m
0
l
!