Sign in with
Sign up | Sign in
Your question

XFX 5870 problems

Last response: in Graphics & Displays
Share
June 9, 2011 3:38:35 PM

Alienware Aurora
i7 920
XFX HD-5870 1gb
500 gb 7200rpm HDD
9 gb ram

I recently got a XFX HD-5870 to replace my nvidia gtx-460 because i wanted to get eyefinity for a triple monitor setup. I pur in the card and everything worked fine for a month or two. Lately however ive had some odd problems with the graphics card. Every so often, it will switch between 1080p and some other resolution which is not native to my monitors. It is also blue screening my computer and crashing randomly. PLEASE HELP ME

More about : xfx 5870 problems

a c 546 U Graphics card
June 10, 2011 12:29:51 AM

Did you uninstall the nVIDIA graphics card driver before switching cards and installing AMD's graphics card driver?
m
0
l
June 10, 2011 10:57:18 AM

Yes i did, like i said it was working great for a month or so, but i tried reinstalling the drivers and it blue screened
m
0
l
Related resources
a b U Graphics card
June 10, 2011 1:34:30 PM

Use driversweeper to removed all Nvidia and AMD/ATI drivers and utilities, including CCC.

Then re-install driver.
m
0
l
a c 546 U Graphics card
June 10, 2011 3:25:57 PM

Also, don't allow Windows Update to update the graphics card driver. Always obtain the latest driver from AMD's website.
m
0
l
June 11, 2011 3:56:20 PM

It has the fan in the middle, does that revision have some problem with it?

Does driver sweeper cost money?
m
0
l
June 11, 2011 11:10:47 PM

Im gona try to explain this, I had 5870 also and sounds like same problem. Like does your computer when you first turn it on any day cycle multiple times before it actually goes into windows? And when you do make it into windows sometimes the screen changes colors or seems like resolution tries changing? Sometimes it freezes/blue screens and reboots? Takes about 15min till its "warmed up" and you dont have problems?
Idk let me know go into more detail if you can if im not describing it right.
m
0
l
June 13, 2011 12:45:31 PM

shata said:
Im gona try to explain this, I had 5870 also and sounds like same problem. Like does your computer when you first turn it on any day cycle multiple times before it actually goes into windows? And when you do make it into windows sometimes the screen changes colors or seems like resolution tries changing? Sometimes it freezes/blue screens and reboots? Takes about 15min till its "warmed up" and you dont have problems?
Idk let me know go into more detail if you can if im not describing it right.


This is exactly what is happening with my card
m
0
l
!