Sign in with
Sign up | Sign in
Your question
Closed

Is it possible to disable specific CPUs?

Last response: in CPUs
Share
November 11, 2011 4:44:58 AM

My computer is really unstable and only runs stably if I have turn 3 of the 4 cores off. In the bios I can't choose which core I turn off, and it doesn't look like msconfig gives me the option either. I want to run the computer with each core by itself to see if I have a bad cpu core, for I'm not sure if I'm having cpu problems or motherboard problems.

Also the cpu is an Intel Core i5 2400, and the motherboard is an AUSU P8H67-M EVO.

I ran the cpu under all 3 of prime95's tests far a total of about 14 - 16 hours each test, and the computer still ran (with all 4 cores active). I just want to be sure what it is before I go buying a new cpu or motherboard. I'm not sure if I tested the cpu long enough.

More about : disable specific cpus

a b à CPUs
November 11, 2011 5:35:12 AM

What kind of instability are you experiencing? Any specific error messages?

System instability can also be caused by (among others) faulty RAM, buggy drivers or overheating. I suggest you do some more testing before spending money on a new CPU or mobo.
Score
0
November 11, 2011 7:16:08 PM

The computer keeps locking up. The mouse doesn't move at all, and everything stops responding. It will no longer be on the network. Its like it blue screens but there is no blue screen. This happens mostly when the computer idles for a few hours. MOST of the time if I'm on the computer it won't lock up, but it is almost guaranteed to be locked up when I come home from school or wake up in the morning. Sometimes it doesn't lock up after those 2 situations, but that is really rare. When 3 of the 4 cores are off, the computer never locks up.
Score
0
Related resources
a b à CPUs
November 12, 2011 8:50:29 AM

This sounds more like a wake from sleep/hibernation problem. Make sure all your drivers are updated, and maybe try hibernating the PC instead of using sleep mode.
Score
0
a b à CPUs
November 12, 2011 9:09:54 AM

Whens the last time you did a bios update?
Score
0
November 12, 2011 5:41:16 PM

I updated the bios about a month and a half ago. Also, this computer is a server, so it is set to never go into sleep/standby mode.

(the server has no effect on the crashing)
Score
0
a b à CPUs
November 12, 2011 5:54:59 PM

Any devices attached that might be causing crashes? Wifi adapters, NIC's, etc?
Score
0
November 12, 2011 6:34:21 PM

I don't have any of those things attached. Just an ethernet cable, keyboard, mouse, monitor, power cable, speakers (splitter so both speakers and headphones are attached at the same time), and a usb extender, though nothing is plugged into it. Just for convenience.
Score
0
November 12, 2011 10:48:13 PM

I don't know if there is a permanent way to choose a specific core. But take a look at this article.

http://masolution.blogspot.com/2008/01/how-to-use-only-...

The best solution to do what you are trying is to probably set the affinity of each process to the core you want.

There are some command line tools to set this affinity as well - combining those with a vbscript to enumerate all running processes you can set affinity on all processes across the board. I did this for game performance once on a dual-core - set all apps to one core and the game to both, it did improve performance.
Score
0
a b à CPUs
November 12, 2011 11:02:38 PM

It's like one in a million chance you have a defective CPU. First consider other choices.
Score
0

Best solution

a b à CPUs
November 12, 2011 11:41:24 PM

MrZoraman said:
The computer keeps locking up. The mouse doesn't move at all, and everything stops responding. It will no longer be on the network. Its like it blue screens but there is no blue screen. This happens mostly when the computer idles for a few hours. MOST of the time if I'm on the computer it won't lock up, but it is almost guaranteed to be locked up when I come home from school or wake up in the morning. Sometimes it doesn't lock up after those 2 situations, but that is really rare. When 3 of the 4 cores are off, the computer never locks up.


Hmmm....

Well im looking around on the web for similar issues to what your having, and im finding a very big trail of problems with the motherboard...... Freezes, BSOD, ect.. 1 Person on the Asustek forum that even under Linux Mint 11 64 bits that it's doing the same thing.

http://vip.asus.com/forum/view.aspx?SLanguage=en-us&id=...

Maybe this will be a big help for you.

Quote:
First of all - my board is (rather) stable at the moment running the 1702 BIOS.

I am also using the 10.5.x Intel RST which is necessary for the mentioned BIOS version. At the moment I got C3 enabled and C6 disabled! (which raises minimum idle consumption of my sys from 32 to 37 watt)

I wanted to inform you about the release of a brand new BIOS:

1850 - BETA

Release notes for this BIOS: - improve system stability

This BIOS is released for nearly the complete portfolio of P67 and H67 Asus mainboards so I assume that a rather basic bug is fixed with this BIOS.

I'd advise all users with the freezing problem to try this BIOS and report back in this thread if it improves things. I'll do that, too.

Asus FTP: ftp://ftp.asus.com.tw/pub/ASUS/mb/LGA1155/P8H67-M_EVO/

File name is P8H67-M-EVO-ASUS-1850.zip


http://vip.asus.com/forum/view.aspx?id=2011050722260736...

Quote:
I already have the AI Charger disabled, however my system still reboots itself for no reason every now and then. Since I am using it as a HTPC, this is very problematic for the family. I disabled C1E, C3, and C6 on Friday and the system has been stable ever since, but only time will tell. The crash dump analysis is incoclusive, not pointing to any specific HW or Drivers causing the issue. The CPU Temp is now idling at 50 degC instead of 40 degC, so I would like to figure out ho to reenable the power saving features while maintaining stability...



Although i cant find anything about disabling a core on the cpu fixes it, but since the C1E, C3, can C6 are all difference states the MB puts the cpu in.... I'd say that your cpu is not the issue but the MB is.

http://www.hardwaresecrets.com/article/Everything-You-N...

I'd say try disabling all theses C-states and report back to us if it continues or not.
_
_
_
EDIT: If it doesn't, you may need to run a 32bit OS instead of a 64bit OS....

Quote:
Out of desparation, I installed 32bit Windows 7 and the system has been stable ever since. I can't for certain that one of the 64bit drivers was the cause, but at least my HTPC is now stable enough for everyday use.



Overall, the MB has issue (cant confirm if it's driver or Hardware) and there is no "true fix" for it as of yet from what im finding.


If i Find something else, I'll post it.
Share
November 15, 2011 12:37:19 AM

I turned on all 4 cores, and I disabled the C1E, C3 and C6. So far, no crashes. Its been a day now (2 standby phases (school and bed)), and so far no crashes. I hope this was the fix that I've been looking for. Will having these stats disabled have any negative effect on my system?
Score
0
a b à CPUs
November 15, 2011 12:49:23 AM

MrZoraman said:
I turned on all 4 cores, and I disabled the C1E, C3 and C6. So far, no crashes. Its been a day now (2 standby phases (school and bed)), and so far no crashes. I hope this was the fix that I've been looking for. Will having these stats disabled have any negative effect on my system?


To the system directly, no. Indirectly, It's make it consume more power than it would with those enabled.

Although that should be only a few watts, (10 to 20 from what im finding but could be more).

Well hopefully Asus has a "true" fix for you in the future than a "band-aid" fix for right now. Just keep us posted if anything happens. ;) 

Also forgot to mention this in my first post.

Welcome to Tom's Forums! :hello: 
Score
0
November 21, 2011 11:38:45 PM

Best answer selected by MrZoraman.
Score
0
!