Sign in with
Sign up | Sign in
Your question
Solved

Asrock Z77 Extreme4 HELP!!!!

Last response: in Motherboards
Share
August 11, 2012 5:27:53 PM

I know its long but it means alot to me if you atleast try to help

OK yesterday I got done building my computer I started it up "Reboot and Select Proper Boot Device" got through that error started installing windows 7 got a error in there tried again it installed because My HDD, SSD, or DVD drive didn't come with sata cable my mobo came with 2 when installing windows 7 i had my DVD drive and my ssd after that I switched it over to SSD and HDD got "Reboot and Select Proper Boot Device" again through opening and closing case and testing. I would turn it on and it would turn off then turn back on sometimes give me video and sometimes not, it was late gave up went to bed got up turned it on it worked i was using it got breakfast come back moved my mouse and turned off turned back on no video have not got it to work since. So i said screw it took out mobo and stuff just needed to boot to bios, didn't boot just black screen, cleared cmos nothing waited about 20 minutes came back turned it on Dr. Debug started to work again (before it would not) and turned off and back on nothing, got mad tried again and it worked!! got to bios, just for kicks and giggles turned off and back on it worked again.

So I guess my question is should I RMA? Do you think its faulty or just user error or will it work it out?

Any suggestions or help is welcome.

Specs:
i5-3570K
Asrock Z77 Extreme4
HAF X
Corsair TX650v2
Corsair H80
Corsair Vengeance 8GB 1600
OCZ Vertex 4 64GB
Western Digital 500GB Blue Caviar
ASUS DVD drive
ASUS Wireless Card

More about : asrock z77 extreme4

Best solution

a c 468 V Motherboard
August 11, 2012 9:51:13 PM

make sure your running the newest bios. there patches for cpu and video cards for that mb.
check that all the cables are on tight...most time when you get post/no post/post. it the power supply the on switch on the case is uses as a electrical switch. when presses a signal goes from the mb to a power line on the 24 pin atx plug and the power supply turns on. for your drive issues make sure the bios is set to achi mode not ide or raid. and that you have your ssd and drives on the intel ports of the mb. some mb have intel and another sata controller. also with new efi bios setting cd-rom or hard drive as the first boot device wont make the mb boot from hd or ssd. you have to under hard drives in the bios set the ssd or hard drive as first device.
Share
!