Sign in with
Sign up | Sign in
Your question
Closed

GTX 590 poor performance... come on...

Last response: in Graphics & Displays
Share
June 10, 2011 9:43:30 PM

Just bought my new $2600 computer, with a gtx 590, and am getting poor performance (as far as i'm concerned) with Just cause 2.
I use the NVidia "recommended" settings in the game for the gtx 590, and my frame rate is on average in the 50s, but on flower patches and grass, my frame rate drops to around 28-31, if not even lower... what the hell? according to benchmarks, and the "optimize your game" section in the nvidia website, the frame rate should average out to about 67... That is definetely NOT the case for my video card.

My system specs are:
Intel core i7 2600k overclocked to 3.8ghz (liquid cooled)
Asus Nvidia geforce GTX 590 (stock clock speed)
8gb of G.Skill Ripjaws RAM.

I'm extremely frustrated that my frame rate drops to so low in this game... What could the problem be? or is this frame rate normal?

EDIT:
I'm playing at my monitors native resolution - 1920x1200, fullscreen.
Some other settings:
Vsync off
AA set to 4x
Anisotropic filtering set to 16x
GPU water enabled

I have the latest drivers for my video card and my MOTHERBOARD is an asROCK p67 Extreme4.

a c 216 U Graphics card
June 10, 2011 9:52:28 PM

Can you post a screen shot of GPU-Z with both cores?

Also, are you playing in fullscreen or windowed mode?
Score
0
a b U Graphics card
June 10, 2011 10:07:45 PM

If you're using a monitor that's 60Hz and the framerate is at 60 for a fair amount of the time, it's not unrealistic to see framerates in the 50's a fair amount of the time.

The 28-31 stuff is more odd- is this for significant periods of time or is it a quick slowdown followed by higher framerates?
Score
0
Related resources
a c 155 U Graphics card
June 10, 2011 10:35:16 PM

That does seem low.

You should use some different games and benchmark utilities to see if those numbers make sense; find benchmarks online to compare your numbers to.

Sometimes you can get a low framerate because one of the settings like AA is cranked way up.

I assume that you have all the drivers for the:
- main motherboard chipset
- latest video card

Score
0
a c 216 U Graphics card
June 10, 2011 10:53:01 PM

Good question, what resolution does he play at? I just assumed it was under performing as if he compared to the same resolution, but that could very well not be true.
Score
0
June 11, 2011 12:50:34 AM

Thanks guys, for all your kind responses (: much appreciated

I'm playing at my monitors native resolution - 1920x1200, fullscreen.
Some other settings:
Vsync off
AA set to 4x
Anisotropic filtering set to 16x
GPU water enabled

I have the latest drivers for my video card and my MOTHERBOARD is an asROCK p67 Extreme4.

photonboy, i'm not sure what you mean by "the latest motherboard chipset"- is that downloadable software? how do i check if i have the latest?

bystander, could you explain what you mean by "a screenshot of GPU-Z with both cores"?

thanks again everyone (:
Score
0
a c 172 U Graphics card
June 11, 2011 2:55:49 AM

what power supply do you have. It is not uncommon to get poor fps if the psu cant keep up.
Score
0
a c 600 U Graphics card
June 11, 2011 3:29:31 AM

Hopefully its a decent power supply. Then it is essential to be using the latest drivers off the Nvidia website. We are now up to the 275.33 WHQL version. Also be sure to check the individual settings in the Nvidia Control Panel for anything that may be causing the problem, maybe SLI isn't enabled or you are on multi-display performance mode, or something similar.

After looking at benchmarks, it seems just about everyone is running the full 8x AA/16x AF and getting over 60 fps, and as much as 110 fps. I did, however, see a couple where they maxed out Just Cause 2 at 45 and 47 fps, so it's all over the place.
Score
0
June 12, 2011 4:53:36 AM

My power supply is 1000 watts.
Score
0
a c 216 U Graphics card
June 12, 2011 6:52:41 AM

If you could download and run GPU-Z, screenshot the first tab, then click on the 2nd GPU and screenshot that too and show us the results.
Score
0
a b U Graphics card
June 12, 2011 7:13:31 AM

try playing other games and see if the problem is actually hardware related
Score
0

Best solution

a b U Graphics card
June 12, 2011 8:06:47 AM

I know exactly what you are talking about.The problem is because of 2 reasons.You may have vsync enabled and you may have put shadows on high.Disable vsync and put shadows quality on medium.There is a weird bug in the game due to which when high shadows are enabled the game lags when there is a lot of grass or flowers on the screen.Also vsync in the game does not have triple buffering due to which when your cards frame rate dips even 1fps below 60 the game will cap your fps to 30.So disable vsync and put shadows on medium and that will solve your problem.The same problem happened on my gtx 275
Share
a c 172 U Graphics card
June 12, 2011 9:43:01 AM

DTsoy said:
My power supply is 1000 watts.

so is my vaccuumme cleaner. seriously, please tell us the specific make and model, not all 1000w PSU's actually preduce their labelled wattage.
Score
0
a b U Graphics card
June 12, 2011 9:53:18 AM

beltzy said:
If you're using a monitor that's 60Hz and the framerate is at 60 for a fair amount of the time, it's not unrealistic to see framerates in the 50's a fair amount of the time.



Not if Vsync is off.
Score
0
June 12, 2011 5:36:46 PM

Best answer selected by DTsoy.
Score
0
June 12, 2011 5:37:31 PM

celpas said:
I know exactly what you are talking about.The problem is because of 2 reasons.You may have vsync enabled and you may have put shadows on high.Disable vsync and put shadows quality on medium.There is a weird bug in the game due to which when high shadows are enabled the game lags when there is a lot of grass or flowers on the screen.Also vsync in the game does not have triple buffering due to which when your cards frame rate dips even 1fps below 60 the game will cap your fps to 30.So disable vsync and put shadows on medium and that will solve your problem.The same problem happened on my gtx 275



Celpas, i have no idea how you figured this out, but it solved my problem. I set shadows to medium and now i can turn everything up, even AA up to 16x, and get smooth gameplay all around :)  Thanks for your help everyone!
Score
0
a c 271 U Graphics card
June 12, 2011 6:15:14 PM

This topic has been closed by Mousemonkey
Score
0
!