Sign in with
Sign up | Sign in
Your question

Ubuntu Linux on Gateway 7510GZ

Last response: in Laptop General Discussion
Share
Anonymous
a b F Wireless
a b D Laptop
August 10, 2005 7:37:19 AM

Archived from groups: comp.sys.laptops (More info?)

I have installed Ubuntu Linux on the above laptop and trying to configure
the wireless Broadcom card. For the most part, I think I have the
software installed correctly.

The part that I can't figure out is how to turn on the wireless radio. On
Windows, I just use the Fn-F2 key combination. On Linux, this key
combination does not work or does not seem to turn power on to the
wireless card.

Any hints appreciated.

--
Frank
August 10, 2005 8:11:55 AM

Archived from groups: comp.sys.laptops (More info?)

What driver are you using for your Broadcomm chip? Broadcomm will not
release the drivers to the Linux community. I think the only options
you have are ndiswrapper - http://ndiswrapper.sourceforge.net/ or
Linuxant Driverloader - http://www.linuxant.com/driverloader/.
Ndiswrapper is free open source software and Driverloader is free for
30 days then $20 for the license. I had a Compaq with a Broadcomm
chip. I could not manage to get ndiswrapper to work but Driverloader
worked beautifully.
Anonymous
a b F Wireless
a b D Laptop
August 10, 2005 4:49:46 PM

Archived from groups: comp.sys.laptops (More info?)

"ross" <rossharold@gmail.com> wrote in news:1123672315.090471.197480
@g47g2000cwa.googlegroups.com:

> What driver are you using for your Broadcomm chip? Broadcomm will not
> release the drivers to the Linux community. I think the only options
> you have are ndiswrapper - http://ndiswrapper.sourceforge.net/ or
> Linuxant Driverloader - http://www.linuxant.com/driverloader/.
> Ndiswrapper is free open source software and Driverloader is free for
> 30 days then $20 for the license. I had a Compaq with a Broadcomm
> chip. I could not manage to get ndiswrapper to work but Driverloader
> worked beautifully.
>
I am using ndiswrapper and have used several different Broadcom drivers.
After installing the ndiswrapper module. I get entries in both syslog and
message log files that the card is recognized. The problem comes when I
tell it to scan for access points, etc, it comes back with nothing.

I believe the radio on the card is not coming on so that it can connect,
etc. I did find this web site:

http://rfswitch.sourceforge.net/

Which are a couple of kernel modules for turning on the radio on some
specific laptop modules. That site kind of hints that Gateway laptops use
a hardware switch and not a software switch to turn this radio on.

Of course, this Fn-F2 combination work under MS Windows but it could just
be a BIOS thing also. I have to boot Ubuntu using "noapic" or the laptop
locks up right after the boot process starts.

I had forgotten about the Driverloader program. I may try it just to see
if it will work. Thanks for the suggestion.

--
Frank
Related resources
Anonymous
a b F Wireless
a b D Laptop
August 10, 2005 4:49:47 PM

Archived from groups: comp.sys.laptops (More info?)

Frank Hahn wrote:
> "ross" <rossharold@gmail.com> wrote in news:1123672315.090471.197480
> @g47g2000cwa.googlegroups.com:
>
>> What driver are you using for your Broadcomm chip? Broadcomm will
>> not release the drivers to the Linux community. I think the only
>> options you have are ndiswrapper -
>> http://ndiswrapper.sourceforge.net/ or Linuxant Driverloader -
>> http://www.linuxant.com/driverloader/. Ndiswrapper is free open
>> source software and Driverloader is free for 30 days then $20 for
>> the license. I had a Compaq with a Broadcomm chip. I could not
>> manage to get ndiswrapper to work but Driverloader worked
>> beautifully.
>>
> I am using ndiswrapper and have used several different Broadcom
> drivers. After installing the ndiswrapper module. I get entries in
> both syslog and message log files that the card is recognized. The
> problem comes when I tell it to scan for access points, etc, it comes
> back with nothing.
>
> I believe the radio on the card is not coming on so that it can
> connect, etc. I did find this web site:
>
> http://rfswitch.sourceforge.net/
>
> Which are a couple of kernel modules for turning on the radio on some
> specific laptop modules. That site kind of hints that Gateway laptops
> use a hardware switch and not a software switch to turn this radio on.
>
> Of course, this Fn-F2 combination work under MS Windows but it could
> just be a BIOS thing also. I have to boot Ubuntu using "noapic" or
> the laptop locks up right after the boot process starts.
>
> I had forgotten about the Driverloader program. I may try it just to
> see if it will work. Thanks for the suggestion.

Open the config file for ndiswrapper and look for a line "radio 0" and
change it to "radio 1". This should turn on the radio.

Q
Anonymous
a b F Wireless
a b D Laptop
August 10, 2005 9:44:47 PM

Archived from groups: comp.sys.laptops (More info?)

"Quaoar" <quaoar@tenthplanet.net> wrote in news:HLednQoXZM8jk2ffRVn-
oA@comcast.com:

> Open the config file for ndiswrapper and look for a line "radio 0" and
> change it to "radio 1". This should turn on the radio.
>
I have searched the all of the ndiswrapper files I can find for the
above.

The closest I have come to are the *.conf files created under
/etc/ndiswrapper when the Windows drivers are installed. There are
several files there and they each have an entry like this:

RadioState|0

I read a previous posting earlier about changing all of these to 1 but it
did not help. Is there another config file I am missing?

Thanks.

--
Frank
Anonymous
a b F Wireless
a b D Laptop
August 11, 2005 2:11:07 AM

Archived from groups: comp.sys.laptops (More info?)

Frank Hahn wrote:
> "Quaoar" <quaoar@tenthplanet.net> wrote in news:HLednQoXZM8jk2ffRVn-
> oA@comcast.com:
>
>> Open the config file for ndiswrapper and look for a line "radio 0"
>> and change it to "radio 1". This should turn on the radio.
>>
> I have searched the all of the ndiswrapper files I can find for the
> above.
>
> The closest I have come to are the *.conf files created under
> /etc/ndiswrapper when the Windows drivers are installed. There are
> several files there and they each have an entry like this:
>
> RadioState|0
>
> I read a previous posting earlier about changing all of these to 1
> but it did not help. Is there another config file I am missing?
>
> Thanks.

That is the only solution I've found for a Broadcom xxx4306 that will
not start the radio. I think that there are several Broadcom chipsets
that are commonly referred to as xxx4306 that are in fact not exactly
the same. Consequently some work with ndiswrapper, and some won't even
power up, and the radio state change only works with a select subset of
the 4306 chipset. Your chipset might be a different version, but given
Broadcom's notoriety in Linux, your chipset might well also be deviant.

Wireless has been the only annoying feature of Linux in my limited
experience, and it's not getting much better. Given the extreme
annoyance of Broadcom in general, I would look for another, easily
configured, wireless card, or rather, chipset, which is the actual
controlling feature for success.

Q
Anonymous
a b F Wireless
a b D Laptop
August 12, 2005 4:58:48 AM

Archived from groups: comp.sys.laptops (More info?)

"Quaoar" <quaoar@tenthplanet.net> wrote in news:T6qdnblcPbhAUmffRVn-
gA@comcast.com:

> That is the only solution I've found for a Broadcom xxx4306 that will
> not start the radio. I think that there are several Broadcom chipsets
> that are commonly referred to as xxx4306 that are in fact not exactly
> the same. Consequently some work with ndiswrapper, and some won't even
> power up, and the radio state change only works with a select subset of
> the 4306 chipset. Your chipset might be a different version, but given
> Broadcom's notoriety in Linux, your chipset might well also be deviant.
>
> Wireless has been the only annoying feature of Linux in my limited
> experience, and it's not getting much better. Given the extreme
> annoyance of Broadcom in general, I would look for another, easily
> configured, wireless card, or rather, chipset, which is the actual
> controlling feature for success.
>
For the time being, I am going to not worry too much about it. I was able
to get the regular NIC card up and running. I even tried the driver from
Linuxant.com but that did not work.

Thanks for the help.

--
Frank
!