I7 920 skyrim fps

Just wondering what sort of fps people are getting on ultra with an i7 920?

I have 580 SLI but it seems i am completely cpu bound at the moment...just rolling into town on carraige at the beginning gives me fps in the high 20's low 30's which to all accounts seems cpu limited.

I have been debating buying a new cpu for a while now...but think i may now do it.

Just wondering if there is something else at play, or if people using the i7 920 are similarly bottlenecked by this game?

Thanks
18 answers Last reply
More about skyrim
  1. No way you need a new CPU. I have a 920 I7 as well and am running two 6970s in crossfire at 2560X1600 with ultra settings and everything maxxed and my cpu is only utilizing 50% of 4 cores. It sounds like you're having some other issues....either that or SLI has issues, not sure.
  2. I'm getting average 47 fps with i7 920 @ 2,66 ghz. I'm using radeon 4890 on high settings + beauty tweaks inside of .ini file and some mods. In my case, graphic card isn't good enough.
  3. it may be more of a software problem. Did you update or are u running any other software that might be slowing down your pc?
  4. Your processor is more than good enough for the game. Something else is causing the FPS to be low for you.
  5. davegl1234 said:
    Just wondering what sort of fps people are getting on ultra with an i7 920?

    I have 580 SLI but it seems i am completely cpu bound at the moment...just rolling into town on carraige at the beginning gives me fps in the high 20's low 30's which to all accounts seems cpu limited.

    I have been debating buying a new cpu for a while now...but think i may now do it.

    Just wondering if there is something else at play, or if people using the i7 920 are similarly bottlenecked by this game?

    Thanks


    I'm having the same trouble. When looking at a town from any distance my Fps drops considerably (from a steady 60FPS to sometimes under 30). I have an i7-920 overclocked to 3.6ghz, 12Gb of ram, a Samsung 470 120Gb SSD and two GTX 570s in SLi.
  6. Well it has to be pretty much a driver problem if you use SLi. I would wait for a drivers update if I were you.
  7. I agree with the sli/driver problem scenario - I'm running a single GTX 460 and don't have ANY of the latency problems mentioned here

    Time will pass and Bethesda will patch this soon enough...or someone will mod and fix it, either way just a matter of time
  8. pretty sure its not an SLI problem, as the same happens with a single gpu, and others with sandy bridge processors get perfect scaling in SLI.

    I've looked at cpu usage, and it never goes over 50% overall usage. If i limit the game to two cores, those two cores get about 100% usage and the fps stays the same. If i limit it to three, i get about 60% usage across the three cores. I've read it elsewhere, and it seems the game just doesn't scale over more than two cores (i.e the most the game can use is about 50% of my cpu).

    I'm not sure this is going to change...i think it is cpu limited, not because of my hardware but because the game is poorly coded. It does seem that half of a sandy bridge seems to suffice for ultra gaming though, whereas half of a first generation i7 isn't....

    I would just lower the settings and play, but as i've been thinking of getting a sandy bridge for a while, i might just take the plunge this christmas (the game will be patched - bugs being seemingly the only negative in reviews - and who knows, there may be some early mods to check out too)
  9. But my AMD Phenom II 945 X4 plays the game at high settings without a problem, why would an i7 even think about having trouble?

    The game is very well optimized, seems to perform like Fallout NV
  10. I'm having this problem also. i5-750 OC'd to 3.8ghz. ATI 5770 + 6770 Xfire. Ulta Settings Minus Shadows. When i first enter the game I get 25-30 FPS (using Fraps). If I alt tab out then alt tab back in, I'm getting 60 frames solid. Hope this helps
  11. Try disabling HT in the bios and report back please.
  12. Disable SLI or update drivers. My 6850 and a Phenom x3 @2.1ghz gets the fps you report. I'm the one who is CPU bottlenecking.
  13. popatim said:
    Try disabling HT in the bios and report back please.


    What is the HT?
  14. coleman318 said:
    What is the HT?

    Hyperthreading
  15. The problem wouldn't be HT enabled because the game just won't use those cores that it doesn't need or is coded to use.
  16. The game doesnt control HT, the system does and with it enabled it would automatically assign some tasks, be it game or system related, to those fake HT cores. Checkout BF3 HT micro-stuttering issues if you need examples.
  17. I really think it is an SLI or driver issue as I have no problem running the game with 8x AA 16x AF and every setting on ultra at 1920x1080 with a single 580 and a 920 @3.36 and with Vsync on I usually hold a steady 60fps and never had it drop below 45fps
  18. I fixed the only issue I've been having with the game (desktop crashes) by modifying the TESV.exe file to use 4GB of memory instead of a maximum of 2. I used to desktop crash every hour and now don't at all since I've done that. You can google how to do this if interested.
Ask a new question

Read More

CPUs Intel i7 FPS