Sign in with
Sign up | Sign in
Your question

Problem with xfx hd 6870

Last response: in Graphics & Displays
Share
June 11, 2011 4:39:33 PM

Hi, the parts of my new build arrived today and I put them together with ease, really impressed with the current design of components (it's been a while since I last build a system).

Everything seemed to be fine - until I tried booting up with the hd 6870. I tried HDMI and both DVI outs to my monitor capable of both (& HDMI to my TV). Nothing. "Ah well" I thought I'll just use the onboard (Z68 chipset/SB i5 2500k) gfx to get to BIOS to make sure everything is ok. Default settings on my gigabyte z68-ud3h board are 'only enable onboard if no addon card installed' or 'always enable onboard'. I set the only setting which seems to be the selector for default graphics card (I forget what they name it) to PCIe x16 where I have the card. Still nothing.

Before I ordered I asked the company where I bought the components whether the corsair tx650 would be man enough this setup and future Xfire and they said yes as there are two 6/8pin PCIe connectors. I (and apparently they) didn't however realise the 6870 would need both, but the fact the 650w PSU has two sugests to me that power isn't the problem. The only other components not mentioned are one SATA HDD, one SATA DVD-RW and three case fans.

Unfortunately I have no compatible system to test parts on. I have googled this problem and found others asking similar questions but no useful answers. I hope it's just something obvious I missed and would really like to get it working tonight.

Would really appreciate some advice from the experts here.

Thanks

Jon

More about : problem xfx 6870

June 11, 2011 5:08:33 PM

Try reseating your RAM, or placing them in different slots. I had the same problem with my first build, put everything together and fired up - but no video, so I switched the ram slots and it solved the problem.
June 11, 2011 5:33:29 PM

Just tried that, no joy. Tried again with no cables in the board's video outs and DVI plugged into the main 6870 DVI out. PC seems to post (obviously can't see but get a single beep) but then the motherboard leds all go off and system seems to hang. If I put the DVI lead into the onboard there's still no signal. This must be from my tinkering because before - with the same set up - it was booting fine just seemingly ignoring the xfx card and starting up the onboard :S

Sound like a faulty card?
June 12, 2011 1:08:24 PM

update:

I've reseated the ram in a few different configurations. I've tried the card in the PCIe x8 slot and changed the BIOS. Same problem.

I've reseated the card in the x16 slot and tried a number of different BIOS settings but no joy.


Any other advice? For further - info with the card in and running of the onboard there is no device being detected in windows so it seems the card isn't even starting up.

Unfortunately I can only contact the retailer on monday to see if it's a case of RMA. Would love to get it working today. Frustratingly I've found a number of people asking the same question but no useful anwers (one solution was because the poster had an insufficient PSU - I'm fairly confident that isnt the case here).
!