Closed Solved

RAM slots ASRock Z68 Extreme3 Gen3

Hello,

Built my first PC, with:
Intel i5 Sandy Bridge 2400k
Z68 Extreme3 Gen3
2x 4 GB G.Skills Ripjaw F3-12800cl9d-4gbrl
Radeon ATI 4890

in a Corsair Vengeance C70

When I initially installed the RAM, I got a debug code 55, no memory detected. This was true for both sticks when installed in 1/3 and 2/4/ I fiddled around with it a little, and got the computer up and running with 1 stick of RAM in slot B1. Both sticks worked in that slot, alone, but using one stick in either of the A slots led to a code 55. I wanted to make sure I explored every avenue before chalking it up to a faulty Mobo--are there any other possible explanations*?

*Technically, my particular model of RAM isn't on the list of approved compatible memory for the z68. But, since I got the computer to run with it, I think I'm ok.

Thanks!
3 answers Last reply Best Answer
More about slots asrock extreme3 gen3
  1. Best answer
    can you run a memtest with each individual stick of ram?...make sure that each stick is good to go and if thats the case you may just want to RMA the board...the 3rd slot could just be dead...you test one stick at a time
  2. Best answer selected by nocamarones.
  3. This topic has been closed by Nikorr
Ask a new question

Read More

ASRock RAM Motherboards