Sign-in / Sign-up
Your question

Asus P8B75-M LE Does not boot: RAM Failure

Tags:
  • Motherboards
  • Asus
  • RAM
Last response: in Motherboards
August 14, 2012 4:34:45 PM

This is the PC i'm trying to build:
MB: Asus P8B75-M LE
CPU: Intel G840
RAM: 2xDDR3 Corsair CMX8GX3M2A1333C9
GPU: ASUS GTS450 (the only piece retrieved from the old P4).

My problem is that i can't see anything:
the MB starts and flash the DRAM led. I tried removing both and only one of the dimm but without any result.
Tried also the "MemOK" button, the reset BIOS jumper, and then again the "MemOK button.
Still, all i have is a flashing "dram" red led. No output on the monitor (a VGA one, if this matter).

The GPU is still not mounted, so i'm using the onboard graphic port.

What should i try?

(sorry for my english, i'm italian)

More about : asus p8b75 boot ram failure

a b V Motherboard
August 15, 2012 3:45:56 AM

if its giving you the bad memory error with both sticks of ram then the best guess is that your memory is bad....do you have other sticks of ram you could try in the system to make sure? if not you could try to RMA your RAM and get a new set.
Anonymous
a b V Motherboard
a b Ĉ ASUS
August 15, 2012 4:27:27 AM

try one stick in each slot, if no work then try the other stick in each slot.

if that does not work, it is unlikely both sticks would be bad.
Related resources
a b V Motherboard
August 15, 2012 4:30:20 AM

^^ I think he said that he has tried only one at a time and it didnt help
Anonymous
a b V Motherboard
a b Ĉ ASUS
August 15, 2012 4:34:53 AM

since i didn't specifically see each one separately in every dimm, i wasn't going to assume it. no offense.
a b V Motherboard
August 15, 2012 5:02:02 AM

fair enough I guess I just made an assumption that since he knew to try one at a time he would know to try both of them as well
December 29, 2012 1:04:36 PM

hey all, here's probably the fix for "power up, no display, no beep, no post (cpu and chassis fan may or may not be spinning, mobo power LED lighted, MemOK LED lighted or not lighted or blinking erratically)" ... i fixed mine after changing the chassis fan connection (3pin connector) from connecting directly to PSU to connecting onto the mobo 3pin out for chassis fan.

this is really a funny one, cuz if u happened to have only 1 chassis fan, like the budget rig i was building, and u overlooked connecting that fan to the mobo but instead spotted that same connector on the PSU, then u would encounter this issue.

here's some story sharing my experience leading to fixing the problem. you could skip this portion onwards ... :lol:  ... i spent abt 2hrs figuring out what went wrong plus there were other possible uncertainties like re-using a 5-yr-old 390W psu which could be underpowered and discovering that the rams i bought were not in the compatibility list on both asus manual and corsair website. stripped everything down to only mobo and cpu connected to psu and yet problem persisted. so i took a nap, woke up, and started work on the 2nd rig using the asus p8h77-vle. got it done in about an hour including some cleaning and vacuuming since the 2nd rig is also re-using a 5yr old case and psu. powered up and got joy. so went back to work on the problem 1st rig. as i was trying to remove the mobo and resit it in the chassis, i realized that p8b75v had 2 chassis fan connector on the mobo that was unused. then i recalled the p8h77vle had only 1 chassis fan connector on the mobo and wondered how come i paid more for p8h77vle but got less. while assembling the p8h77vle, that chassis had 2 chassis fans and again i connected to the psu 3pin instead on the mobo. i was planning on going to the shop to get the adapter to convert the 4pin molex from the psu to 3pin. then i looked around the assu manual again to confirm that i didnt miss out on any connection and realized that there was a 3pin chassis fan connector on the mobo, so that saved me a trip down to the shop. and i guess this is important as the fan rpm is also being tracked and regulated by the mobo, not only the cpu fan. that was when i realized that maybe i should change the 3pin connection to the p8b75 mobo instead of direct to psu connector. powered up and heard 1 long beep + 2 short beeps = no dram detected = joy ... hearing a response beats hearing none ... and so that 1st rig got fixed, saving another trip back to the shop.
December 30, 2012 11:21:19 AM

here's another one to share ... the 1st rig p8b75 seemed ok but after a few power resets while testing out the rig, it went into eternal reboot, ie. powered on, fan spins, no post no display no beeps, then auto power off, then auto power on, fan spins and repeats. after tearing up the rig to isolate the problem, discovered that the casing pins for PwrReset seemed cranky. it must have shorted and the system keeps power cycling with no beeps, no display, no post. anyways, you could either try cleaning the contacts to solve the shorting, or, as i chose, leave it unplugged since i dun really need this pwrreset convenience. cheers!