Sign in with
Sign up | Sign in
Your question

Screen has purple tint

Last response: in Graphics & Displays
Share
June 12, 2011 7:17:56 PM

My screen has a light purple tint, well everything that should be white is almost neon purple. I've had this problem before and I've heard it might be the video card, it's a small black box on the bottom left back of the tower. If I have it pushed up (the box) against a shelf & turn the tower a certain way, it goes away. I just recently moved & can't seem to get the color to go back to normal, even when I try having that part in the same position. Just wondering if anyone knows what it could be or if I need something replaced. It's a Dell Dimension E310...thanks !!!

More about : screen purple tint

a c 130 U Graphics card
June 12, 2011 8:07:44 PM

Sounds like a cable issue to me. When you used to turn it just so something that wasn't quite lined up connected, I have had it do it with a pink tint before and a new cable fixed it for me.

Mactronix :) 
m
0
l
a b U Graphics card
June 12, 2011 8:48:46 PM

I also had this issue and just straightened some bent pins.
m
0
l
Related resources
December 4, 2011 6:50:10 PM

I had just installed a Asus ATI Radeon EAH5450, utilizing the HDMI port. The computer booted fine, and everything looked great up until just after the "Starting Windows" screen in Windows 7. Then when it came to my sign in and desktop everything had a pink/purple hue, and the display was being underscanned, and not filling up the tv. I scoured the net for a soulution but found absolutely NOTHING. Kind of irritating. I downloaded fresh drivers, and that still didn't help. Finally after going though every setting in CCC, (Catalyst Control Center) I discovered the Pixel Format setting. I changed it from 4:4:4 YCbCr to 4:4:4 RGB and that solved the problem. I then went to the Scaling Options tab and changed the Underscan/Overscan to 0% and it nicely filled up my screen.

Detailed solution.

1. Open CCC
2. Select Desktops and Displays from the Graphics dropdown menu.
3. Right Click your problematic display from the "please select a display" selection and select Configure
4. Tab over to the end tab and change the Pixel Format. Try going from YCbCr to RGB, thats what worked for me.
5. The Scaling options tab allows you to resize the screen to fit the display.
6. CCC could be built better to be more navigation friendly, but hey, who's perfect.

With that problem fixed, It was time to figure out why the audio over HDMI wasn't working. After installing more drivers for ATI Hi Def Audio, and still no fix, I decided to just go ahead and start from scratch by doing a system restore. Back to square one. But I figured that I knew how to fix the pink/purple and could zip through the reinstall of the graphics card quickly. So system restored, drivers installed, and guess what, no pink/purple problems this time. Weird. But still no audio.

Being extremely fed up, I re-opened the ausu box, pulled out the static proof bag and pulled my computer from the wall, ready to rip this darn thing out and send it back. But when I bumped the HDMI cable, I heard a noise through my speakers. It wasn't much, but it gave me hope. I then pushed the HDMI cable into the HDMI port alot harder than I though was necessary, and it went "Plunk". The HDMI Cable wan't seated properly. With that done, the audio worked fine. and I knew alot more about graphics cards.

I hope this will help others.

m
2
l
September 7, 2013 9:32:52 PM

This happen to me today also but I use a laptop acer 5950g hope u guys came up with a solution
m
0
l
a c 84 U Graphics card
September 7, 2013 10:35:53 PM

This thread is two years old!

In any case, check the control panel for you GPU and make sure the color channels are set correctly. Most notably make sure the green channel is not turned down.
m
0
l
September 8, 2013 10:39:22 AM

Thanks I'll try
m
0
l
October 21, 2013 5:49:10 AM

aberobert said:
I had just installed a Asus ATI Radeon EAH5450, utilizing the HDMI port. The computer booted fine, and everything looked great up until just after the "Starting Windows" screen in Windows 7. Then when it came to my sign in and desktop everything had a pink/purple hue, and the display was being underscanned, and not filling up the tv. I scoured the net for a soulution but found absolutely NOTHING. Kind of irritating. I downloaded fresh drivers, and that still didn't help. Finally after going though every setting in CCC, (Catalyst Control Center) I discovered the Pixel Format setting. I changed it from 4:4:4 YCbCr to 4:4:4 RGB and that solved the problem. I then went to the Scaling Options tab and changed the Underscan/Overscan to 0% and it nicely filled up my screen.

Detailed solution.

1. Open CCC
2. Select Desktops and Displays from the Graphics dropdown menu.
3. Right Click your problematic display from the "please select a display" selection and select Configure
4. Tab over to the end tab and change the Pixel Format. Try going from YCbCr to RGB, thats what worked for me.
5. The Scaling options tab allows you to resize the screen to fit the display.
6. CCC could be built better to be more navigation friendly, but hey, who's perfect.

With that problem fixed, It was time to figure out why the audio over HDMI wasn't working. After installing more drivers for ATI Hi Def Audio, and still no fix, I decided to just go ahead and start from scratch by doing a system restore. Back to square one. But I figured that I knew how to fix the pink/purple and could zip through the reinstall of the graphics card quickly. So system restored, drivers installed, and guess what, no pink/purple problems this time. Weird. But still no audio.

Being extremely fed up, I re-opened the ausu box, pulled out the static proof bag and pulled my computer from the wall, ready to rip this darn thing out and send it back. But when I bumped the HDMI cable, I heard a noise through my speakers. It wasn't much, but it gave me hope. I then pushed the HDMI cable into the HDMI port alot harder than I though was necessary, and it went "Plunk". The HDMI Cable wan't seated properly. With that done, the audio worked fine. and I knew alot more about graphics cards.

I hope this will help others.



This solution solved the problem. Thank you very much!
m
0
l
October 22, 2013 3:57:58 PM

aberobert said:
I had just installed a Asus ATI Radeon EAH5450, utilizing the HDMI port. The computer booted fine, and everything looked great up until just after the "Starting Windows" screen in Windows 7. Then when it came to my sign in and desktop everything had a pink/purple hue, and the display was being underscanned, and not filling up the tv. I scoured the net for a soulution but found absolutely NOTHING. Kind of irritating. I downloaded fresh drivers, and that still didn't help. Finally after going though every setting in CCC, (Catalyst Control Center) I discovered the Pixel Format setting. I changed it from 4:4:4 YCbCr to 4:4:4 RGB and that solved the problem. I then went to the Scaling Options tab and changed the Underscan/Overscan to 0% and it nicely filled up my screen.

Detailed solution.

1. Open CCC
2. Select Desktops and Displays from the Graphics dropdown menu.
3. Right Click your problematic display from the "please select a display" selection and select Configure
4. Tab over to the end tab and change the Pixel Format. Try going from YCbCr to RGB, thats what worked for me.
5. The Scaling options tab allows you to resize the screen to fit the display.
6. CCC could be built better to be more navigation friendly, but hey, who's perfect.

With that problem fixed, It was time to figure out why the audio over HDMI wasn't working. After installing more drivers for ATI Hi Def Audio, and still no fix, I decided to just go ahead and start from scratch by doing a system restore. Back to square one. But I figured that I knew how to fix the pink/purple and could zip through the reinstall of the graphics card quickly. So system restored, drivers installed, and guess what, no pink/purple problems this time. Weird. But still no audio.

Being extremely fed up, I re-opened the ausu box, pulled out the static proof bag and pulled my computer from the wall, ready to rip this darn thing out and send it back. But when I bumped the HDMI cable, I heard a noise through my speakers. It wasn't much, but it gave me hope. I then pushed the HDMI cable into the HDMI port alot harder than I though was necessary, and it went "Plunk". The HDMI Cable wan't seated properly. With that done, the audio worked fine. and I knew alot more about graphics cards.

I hope this will help others.



blkjck said:
aberobert said:
I had just installed a Asus ATI Radeon EAH5450, utilizing the HDMI port. The computer booted fine, and everything looked great up until just after the "Starting Windows" screen in Windows 7. Then when it came to my sign in and desktop everything had a pink/purple hue, and the display was being underscanned, and not filling up the tv. I scoured the net for a soulution but found absolutely NOTHING. Kind of irritating. I downloaded fresh drivers, and that still didn't help. Finally after going though every setting in CCC, (Catalyst Control Center) I discovered the Pixel Format setting. I changed it from 4:4:4 YCbCr to 4:4:4 RGB and that solved the problem. I then went to the Scaling Options tab and changed the Underscan/Overscan to 0% and it nicely filled up my screen.

Detailed solution.

1. Open CCC
2. Select Desktops and Displays from the Graphics dropdown menu.
3. Right Click your problematic display from the "please select a display" selection and select Configure
4. Tab over to the end tab and change the Pixel Format. Try going from YCbCr to RGB, thats what worked for me.
5. The Scaling options tab allows you to resize the screen to fit the display.
6. CCC could be built better to be more navigation friendly, but hey, who's perfect.

With that problem fixed, It was time to figure out why the audio over HDMI wasn't working. After installing more drivers for ATI Hi Def Audio, and still no fix, I decided to just go ahead and start from scratch by doing a system restore. Back to square one. But I figured that I knew how to fix the pink/purple and could zip through the reinstall of the graphics card quickly. So system restored, drivers installed, and guess what, no pink/purple problems this time. Weird. But still no audio.

Being extremely fed up, I re-opened the ausu box, pulled out the static proof bag and pulled my computer from the wall, ready to rip this darn thing out and send it back. But when I bumped the HDMI cable, I heard a noise through my speakers. It wasn't much, but it gave me hope. I then pushed the HDMI cable into the HDMI port alot harder than I though was necessary, and it went "Plunk". The HDMI Cable wan't seated properly. With that done, the audio worked fine. and I knew alot more about graphics cards.

I hope this will help others.



This solution solved the problem. Thank you very much!


This didn't help me a bit. I use an acer laptop and I was following it steps until it says end tab and I can't find the that configure the pixel display. I hope some one can tell me the name if the tab. Plz help me I've been struggling for 2 months already.

Thx
m
0
l
June 2, 2014 5:09:00 AM

This worked for me, Thanks!

aberobert said:
I had just installed a Asus ATI Radeon EAH5450, utilizing the HDMI port. The computer booted fine, and everything looked great up until just after the "Starting Windows" screen in Windows 7. Then when it came to my sign in and desktop everything had a pink/purple hue, and the display was being underscanned, and not filling up the tv. I scoured the net for a soulution but found absolutely NOTHING. Kind of irritating. I downloaded fresh drivers, and that still didn't help. Finally after going though every setting in CCC, (Catalyst Control Center) I discovered the Pixel Format setting. I changed it from 4:4:4 YCbCr to 4:4:4 RGB and that solved the problem. I then went to the Scaling Options tab and changed the Underscan/Overscan to 0% and it nicely filled up my screen.

Detailed solution.

1. Open CCC
2. Select Desktops and Displays from the Graphics dropdown menu.
3. Right Click your problematic display from the "please select a display" selection and select Configure
4. Tab over to the end tab and change the Pixel Format. Try going from YCbCr to RGB, thats what worked for me.
5. The Scaling options tab allows you to resize the screen to fit the display.
6. CCC could be built better to be more navigation friendly, but hey, who's perfect.

With that problem fixed, It was time to figure out why the audio over HDMI wasn't working. After installing more drivers for ATI Hi Def Audio, and still no fix, I decided to just go ahead and start from scratch by doing a system restore. Back to square one. But I figured that I knew how to fix the pink/purple and could zip through the reinstall of the graphics card quickly. So system restored, drivers installed, and guess what, no pink/purple problems this time. Weird. But still no audio.

Being extremely fed up, I re-opened the ausu box, pulled out the static proof bag and pulled my computer from the wall, ready to rip this darn thing out and send it back. But when I bumped the HDMI cable, I heard a noise through my speakers. It wasn't much, but it gave me hope. I then pushed the HDMI cable into the HDMI port alot harder than I though was necessary, and it went "Plunk". The HDMI Cable wan't seated properly. With that done, the audio worked fine. and I knew alot more about graphics cards.

I hope this will help others.



m
0
l
June 17, 2014 7:52:37 PM

aberobert said:


Detailed solution.

1. Open CCC
2. Select Desktops and Displays from the Graphics dropdown menu.
3. Right Click your problematic display from the "please select a display" selection and select Configure
4. Tab over to the end tab and change the Pixel Format. Try going from YCbCr to RGB, thats what worked for me.
5. The Scaling options tab allows you to resize the screen to fit the display.
6. CCC could be built better to be more navigation friendly, but hey, who's perfect.




After updating my AMD GPU driver from the version provided by the manufacturer (Asus) to the AMD official version, I had just exactly the same screen tint problem alike, and solved it with CCC with a different approach. Being unable to find the mentioned "Pixel Format" section in the latest version of CCC (v 14.4, published on April 17, 2014), I tried simply checking the box of "Use Extended Display Identification Data (EDID)" and everything went back to normal. Details below:

1. Start your AMD Catalyst Control Center (CCC)
2. At the left column, go to "My VGA Displays" and open the tab"Display Color (VGA Display)" there.
3. At the right side main columnm, find "Color Temperature Control" and check the box of the option "Use Extended Display Identification Data (EDID)"
4. Click "Apply" at the right-down corner.

Hopefully this would help.

by Pallas Landan., June 18, 2014.
m
0
l
!