Sign in with
Sign up | Sign in
Your question

GTX 590, Just cause 2 does not use both GPUs... WHY??

Last response: in Graphics & Displays
Share
June 12, 2011 10:36:18 PM

I get pretty low frame rates for a computer running a GTX 590, and one day i decided to disable multi-gpu mode to see how just cause 2 would be affected - I did not notice any significant performance drop, the game played relatively similar when i set the computer to single-gpu mode rather than dual-gpu mode.

I don't understand WHY this is happening because the game has an SLI profile in the nvidia control panel... So it should theoretically use both GPUs...

My specs:
Asus Nvidia gtx 590 3gb (dual gpu, 1.5gb each)
Intel core i7 2600k overclocked to 3.8 ghz (liquid cooled)
8gb G.Skill ripjaws RAM
1000Watt PSU

Game settings:
Shadows set to medium
AA set to 8x
Vsync off
Everything else maxed out

Can anybody help me out? :( 

More about : gtx 590 gpus

a b U Graphics card
June 12, 2011 10:59:28 PM

I would try newer or different drivers, some are optimized for just cause 2 some just plain suck at it. Take the beta drivers for instance, which in the Witcher 2 would cause you to get severe lag and then they fixed that in the main drivers that came out the week after.

If that doesnt work, i would do this: Enable single display performance mode, force alternate frame rendering 1 or 2, enable multicore support on instead of auto, and for power mode I would set to full power.

On my 470's i get about 100 fps with tessellation on and on my other build with a 5870 and a cheap amd i get about 60-70 fps on maxed settings.

June 13, 2011 12:32:53 AM

mightymaxio said:
I would try newer or different drivers, some are optimized for just cause 2 some just plain suck at it. Take the beta drivers for instance, which in the Witcher 2 would cause you to get severe lag and then they fixed that in the main drivers that came out the week after.

If that doesnt work, i would do this: Enable single display performance mode, force alternate frame rendering 1 or 2, enable multicore support on instead of auto, and for power mode I would set to full power.

On my 470's i get about 100 fps with tessellation on and on my other build with a 5870 and a cheap amd i get about 60-70 fps on maxed settings.




I'd rather not downgrade my drivers :p  I have AFR set to 2, i have single display performance mode on, but i don't know how to enable multicore support or how to set power mode - could you show me how to do that?

Thanks for your help, mightymaxio :) 
Related resources
a b U Graphics card
June 13, 2011 12:56:53 AM

AA on 8x? I can max everything out with AA on full (32xQ) with V-Sync off, and I get 40-50 fps on my GTX 560 Ti... So up the AA! =)
June 13, 2011 2:50:31 AM

amk-aka-Phantom said:
AA on 8x? I can max everything out with AA on full (32xQ) with V-Sync off, and I get 40-50 fps on my GTX 560 Ti... So up the AA! =)


then you clearly are not experiencing the problem that i am :( 
a b U Graphics card
June 13, 2011 4:42:31 AM

Make sure you have your card set in sli mode, Should be under Set SLI and PhysX configuration. I cant say for sure because its been a while since i had my 7950gx2 but i do remember you have to enable SLI through that menu choice under 3d settings list. Then under SLI rendering mode select force alternate frame rendering 1 and under power management mode choice prefer maximum performance these would be under global settings under manage 3D settings.

The one for the processor is called threaded optimization, make sure you have that on instead of auto. Also turning on triple buffering may smooth out lag spikes as well as increase your FPS in some locations.

If you cant find the Power management mode you may have a different set of drivers than the normal ones.
!