Sign in with
Sign up | Sign in
Your question
Solved

XFX HD 5850 woes...

Last response: in Graphics & Displays
Share
June 13, 2011 1:00:38 AM

Let me begin this, unfortunately, long story by sharing my computer specs.

AMD Phenom II x4 955 Black Edition
XFX HD 5850 1 gig DDR5
4 gigs Corsair DDR3 XMS 1333MHz
ASUS M4A88TD-V EVO/USB3
1 TB Western Digital Caviar Black
Ultra LSP 750W
HAF 912 Case with 4 fans, 2 intake 2 out.
LG 32in 1080p HDTV connected by HDMI

So I built this computer on my birthday, May 16th. I started ordering parts in the middle of April as I got the money and my family bought me the final components I needed for my birthday. After putting it together there were no problems. The video card was recognized immediately and no driver problems once I found the hotfix. So far so good with any games I tried to play.

I bought The Witcher 2 last week and played it through the prologue with no issues. Once I started the actually game my screen started to flicker and then freeze. I thought it was a heat issue, so I checked the temps of everything and there wasn't a single problem. My GPU didn't go over 55c and everything else was at perfectly acceptable temperatures. I fiddled with drivers, checked google, and asked as many of my friends as I could to try and figure out why there was flickering and freezing. I then started to flicker and crash to desktop with the display driver stopped responding error. I reset my GPU, flashed the BIOS, tried different drivers, and did everything else I found on the internet to no avail.

As I tried the Witcher 2 again it flickered and froze again, but my computer restarted. After the restart I didn't have any display on my screen. It was just black with nothingness. After a couple restarts and fiddling I noticed that it was pretty evenly split between black screen and no signal bouncing around the screen. I switched to onboard after taking out the HD 5850 and it worked fine. Now when I put the 5850 in I get mostly no signal with the occasional black screen. If I try onboard with the 5850 in, it doesn't display anything. I've tried disabling the 4250 onboard in safe mode, the BIOS which just changes the order, used driver sweeper, and everything else I could find since 7PM last night. I went out and bought a new HDMI cable thinking maybe my cheap one was failing on me, but it has not done anything different. I don't have a straight DVI or VGA cable to try either, but I can pick one up tomorrow if you guys think that will change anything.

The fan on the GPU turns on to regular speed, but displays nothing. If the card died I am SOL because it's past the 30 day return for Tiger Direct. If the card died I'd really just like to know so I can move on and just get a 6850.

I'm sorry for the novel and I'm sure I left something out, but any suggestions are welcome at this point. I am ready rip my hair out and make the 5850 a paper weight and get a 6850.

P.S. The BIOS does not show PCIe for primary display adapter, only PCI. I don't know if my PCIe slots died (both of them) I'll just quit. Blah blah blah I'm done for now. I'll keep checking hoping for some help

More about : xfx 5850 woes

June 13, 2011 3:50:23 AM

I'm about to call it a night, I just wanted to bump this so maybe, just maybe, someone can offer some advice. I'm gonna try and take it to a local computer shop tomorrow if I can't figure it out or find any other help.
m
0
l
a b U Graphics card
June 13, 2011 5:28:45 AM

Best bet is to test the card in another computer; if the card is bad, the symptoms should follow the card....
m
0
l
Related resources

Best solution

a c 173 U Graphics card
June 13, 2011 7:22:24 AM

those crappy ultra psu's cause issues like this too, have seen it before.
Share
a c 214 U Graphics card
June 13, 2011 7:29:22 AM

It should automatically switch from the On board to the GPU.The PCI is the GPU.

Is your 955 O.C. at all?

Witcher 2 is a very very CPU demanding game.I've seen an i7 975 @ 4ghz with 4 GTX480's get bottlenecked to the 30's.An i7 975 @ 4ghz is way more powerful than a 955.

I suggest lowering the graphics settings and trying again.It's possible that the restart was because it locked up under such a heavy load.But the other symptoms of a black screen might mean it's the graphics card.Try lowering the graphics settings and trying it again.If it does it again then i'd say it's the card and RMA it.
m
0
l
June 27, 2011 6:09:08 PM

Best answer selected by rmcron5296.
m
0
l
a c 173 U Graphics card
June 28, 2011 2:14:48 AM

so i guess it was the psu?
m
0
l
!