Solved

How to select wireless (has Internet) over wired (no Internet)

Hello,

I have two routers at home.
One is connected to the Internet (wireless), the other is not.

I am connected wirelessly to the one with Internet and I am wired to the other (no Internet).

How do I get my computer to prioritize the wireless connection to maintain Internet access? Currently, when I connect the LAN cable, I get disconnected over the Internet. It is as if it is trying to channel the Internet traffic to the wired connection without the Internet.

I only want to use the wired connection just to connect to a specific device in the other network, so I'll just input the address of that PC directly.

I'm using Windows 7.

Switching to wired on the one with Internet is not an option.

Thanks!
12 answers Last reply Best Answer
More about select wireless internet wired internet
  1. Best answer
    The reason this is happening is that both network connections have a default gateway. But Windows only recognizes one as the default gateway (it wouldn't be a default if it didn't, right?). But unfortunately, as you suspected, the wired connection presently has precedence over the wireless connection.

    Go to Start (or a DOS prompt), type "ncpa.cpl" (no quotes), and hit Enter. On the Network Connections dialog, hit Alt (to expose the menu bar), go to Advanced->Advanced Settings, and you’ll see a list of network connections. Make sure the wireless is listed first. Save and reboot.
  2. eibgrad said:
    Go to Start (or a DOS prompt), type "ncpa.cpl" (no quotes), and hit Enter. On the Network Connections dialog, hit Alt (to expose the menu bar), go to Advanced->Advanced Settings, and you’ll see a list of network connections. Make sure the wireless is listed first. Save and reboot.


    Thanks for the reply. I tried this earlier this morning but unfortunately, I could not make it work. From the following order:

    1. Wired
    2. Wireless
    3. Remote (no idea what this is)

    I swapped to make Wireless on the top of the list, rebooted, but still the wired connection took precedence. In the following:

    My computer --- wired to router --- Other computer
    |----- wireless to router --- modem --- Internet

    In both cases, I can connect via IP address to the other computer and wireless router but I could not access the Internet.

    I searched more about my problem and encountered something about the Default Gateway. It involved unchecking the automatic metrics setting and assigning a lower number metric for the wireless and the higher number metric for the wired connection. Although this made me connect to the Internet, I could not access the other computer.

    I was wondering if you might have other ideas? Thanks!
  3. We're at that point where I need to see how the PC's configured. I’ve been making several assumptions about default gateway IP, subnets, etc., and maybe those assumptions are wrong.

    Go to Start, and in the search input field, type "cmd" (no quotes), and hit enter. In the command window, type "ipconfig /all > temp.txt" (no quotes) and post the file's contents here.

    And btw, let’s go back to the original configuration as well, before you made any changes. If you make too many changes from the defaults, and I 'm not aware of them all, it will make it even more difficult.
  4. Hi,

    I've got an acer notebook. When there is a wifi connection my LAN port isn't working :)

    Dream situation for you but it wasn't for me I wanted to get Lan rather than Wifi.

    In fact I went to the Device manager->Network Adapters Advanced TAB, and there was an option to select which one you want first. Wifi or Lan..

    Hope it helped. I'll try to get a screenshot when I get home.
  5. eibgrad,

    Since this appears fairly recent, I thought I might tag along on this one. I'm currently using a WLAN for the internet connection. When I plugged in another router (another wireless router I am configuring), the internet connection ceased to function, presumably due to windows 7 prioritizing the wired connection. Removing the cable immediately restored connectivity.

    Looking at the network configuration as described, I see the above. wired connections were already below the wireless ones, (though I did move the virtual wireless 3 connection below the 2, something I don't imagine is significant here.) In any case, this provided no route to solve the problem.

    An image of the current settings:



    Checking settings using using ipconfig (with both connections established) provides the following data:


    Windows IP Configuration

    Host Name . . . . . . . . . . . . : computer
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) WiFi Link 5100 AGN #2
    Physical Address. . . . . . . . . : XXXXX
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IPv4 Address. . . . . . . . . . . : 192.168.1.129(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Wednesday, October 27, 2010 4:26:30 PM
    Lease Expires . . . . . . . . . . : Thursday, October 28, 2010 4:26:30 PM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 192.168.2.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Wireless LAN adapter Wireless Network Connection 3:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
    Physical Address. . . . . . . . . : XXXXX
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) 82567LM Gigabit Network Connection
    Physical Address. . . . . . . . . : XXXXX
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IPv4 Address. . . . . . . . . . . : 192.168.1.134(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Wednesday, October 27, 2010 5:12:00 PM
    Lease Expires . . . . . . . . . . : Thursday, October 28, 2010 5:15:09 PM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 192.168.1.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Bluetooth Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
    Physical Address. . . . . . . . . : XXXXX
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes


    Maybe I can find some help with this, or at least it might provide another data point for the other person's problem. If you or anyone else has anything useful, I'd quite appreciate it.
  6. Best answer selected by Decollete.
  7. First, eibgrad was right about the gateway,

    You should configure one of your router on 192.168.2.1 and all connected devices 192.168.2.x

    when you plug your Lan cable he's got to similar gateway to send to which one to choose...

    Second thing is about the priority,
    I took a screenshot, I hope it will help you


    Go to System, device manager, select your LAN network adapter, properties, and in advanced, you should find the of options u are looking for.
  8. For the Ethernet simply give the Static IP whatever you need it to be, or is assigned by your router. Except, do not fill in the gateway.
    Automatically, Wireless will definitely access the Internet, Since it can reach its gateway, and wired Ethernet does not have any gateway, no attempt will be made to connect to internet.
  9. I found this on another website and it worked for me:

    "When more than one network connection is available, Windows uses the one with the lowest metric value. By default, it automatically assigns a metric value based on the network connection's rated speed. See An explanation of the Automatic Metric feature for Internet Protocol routes .

    To force Windows to use a specific network connection, assign a metric value to each one, giving the lowest value to the desired connection:

    Open the Network Connections folder (Start > Run > ncpa.cpl)
    Right click the desired connection.
    Click Properties > Internet Protocol Version 4.
    Click Properties > Advanced.
    Un-check "Automatic metric".
    Enter a number between 1 and 9999 for the "Interface metric"."
    Manually set LAN to a larger integer than the wireless
    Ex: LAN [interface Metric: 3 ], wireless [interface Metric: 2 ]

    http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/wired-and-wireless-connections-on-the-same-windows/ee40d9a6-297b-46d4-b5c8-db57d927b62e
  10. Decollete said:
    Hello,

    I have two routers at home.
    One is connected to the Internet (wireless), the other is not.

    I am connected wirelessly to the one with Internet and I am wired to the other (no Internet).

    How do I get my computer to prioritize the wireless connection to maintain Internet access? Currently, when I connect the LAN cable, I get disconnected over the Internet. It is as if it is trying to channel the Internet traffic to the wired connection without the Internet.

    I only want to use the wired connection just to connect to a specific device in the other network, so I'll just input the address of that PC directly.

    I'm using Windows 7.

    Switching to wired on the one with Internet is not an option.

    Thanks!
  11. Worked for me. thanks!
Ask a new question

Read More

LAN Wireless Connection Internet Networking