Sign in with
Sign up | Sign in
Your question

Only allow a magic packet to wake the computer

Last response: in Networking
Share
October 8, 2010 11:38:17 PM

Hey guys,

Having a wee issue at present surrounding WOL. I got an iphone app called iWOL which allows me to wake up my pc over the net. After setting up the necessary port forwarding etc I gave it a go but it didn’t work. After some mucking about I found out that unticking the "only allow a magic packet to wake the computer" option in my network card properties solved the problem and I could now wake up the PC over the net.

However after the initial power up and shut down I tired again to see if it was working flawlessly but alas nothing happened the 2nd time. When I booted the machine up normally I went to the card properties again to check if everything was still the same. However upon going into the settings I found that the "only allow a magic packet to wake the computer" box had reticked itself.

Now I tried a number of times to untick this and reboot etc and every time I did it the setting would retick itself. Has anyone got any idea why this would happen and how to solve it? Id prefer this option remained unticked so I could use the iWOL app freely and with trust that my computer will turn on when I use it.
October 9, 2010 12:18:20 AM

I don't know why it won’t allow you to change that option permanently (maybe there’s a conflict w/ the BIOS WOL setting, esp. if it's a motherboard ethernet port), but in my experience, you probably want that option enabled unless that’s the only PC on your network. Without it, almost ANY network traffic will wake the PC (incredibly annoying). And that's virtually impossible to avoid unless the PC is connected directly to the modem (even then I’m not so sure).
October 9, 2010 9:23:03 AM

Yeah thought that might be the case but the pc is the only cabled one in the house so hopefully wouldn't have too much bother with that. It is a motherboard Ethernet bur I checked the bios and the settings are pretty basic like "allow pc tonne woke with pci dev ice" and that's it! Should I try a separate network card see if that works or has anyone else got a different solution to how to wake a pc via iPhone via a router that's obviously not sending the magic packet through correctly?

Ps i would use dd wrt but sadly it's a dsl router :( 
October 9, 2010 1:41:29 PM

If by "dsl router" you mean one of those combo dsl modem+routers, you can typically place the device in bridge mode (essentially demoting the device to only a modem) and use your own dd-wrt router. At least then you can do whatever you want wrt routing rather than being limited by the ISP's solution.
!