Sign in with
Sign up | Sign in
Your question

Stuttering with 6870 crossfire

Last response: in Graphics & Displays
Share
June 15, 2011 3:11:14 PM

Hi, I have several problems. I'll list them in order of worst to least important. First. In amd overdrive, I only see the voltage and temp of gpu 0 and gpu 2 not gpu 1 or 3 (1&3 are the second card I've deduced.) also, in crysis 2, when xfire is disabled i pull anywhere from 50-65 fps with about 95%+ load on the main card. With xfire enabled, I get about 50-65 fps with about 85% load on each card. For 85% per card, shouldn't I have more fps? And finally, when xfire is enabled in crysis 2, the 50+ fps I get is literally UNPLAYABLE. I cannot play it and retain my sanity. It feels like 20 fps max. Please. Help me in any way you can. It is greatly appreciated.
June 15, 2011 3:29:21 PM

Just a little further info, I just did a test with each card in slot one and each card appeared exactly the same. They both got 39 fps in furmark with the same settings. There was a small (but noticeable) amount of stuttering in furmark. I will try testing with slot 2.
m
0
l
June 15, 2011 3:41:11 PM

Hey, thanks. I checked each card in each slot. In each slot they each get 39 fps. The cards are flawless. I'm going to check if it's a problem with the cpu.
m
0
l
Related resources
a c 128 U Graphics card
June 15, 2011 3:52:20 PM

Quote:
crossfire aswell as sli have these issues.
sometimes a high cpu overclock can iron it out or its just bad bugs with games.

I had these issues when I ran with a crossfire setup. I switched to an SLI setup at the end of February and haven't had the stuttering problem since. There's a video out on youtube demonstrating this stuttering with a 6990 in crysis 2.

I had the stuttering in BFBC2 and MOH when I ran with crossfire too.
m
0
l
June 15, 2011 4:26:54 PM

I have it in lost planet 2 as well... it seems when i return my cpu to stock though, I get less of it... hmm.
m
0
l
a c 128 U Graphics card
June 15, 2011 6:31:11 PM

You're likely producing a few less FPS with the stock clock. Makes sense that there's less stuttering.
m
0
l
a c 172 U Graphics card
June 16, 2011 3:24:12 AM

enable tripple buffering and vsync. not sure how to do that with ATI cards, but if you can force tripplebuffering that should remove some stuttering.
m
0
l
a c 106 U Graphics card
June 16, 2011 3:33:39 AM

Uninstall the drivers, run driver sweeper, and then reinstall the drivers. I've had to do this both times I went Crossfire. Seems like other people don't though -_-, but try it and see if your problems go away. Also, make sure both cards are using the same BIOS. I had to update the BIOS on my older 5870 when I dropped in the new one to get rid of some strange issues in a few games.
m
0
l
a c 128 U Graphics card
June 16, 2011 9:36:56 AM

megamanx00 said:
Uninstall the drivers, run driver sweeper, and then reinstall the drivers. I've had to do this both times I went Crossfire. Seems like other people don't though -_-, but try it and see if your problems go away. Also, make sure both cards are using the same BIOS. I had to update the BIOS on my older 5870 when I dropped in the new one to get rid of some strange issues in a few games.

This is definitely necessary with the AMD cards. Each time you physically add/remove/change your card configuration, you need to uninstall, driver sweep and re-install the drivers.
m
0
l
a c 128 U Graphics card
June 16, 2011 11:32:48 AM

iam2thecrowe said:
enable tripple buffering and vsync. not sure how to do that with ATI cards, but if you can force tripplebuffering that should remove some stuttering.

Vsync will fix the stuttering issue, though the unfortunate part of this is the introduction of a slight lag in the video response. This is especially noticeable in the shooters.
m
0
l
June 16, 2011 12:22:30 PM

I hate vsync for that reason. okay, I'll wipe and reinstall. Thanks :) 
m
0
l
a c 128 U Graphics card
June 16, 2011 12:31:53 PM

If re-installing doesn't clear everything up, use the triple buffering option in catalyst control center as Iam2thecrowe has suggested and let us know if that helps any.
m
0
l
a c 128 U Graphics card
June 16, 2011 12:54:17 PM

Quote:
triple buffering will help smooth out input lag in games such as mouse moevement ect.

crossfire microstutter is very common.
i had microstutter on a single 4870....

I had it on 2 5850s and then 3 5850s. Sounds like they still haven't gotten it worked out over the last few months.
m
0
l
a c 128 U Graphics card
June 16, 2011 1:08:02 PM

I know, but I want AMD's solutions to get better for the sake of competition. I'm waiting for the day when we can choose either AMD or Nvidia again and have them both work. This will force Nvidia prices to drop. ;) 
m
0
l
a c 106 U Graphics card
June 16, 2011 3:00:47 PM

I never got micro stutter myself except for Gothic 4, but that game had other problems (like being a crappy game).

Oh yeah, make sure the CF connector is properly connected. If you have two of them try one, then the other. A faulty CF cable can cause issues and they are pretty easy to damage.
m
0
l
June 16, 2011 3:30:26 PM

Hey, after a reinstall of the latest 11.6 drivers and catalyst application profiles I can now say that the stuttering in crysis 2 is done. It still exists in some other games like lost planet 2 but I now believe that it was all just a matter of bad drivers. Thanks everyone!
m
0
l
a b U Graphics card
August 2, 2011 11:12:21 PM

stutter still persistent? I was wondering what your experience has been since your last post? I found myself in your same spot a few months ago and have since switched to a gtx 570 and I am more than happy because of stability among other things.
m
0
l
August 4, 2011 1:37:15 AM

Stuttering is still very much a reality. But I haven't been able to do anything to fix it.
m
0
l
a b U Graphics card
August 4, 2011 1:45:36 AM

what are your full system specs?
m
0
l
!