Closed Solved

RAM Timing Issue

Just finished my first build and loving it so far. I ran into what I think might be a problem. I have a GIGABYTE GA-Z77X-UD5H LGA 1155 Intel Z77 Intel Motherboard with RAM G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 .

I went into the BIOS to M.I.T, Current Status and my frequency looked correct at 1600, but both the Memory Channel A & B had timings of tCL 11, tRCD 11, tRD 11 and tRAS 28 when I believe they should be tCL 9, tRCD 9, tRD 9 and tRAS 24. I doubled check and went in to M.I.T., Advance Memory Setting and under both Channel A & B Timing Settings I found the above settings of 11-11-11-28 as well.

If this is something that should be corrected, could you please tell me how to correct it as well. I change the setting for Advance Memory Setting from AUTO to both QUICK and EXPERT and was unable to figure how to change the timing to 9-9-9-24.

Thank you in advance for your help.
4 answers Last reply Best Answer
More about timing issue
  1. Best answer
    Just enable the X.M.P. profile and you'll be good to go.
  2. DJDeCiBeL said:
    Just enable the X.M.P. profile and you'll be good to go.


    Thanks, this worked perfectly. If I could ask a followup question, What is X.M.P. and why was the timing being read or set incorrectly without this enabled?
  3. Best answer selected by ctpcbuild.
  4. This topic has been closed by Nikorr
Ask a new question

Read More

Memory RAM Product