Sign in with
Sign up | Sign in
Your question

ASUS M5A99x EVO Bios problem

Last response: in Motherboards
Share
August 19, 2012 12:29:15 AM

Hi all.
recently bought the following:
ASUS M5A99X EVO
AMD FX 4100 BLACK EDITION
MSI 6870 OC EDITION
4GB CORSAIR VENGEANCE LP
I installed all the components fine, powered up the system and continue to install win 7 pro, only problem i had was installing the motherboard drivers as my new optical drive hadn't turned up so i downloaded all the latest drivers/bios off asus.com.
I restarted and tried to enter the bios but couldn't, i've held delete from power on, tapped it throughout the whole post, but nothing, it just hangs on the POST screen, doesn't even give me a message like "press del to enter setup", the board comes with L.E.D lights to show whats being tested in POST, i've noticed that the "BOOT DEVICE" led stays on if i press delete, but if i leave the keyboard alone, it stays on till the post screen finishes. I'm at my wits end with it now, only had it for two days.
Any help would be amazing.
thanks
david
a b Ĉ ASUS
a c 128 V Motherboard
August 19, 2012 6:05:45 AM

Are you using a wireless keyboard by any chance? You need a wired keyboard in most cases to be able to get into the bios.
m
0
l
August 19, 2012 1:17:54 PM

Thanks for the reply abekl, i've tried with a ps/2 keyboard and still had no luck :(  the boot device led comes on and the system just hangs, to be though it sounds more like a software problem than a hardware fault. the hdd i'm using probably isn't the best, it's an old sata 2 i had laying around, i flashed the bios back to an older version but still no change.
m
0
l
September 2, 2012 6:26:57 PM

you can try pressing that MemOK button just beside the outermost memory slot.
m
0
l
!