Sign in with
Sign up | Sign in
Your question
Closed

Background noise with USB Headset

Last response: in Components
Share
November 17, 2011 2:58:07 PM

So I just recently got myself a "new" PC. It's actually my old Quad, I just brought it back to live, since my laptop died.
Anyway, I installed Teamspeak3 to communicate with my fellas as usual. But when TS is running, I hear weird windy noise all the time. It was all ok with previously on my laptop.

I use Creative Fatality HS-1000 USB Headset. I tried to plug it in different usb slots, nothing seems to help. I updated every possible driver, but it did not help either. Pretty please, help me, it's driving me nuts.

I've also found this thread on teamspeak forum http://forum.teamspeak.com/showthread.php/44608-Weird-n... which is probably the same issue as I have, but I did not really understood the solution. I disabled something connected with sound card in BIOS, but it did not help.

Some hints:
*When I disable my mic in Sound options in windows, it stops. But moving levels down or anything does not help...
*Realtek HD Audio Manager does not list my headset, I think it did previously on Laptop. But since the headset is USB, I think it should not list it anyway?
*Currently I run on W7 64bit.

Thank you very much

More about : background noise usb headset

November 17, 2011 4:19:35 PM

Its not a soundcard thing, because the USB headset will ignore any soundcard thats intalled.

Based on the fact it goes away when you mute your mic, the headset is probably configured to play back whatever the mic picks up, which would create a constant background noise [because the audio output would ALWAYS be open, even if the mic volume was set all the way to the bottom]. So check TS/Windows to see if the mic is set to playback whatever it picks up.
November 17, 2011 4:48:38 PM

It's not like I hear everything that goes thru the mic. I hear a very quiet, annoying, wind-like noise. The box that says "Listen to this device" is unchecked, if that's what you meant.

Also I can hear the mouse scroll button thru the headset, but as I said, the Listen to this Device is unchecked, and I don't hear myself in there when I type on keyboard/talk, which is much louder.
Related resources
November 18, 2011 2:48:57 AM

Could just be the headset has a really bad digital to analog converter then...

Check to see what devices are used from within TS, since it can override whatever the OS is set to.
November 18, 2011 4:02:39 AM

I set the Creative USB Headset in TS. Also I just tried it on different PC and it works fine...
November 18, 2011 4:34:12 AM

I had this issue, plug the usb into another one far from your optical mouse. That was my issue.

Edit, I just read you tried different usb ports...This may be odd, but try unplugging your optical mouse just to see if its the issue.
November 18, 2011 10:55:32 AM

Yeah, could be the USB hub isn't quite putting out enough power to properly drive the headset [though windows *should* warn you if a hub is underpowered...]
November 18, 2011 11:04:14 AM

It might be it, I am testing right now, it seems without the mouse it's better. I'll test more this evening and report if I succeed or not. Thanks guys, however, what can I do about this? Buy a new Power Supply to the PC?
November 18, 2011 2:29:21 PM

Its not a PSU problem; each USB hub can only put out so much power at any one time. You can try using a USB connector thats using a different hub [most PC's have two seperate USB hubs], or you could get a powered USB hub and use that instead.
November 18, 2011 3:13:34 PM

I plugged the headset from the front, while keeping the mouse connected in the back. No chance. Unplugged mouse, no change... I'm getting really desperate, it seems like I listen to the static from the PC and it's driving me nuts... I'll probably buy a new headset with 3,5mm jacks, instead of this freakyn USB, but why does it work on other PCs and not on mine? God dammit...
November 18, 2011 3:14:21 PM

Any why is it only happening with Teamspeak on?
November 18, 2011 3:56:48 PM

I got mad and started plugging/unplugging and eventually I screwed the headset completely, Windows cant detect it now... Ordered new headset with classy jacks.
!