Sign in with
Sign up | Sign in
Your question
Solved

WPA2-PK Encryption drastically kills internet speeds

Last response: in Wireless Networking
Share
January 20, 2011 2:43:44 AM

Currently my home network is on WEP security. Really crappy security and limits all speeds to 54mbps.

So I changed security to WPA2-PK and afterwards the internet is DEADLY slow. speedtest.net shows me at about 1mbps compared to 13-20 with WEP encryption. Something is obviously wrong here, and I can't figure out what.

Linksys Router WRT160N
Mixed network mode
Wide 40mHz channel

These are the only things connecting to the network:
1 Windows 7 laptop built in N wireless card.
2 Windows XP laptops b/g wifi card, but both using linksys AE1000 Wireless N Adapters
1 Xbox b/g standard xbox wifi adapter
1 b/g/n Bluray player
1 iPhone

I'm really puzzled as to why WPA2-PK is so awful. After changing it I can't log back into 192.168.1.1 unless I power cycle the router and connect via wired connection.

Any ideas?
Anonymous
a b 8 Security
January 20, 2011 3:03:55 AM

The more complex the security the longer it may take to negotiate connection initially especially with a marginal wireless signal (this sometimes leads to failure to connect at all that disappears when encryption is disabled).

WEP is useless these days, but ordinary WPA-PSK TKIP provides protection against most threats.
m
0
l
January 20, 2011 4:03:18 AM

So I should change it to WPA2+PK and then just leave it be for a while to fix itself? The longest I left it on WPA2 after changing it was like 5 minutes.
m
0
l
Related resources
Can't find your answer ? Ask !
Anonymous
a b 8 Security
January 20, 2011 8:12:46 AM

Wot ?

It won't take five minutes to negotiate. The difference between simple WEP and WPA successfully negotiating is perceptible -- but only a matter of seconds. The problem can arise if you have a marginal signal at which point the delay or something seems to sometimes be relevant to non-connection.

I didn't say use WPA2 though the problem you mention may be to do with not supplying a password to the wireless adapter.

Try connecting without security. Then try connecting using WPA-PSK TKIP.
m
0
l
January 21, 2011 12:29:07 AM

Sorry if my response was confusing. Frankly to be quite honest I don't know what you mean. When I change the router to WPA2-PK i change the WiFi settings on all adapters to WPA2-PK with the key and they can connect. But my download speeds go down the drain.

If I hadn't supplied the password to wireless adapter I wouldn't have been able to connect at all... so obviously that isn't the issue.
m
0
l

Best solution

a b 8 Security
January 21, 2011 3:05:45 AM

have you tried the 20mHz setting?
Share
January 27, 2011 10:58:46 PM

Best answer selected by PBuzzle.
m
0
l
!