Sign in with
Sign up | Sign in
Your question

Asrock Z77 Extreme4 - USB 3 Asmedia issue.

Last response: in Motherboards
Share
August 21, 2012 5:53:52 AM

I currently have had some issues with some random lockups as of late. I have traced it as best as I could to the Asmedia USB 3 controller.

Basically, the ports work as far as I could tell, however I did have a hard lockup the other day with devices connected to USB 3. However, the bigger issue is that if I do any sort of Scan for Hardware Changes in the Device Manager, it will just hard lock the machine. No reboot, blue screen, event viewer log or anything, just everything on the screen will stop working that requires a button press. I thought maybe a driver issue, so I tried to uninstall the drivers, and EVEN THEN it locks up midway through the uninstall. (This is the only driver that has issues being uninstalled, the Intel USB 3.0 updated and installed just fine)

I went in safe mode, enabled the Windows Installer service and attempted to uninstall the driver. It uninstalled fine without a lockup. I went ahead and reinstalled the latest from Asmedia's website, it went through without a lockup. Booted back up, still locks up on Scan for Hardware changes and removing the driver through Windows normally. Do I have a bad controller or what's the problem?

I have the latest BIOS 2.00 and have tried these settings with no overclock and with, it makes no difference...

Thanks for any help. :( 

EDIT: IF it helps here are the specs:
Intel i5 3570k
Asrock Z77 Extreme4 Motherboard (Latest BIOS)
16GB Corsair 1600MHZ DDR3 memory. (Passed 8 hours of Memtest 86+)
Asus Xonar Essence STX
EVGA Geforce GTX 670
2x OCZ Vertex4 120GB (RAID 0)
2x Seagate 320GB (RAID 1)
1x 1.5TB WD Drive
August 27, 2012 8:33:14 PM

Did you get any resolution to the USB3 problem? Mine has been locking up. Each bios update they release supposedly fixes it, but still no luck. Everything I plug into those 2 USB3.0 ports causes a hard lockup and button press to reboot. Really frustrating.
m
0
l
August 28, 2012 4:47:19 AM

The only thing that seemed to help was loading BIOS defaults. Then resetting everything up, and the scan hardware freezing and driver uninstalling seemed to stop instant locking. However, now I have issues where my USB devices will randomly disconnect. Sometimes my keyboard and mice just stop working entirely, even if I unplug them and plug them back in, it will recognize them via Windows sound and get power. They just don't come back unless I move them to different ports. A pain in the ass.

Also my Asmedia SATA ports cause the system to instant lock when I benchmark hard drives on it. Sigh.
m
0
l
Related resources
October 12, 2012 2:20:15 PM

BIOS update should probably fix it.
m
0
l
December 12, 2012 2:52:51 AM

THE SOLUTION TO FREEZES - LOCKDOWNS - RANDOM DISCONNECTINGS OF HDD CONNECTED VIA USB 3.0 ENCLOSURE TO ASMEDIA CONTROLLERS

I have searched all the internet for the last 5 days for a solution regarding my random disconnecting/reconnecting of my HDD connected to Asmedia Controllers via USB 3.0 enclosure.

I did all the following without any luck:
- Updated the BIOS of my MB (Asus P8z68 V-Pro)
- Updated the firmware of AsMedia ASM 104x contoller
- Updated the drivers of Asmedia ASM 104x controller
- Lowered the PCIe frequency to 100Mhz
- Changed cables
- RMAd the USB 3.0 enclosure

Nothing worked until i bumped against the following forum:
http://forum.mediasonic.ca/viewtopic.php?f=27&t=1234

As they proposed, I uninstalled all the programs that check the SMART data of all connected hard drives occasionally and voila, NO MORE RANDOM DISCONNECTINGS !!!!!

Try it out and spread out the word !!!
m
0
l
!