Sign in with
Sign up | Sign in
Your question

Tried to update graphics card driver, now opengl is broken

Tags:
  • Graphics Cards
  • Installer
  • Graphics
Last response: in Graphics & Displays
Share
June 18, 2011 10:12:58 AM

I have a Radeon HD 5870, windows 7 64bit. I have been experiencing a crash in the game Minecraft when I play with the 'fancy' graphics setting. I wanted to try to fix this, and someone suggested I update my graphics card driver.

I went to the site for downloading Radeon standalone drivers and downloaded the installer "11-6_vista64_win7_64_dd.exe" and ran the installer. It blue-screened halfway through, and my computer rebooted.
The display driver was borked so I tried downloading the full Catalyst installer next "11-6_vista64_win7_64_dd_ccc_ocl.exe", and ran that exe. It extracted to my C drive but never continued the installation. SO I navigated to the folder on C that it had extracted to and tried running "Setup.exe" there.

I got this Error: "C:\ATI\Support\11-6_vista64_win7_64_dd_ccc_ocl\Setup.exe has failed to start because its side-by-side configuration is incorrect."

So then I followed the instructions to completely remove the ATI drivers, and restarted, but the Setup.exe in the exe installer still didn't run, still gave the same "side-by-side" configuration error.

I emailed AMD's tech support, they just said "use the old drivers, maybe there will be a new driver next week" (REAL helpful) so I dug out my old graphics card instal cd and ran the old installer. Which worked EXCEPT now when I try to run Minecraft it says it can't "find an Opengl accelerated card" or something.

So reverting to the old driver works except for Opengl which I need to play Minecraft which was the whole point of running the updater in the first place.

TL;DR: So basically I tried to update my driver and it completely broke Opengl.

Any ideas on what I can do to get OpenGL working again?
I tried titaniumgl.tk, it mangled Minecrafts graphics into garbage, so that doesn't work.

I can't even try to run the ATI installer again because it always says "side-by-side configuration" error.

Any advice on what I can do?

More about : update graphics card driver opengl broken

Related resources
a b U Graphics card
June 18, 2011 7:38:33 PM

Yes. I'm using Firefox 3.6.17

Should look like:

June 18, 2011 8:00:11 PM

Thanks, The connection finally went through, I downloaded it, uninstalled, ran Driver Sweeper, and then installed 11.5 and it's working now!
a b U Graphics card
June 18, 2011 8:00:35 PM

awesome, glad to hear it
!