Sign in with
Sign up | Sign in
Your question

Motherboard only read 4gb

Last response: in Motherboards
Share
August 22, 2012 9:36:04 AM

Recently my motherboard spoiled and i rma it. I got back a refurbished set thinking that it might work properly. The first few days was alright until yesterday when i got a blue screen. When i turned on the computer again it read "WARNING!!! The previous overclocking had failed". I restart it again and it read "Bad CMOS". I google up some information and tried removing the mobo battery and putting it back. But it still doesn't work. Tried mflash the bios and update it but problem still there.

Strange thing is when i pop out one ram, it works as normal. I thought that the faulty ram is causing the problem. But when i test it on another computer of mine, it is working properly. The thing is my motherboard can only read that particular ram. I have tried 4 different 4gb 1333mhz ram on it , it doesnt work but they work fine on other systems. It is not the socket problem because i tried switching them but problem still there.
:sweat: 

My build:
Msi g54-870a
Kingston 8gb (4gbx2) 1333mhz

More about : motherboard read 4gb

a c 170 V Motherboard
August 22, 2012 9:56:25 AM

Pulling the clock battery is not guaranteed to clear the firmware settings. On older motherboards the firmware code was stored in EEPROM and the firmware settings (BIOS implementation) were always stored in volatile SRAM so pulling the clock battery cleared the SRAM as well.

On newer motherboards (BIOS, EFI and Hybrid) many manufacturers have opted to put the firmware and the firmware settings in Flash instead. Thus, pulling the clock battery does nothing more than force you to reset the date and time.

MSI has been using Flash for firmware storage for quite some time. Please consult your motherboard manual to figure out how to properly reset the settings.
m
0
l
August 22, 2012 4:11:22 PM

I did whatever my manual wrote; switching the jumper. But it still doesn't solve the problem. Now the thing is, i took a spare (1x2gb) ram and slot it beside with the (1x4gb ) ram and it reads 6gb.

So i thought it was the " faulty ram" that is causing the problem and went to RMA it. I got the "new" ram and slot it beside the (1x4gb)ram that was working correctly. I pressed the power button and only the power led lights up. It couldn't even go into the bios screen. I pair the "new" ram beside with the (1x2gb) ram. Again, only the power led lights up.


m
0
l
!