Sign in with
Sign up | Sign in
Your question

PSU works in one computer but not in the other.

Last response: in Systems
Share
August 22, 2011 6:54:34 PM

I'm building a "new" system with new motherboard and cpu, but I'm reusing my 750W PSU from my last gaming rig which always worked great.

And this is where it starts to get strange; it won't work in the new system for some reason. It starts for a brief moment and then stops which can be seen on the fans which spin up for half a second, and the lights which will flash.

Swapping the PSU back to my old computer and it works again. So I figured the new system was broken in some way, so I tested with another PSU (older one, with 550W power). And lo and behold - that works!

Anyone has a clue on what I should do next? My friend thinks my 750W PSU must be broken, but why would it work in my old rig then? I think my new rig is infact broken and my 750W PSU detects this trough all the protection it has, and that the 550W doesn't and keeps on powering it. But I admit to not having much electricity knowledge.

I really have no idea what to try next.

Thanks for any insight you can give me.
/Stefan

More about : psu works computer

August 22, 2011 7:03:19 PM

Well it could be the 750w doesn't have enough juice on the 12v rails to power the system.

You say well why would the 550w unit power it then. Well there could be many reasons. Maybe if you told us what power supply makes and models were talking about here.

The thing about psu's is they are rated like cheap speakers. You ever see $10 speekers that say 500w MAX POWER and you hook them up to 25w and blow them out of the cone, yeah, that's because the rating is given using a "cheating" method of rating.

Same with psu's. A cheapo 750w power supply might only be capable of putting out 400 real watts, while a name brand quality 550w power supply would be capable of an actual 550+ watts while being 10-30% more efficient at the same time.
August 22, 2011 7:24:25 PM

I'm well aware of how some PSU's are much weaker than what their specification says, but I bought the 750W because most reviews said it was up to par. Here are the PSU's:

Chieftec CFT-750-14CS
Aspire ATX-AS550W-BK

The Chieftec one claims to have tons of protection systems, which was why I thought those might detect something is bad and shut down the PSU. Which would explain why the Chieftec works in my old gaming rig.

Or it could be that the old gaming rig doesn't strain the Chieftec as hard as the new rig does and thus doesn't show the problem with the Chieftec until it's strained?
Related resources
August 22, 2011 7:47:11 PM

Ok the Chieftec seems to be a decent unit made by Channel Well, so, at least we have narrowed that down.

The Aspire on the other hand is garbage.

So your saying that the fans come and then shut off?

Why don't you start by telling us what the new system is. Motherboard, cpu, ram, etc, maybe you have something incompatible or hooked up incorrectly in the new system.
August 22, 2011 7:58:42 PM

Just curious, try powering on without the +12v (the 4 or 8pin power connector) plugged into the board.
Without +12v you won't get a screen, but just want to know if it will last longer
than half second.
August 22, 2011 8:35:01 PM

GeekApproved: Uh, nothing is hooked up incorrectly and it does work with the Aspire PSU. It doesn't even post with the Chieftec so what RAM I got is irrelevant as it never gets to the RAM.

Yeah, the fans spin up and shut off. Hooking up a multimeter and measuring shows the same, it gives out steady power for half a second then shuts it.

lp231: Thanks for the tip! Plugging in the 8-pin from a rail described as "CPU" (on the PSU's chassis), plugging in a 4-pin into the correct position on the 8-pin connector, or leaving it empty has no difference. Fans/lights start but only briefly.

The only difference I get is when I put in a 8-pin 12V from the same rails that the PCI-E GPU's usually are put, the CPU led will flash red until I power down. No fans or lights. I guess that wasn't correct.

* 8-pin plugged in from the rail described as "CPU" on the PSU's chassis = fans/lights start for a brief second.
* 4-pin plugged into the 8-pin in the correct position according to the manual = same as above.
* 8-pin plugged in from a 12v rail = no fans or lights start, but the CPU led flashes red until I shut the power off.
August 24, 2011 5:12:25 PM

PSU not compatible with that board, happens but rarely.
August 24, 2011 5:38:58 PM

It happens on two new motherboards now, so I've decided to replace the PSU. It doesn't even spin the chassis fans with *only* the motherboards plugged in, which the other weaker PSU does.

Breadboarding was the most useful thing I did in this case. It's so much simpler to swap out components and test different PSU's that way.

Thanks again all of you + lp231 for the wonderful suggestions!
November 18, 2011 12:29:44 AM

Hi all,

I have had the same problem as this, except that my Silverstone 750W SST-ST75F was working one day (for well over a year) and stopped the next, a few days after I had a video card failure. Swapping out the PSU, it worked in another PC and the crappy 430W cheap PSU from the other PC worked in mine. Swap them back again and no joy. Worse still, I bought another PSU and, like Stefan's problem, it still would not POST - exactly as the Silverstone developed.

Could the power regulator on the motherboard have become pooched somehow? (All the caps look intact.) I really was not in the mood to get a new one after all the fussing around I did with PSUs and the run of bad luck I have been having in general but I am just looking for answers right now.

I suspect a power sag might have shorted something out since I had to replace the UPS batteries and have not reconnected it yet...
November 18, 2011 10:03:37 AM

Hi Ev!

That sounds exactly like what happend to me except the computer which was running on the PSU at that time still worked with the PSU even though it was broken. Then when I switched, it became obvious. In your case, it became obvious instantly when it broke.

I bought a new motherboard, without luck. Stripped down my workstation and put it on a piece of wood to test each component but no luck there either. Finally bought a new PSU (and boy was that a hard decision, I was so sure it was something else that broke and not the PSU since it did work in another computer).. and haven't had any more issues since.

As for your questions about the power regulator - I wish I knew what you were talking about. Software is so much more logical than hardware. :)  And the motherboards I tested weren't exactly easy to diagnose, for me anyway..

Oh and another detail; my faulty PSU was probably due to an error in our electrical equipment here at home where our 3-phase power (not sure if that's the correct term in English.. it's used for high voltage equipment like kitchen ovens..) was leaking 400+V into our regular 2-phase 220V which caused power surges and most likely fried the PSU "partly" which made it break under pressure.

Sorry if I'm not making sense as I'm in a hurry. Hope you fix your issues, I know it's a pain!
October 2, 2012 6:50:12 AM

Stefan, that seems like a big problem - three phase leakage into your two phase circuit would pose a large safety risk!

Luckily, I resolved my issue. The motherboard components had failed and getting a new mobo (and the rest!) got it working fine again on the SilverStone PSU. Lesson learned here: always buy a more resilient board with long warranty. (In my case an ASUS SaberTooth 990.)

The UPS is ticking away nicely too...
!