Sign in with
Sign up | Sign in
Your question
Solved

Gigabyte GA-Z77-D3H "Bios ID Check Error"

Last response: in Motherboards
Share
August 25, 2012 8:43:51 AM

Ok So this has been driving me nuts all day,

I am trying to update the BIOS for my mobo which is

GA-Z77-D3H (rev 1.0)

I am 100% sure of the model and revision , I can see them printed on the mobo. According to system info the current version is:

BIOS Version/Date American Megatrends Inc. F5, 09/03/2012

I am trying to update it to F18 using:

http://www.gigabyte.com/products/product-page.aspx?pid=...

But when I try using the q-flash utillity I just get "Bios ID Check Error" back. This is so frustrating, any help would be greatly appreciated.

Cheers

Best solution

a c 125 V Motherboard
August 25, 2012 9:30:05 AM

Not sure if this will help, but try using the @BIOS utility to flash the FW. It might work.
http://download.gigabyte.us/FileList/Utility/mb_utility...
Share
August 25, 2012 10:43:19 AM

Thanks for the reply,

I tried using the @BIOS utility to install the BIOS File I had already downloaded (F18) and got the same error as before. I told it to carry on and update anyway but system wouldn't boot so I restored it to the original BIOS and tried the "update from Gigabyte Server" option. For some reason the most recent version it could find was F9, when I tried to upgrade to that I got a warning: "This is not a regular file name" I ignored it and upgraded anyway and again it wouldn't boot.

Thanks again for getting back to me, any other suggestions would be appreciated. I'm totally stumped...
m
0
l
Related resources
August 25, 2012 10:58:27 AM

Update:

I've now managed to update to F9. I got the same boot error as before

"'Remove disks or other media. Press any key to restart"

So I entered the BIOS and looked at the boot options. For some reason my internal SSD was showing up as a flash drive and was not a boot option, I set this to boot first and the system seems fine. Curiously I still can't upgrade to F18 as the Gigabyte servers only have F9 and the BIOS files I used before now just give the error "BIOS Partnumber is not correct" with no option to override.
m
0
l
August 25, 2012 11:13:27 AM

Oh Dear.... This is deeply embarrassing!

Turns out my mobo is the z77x. At least everything makes sense now I know it was just me being a numpty.

Thanks again for your help abekl
m
0
l
August 25, 2012 11:16:08 AM

Best answer selected by phb07jm.
m
0
l
a c 125 V Motherboard
August 25, 2012 11:21:20 AM

No problem. At least you got it sorted
m
0
l
!