Sign in with
Sign up | Sign in
Your question

Whats wrong with my pc..?

Last response: in Graphics & Displays
Share
June 21, 2011 6:50:22 AM

PC specs:
Windows 7 ultimate 64 bit
core 2 duo e7400 @ 2.8Ghz
XFX Radeon 5770 HD
dg31pr motherboard
4GB DDR2 Ram..

cant play games like hot pursuit, just cause 2, crysis etc even at the lowest settings..my drivers are up to date..it lags like hell..
any help..?

More about : whats wrong

June 21, 2011 7:17:49 AM

what power supply do you have? with those specs it shoud run the mentioned games pretty well. Also what screen resolution are you running?
June 21, 2011 7:24:06 AM

iam2thecrowe said:
what power supply do you have? with those specs it shoud run the mentioned games pretty well. Also what screen resolution are you running?

600 watts supply and 1366x768 resolution..
Related resources
June 21, 2011 7:30:35 AM

Sounds to me like you have your overrides set in your ATI Cat center such as Anti lacing and other things. This will force higher graphic settings regardless of what is set in your game options.
June 21, 2011 10:11:03 AM

when running hot pursuit at high settings the CPU usage is around 75-80% and memory usage is around 2.15 GB (out of 4GB)..my GPU is also good enough to run this game at resolution 1366x768...so what's causing this lag.. :( 
June 21, 2011 10:13:47 AM

randykeith said:
600 watts supply and 1366x768 resolution..

what make/model power supply do you have? Just because it says 600w on the box doesnt mean it can produce 600w continuous of DC power, some 600w psu's cant even produce 300w continuous.
June 21, 2011 10:16:34 AM

iam2thecrowe said:
what make/model power supply do you have? Just because it says 600w on the box doesnt mean it can produce 600w continuous of DC power, some 600w psu's cant even produce 300w continuous.

Cooler master extreme power plus 600w psu..!
June 21, 2011 1:02:23 PM

Did you check your settings for ATI Catalyst Control Center like dormantreign suggested?

Is anything else using much of your CPU while you're playing these games? Like an antivirus program or anything.

You could check memory speeds and timings and see if they are correct in Windows using CPU-Z or a utility for your motherboard or in BIOS. Could also check if your RAM is running in dual-channel mode.

Maybe you're hitting your swap file (paging file) on HDD. You could try chaning your virtual memory settings and checking "Automatically manage paging file size for all drives."
June 21, 2011 1:40:37 PM

arson94 said:
Did you check your settings for ATI Catalyst Control Center like dormantreign suggested?

Is anything else using much of your CPU while you're playing these games? Like an antivirus program or anything.

You could check memory speeds and timings and see if they are correct in Windows using CPU-Z or a utility for your motherboard or in BIOS. Could also check if your RAM is running in dual-channel mode.

Maybe you're hitting your swap file (paging file) on HDD. You could try chaning your virtual memory settings and checking "Automatically manage paging file size for all drives."

While running games i wont run any other program..
yes the ram is running in dual channel mode..is that all right?


Maybe you're hitting your swap file (paging file) on HDD. You could try chaning your virtual memory settings and checking "Automatically manage paging file size for all drives."

Sorry but what is this and how to do this..??
Also the GPU load is constantly at 100% while playing..is this a problem?
June 21, 2011 3:24:49 PM

Dual channel is good, you want it in dual channel mode so leave it like that.

Swap or paging file is referred to as 'virtual memory' and it's a file on your hard drive that Windows will use like RAM if you run out of physical RAM. Windows shouldn't do that unless all of your physical RAM is in use. Too see the settings do the following:

1. Open start menu and type 'advanced system settings' and hit enter
2. Check the 'Settings' button inside the 'Performance' section
3. Click the 'Advanced' tab
4. Click the 'Change' button
5. Click the check box at the top that reads 'Automatically manage paging file size for all drives'


Go ahead and change that setting, it's one I like to always use. However, if your CPU is always at 100%, then it seems to be bottlenecking the rest of your system and provides good reason to think it's the source of all of your problems. Earlier you said it was about 75-80% and that shouldn't really be a problem. 100% would be a problem though because all of your CPU cycles are being used faster than it can handle.

Somebody else should chime in. I didn't think those games would completely overload an E7400 but I could be wrong.

randykeith, play one of your problem games and see if both cores of your CPU are at 100% in task manager under the 'Performance' tab. Also, look under 'Processes' tab in task manager and see what all processes are using your CPU. Tell me anything that's using more than 00 under the CPU column and tell me what the number is for each process (.exe).
June 21, 2011 6:21:26 PM

arson94 said:
Dual channel is good, you want it in dual channel mode so leave it like that.

Swap or paging file is referred to as 'virtual memory' and it's a file on your hard drive that Windows will use like RAM if you run out of physical RAM. Windows shouldn't do that unless all of your physical RAM is in use. Too see the settings do the following:

1. Open start menu and type 'advanced system settings' and hit enter
2. Check the 'Settings' button inside the 'Performance' section
3. Click the 'Advanced' tab
4. Click the 'Change' button
5. Click the check box at the top that reads 'Automatically manage paging file size for all drives'


Go ahead and change that setting, it's one I like to always use. However, if your CPU is always at 100%, then it seems to be bottlenecking the rest of your system and provides good reason to think it's the source of all of your problems. Earlier you said it was about 75-80% and that shouldn't really be a problem. 100% would be a problem though because all of your CPU cycles are being used faster than it can handle.

Somebody else should chime in. I didn't think those games would completely overload an E7400 but I could be wrong.

randykeith, play one of your problem games and see if both cores of your CPU are at 100% in task manager under the 'Performance' tab. Also, look under 'Processes' tab in task manager and see what all processes are using your CPU. Tell me anything that's using more than 00 under the CPU column and tell me what the number is for each process (.exe).


Playing crysis at 1366x768 resolution (high) :
GPU core clock : 850 mhz
Gpu memory clock :1200 mhz
GPU temperature : 78 degrees
Fan speed : 53%
GPU load : 100%

CPU performance :
one core : 100%
other core : around 60%
memory usage : 1.78 GB
crysis.exe uses 43 under CPU column and memory (private working set) 796,591k..
dwm.exe uses 03 under CPu column..
FPS: 5-10 probably..

it is the GPU which is under 100% constant load..!
June 21, 2011 6:48:23 PM

My bad, I read your previous post wrong and read GPU as CPU. Yea, seems like your current in-game settings are just too much for the card. You mentioned this happens even at lowest settings. Does crysis have an option for it to auto-detect the best settings for your system? You could try that. Or just make sure options like antialiasing and anisotropic filtering are disabled/off. It seems like RAM is fine and your CPU is skating by with not quite both cores at 100%. I forget the graphic settings in Crysis since it's been so long since I've played it. But I think I remember it being able to auto detect your system and recommend best settings.

EDIT: 2 more questions. Is your card a 512MB or 1GB card? and are you gaming in window mode by any chance? If you are, don't do that and game in full screen mode. Window mode puts more strain on your video card.
!