Sign in with
Sign up | Sign in
Your question

ASRock 970 Extreme 3 USB Ports not working

Last response: in Motherboards
Share
August 27, 2012 8:06:01 AM

Along with various other things not working on this board including onboard audio, I've run into another problem. None of my USB ports work except 3.0...and that's with 2.0 disabled in bios. I have a PS2 Keyboard and my USB mouse plugged into one of the 3.0 ports. When I enable the 2.0 Ports in Bios, everything basically freezes. My mouse wont work and neither will my keyboard. I've come up with the possibility that my Motherboard is faulty. I've installed all the Drivers and reinstalled them multiple times, I've tried every single 2.0 USB port...to no avail. If any of you guys could help, that would be awesome. If not, I'll take it that this motherboard is junk and try and have them send me a new one.
a b V Motherboard
August 27, 2012 8:37:03 AM

ASRock = cheap rubbish i really dont like there products but this sounds like either drivers or settings issue (but dont rule out flakey motherboard)

reset cmos, use native ports initially (bios/windows) and check drivers/chipset software is up to date
m
0
l
a b V Motherboard
August 27, 2012 8:46:57 AM

apache_lives said:
ASRock = cheap rubbish i really dont like there products but this sounds like either drivers or settings issue (but dont rule out flakey motherboard)

reset cmos, use native ports initially (bios/windows) and check drivers/chipset software is up to date



the irony in the statement is that asrock was a subdivision of asus, which you are using a mobo for.(back then) they have since then seperated
m
0
l
!