Sign in with
Sign up | Sign in
Your question

Radeon 6950 2gb not seeing performance increase??

Last response: in Graphics & Displays
Share
June 23, 2011 2:20:48 AM

I just upgraded from an ASUS Radeon 5770 to a HIS Radeon 6950 2gb, and I am not seeing the performance increase I was hoping for. StarCraft 2 cutscenes seem to drop frames (this is the best way I can think to describe it...), and I recently downloaded UT3 Black Edition (Have been a big fan of the series since the original) just to try it out, and running max settings it seems to also do the same.

Any thoughts? My initial theory is that I don't have enough power - 530w Rosewill (80% efficient), or it is running too hot.

System:

MSI 870-G45 mobo, AMD Athlon II x4 3.0ghx
8gb (4x2gb) G.SKill Eco DDR3 1333
HIS Radeon 6950 2gb
530w Rosewill PSU
4x 120mm LED fans, 1x 200mm LED fan

Card runs at about 70c when at load during games, runs at about 90c when using furMark, but this isn't always a realistic measure

Also, the card requires 2x 6-pin PCIe power connectors - I have one PCIe 6-pin from my PSU hooked up, and I then took the 6-pin part of an 8-pin connector (they are split at 6-2, I assume so you can subsequently use either the 6 or 8). Does this matter? Or should I use the double 4-pin molex to 6-pin PCIe adapter that came with the card?
August 12, 2011 11:49:58 AM

defever3 said:
I just upgraded from an ASUS Radeon 5770 to a HIS Radeon 6950 2gb, and I am not seeing the performance increase I was hoping for. StarCraft 2 cutscenes seem to drop frames (this is the best way I can think to describe it...), and I recently downloaded UT3 Black Edition (Have been a big fan of the series since the original) just to try it out, and running max settings it seems to also do the same.

Any thoughts? My initial theory is that I don't have enough power - 530w Rosewill (80% efficient), or it is running too hot.

System:

MSI 870-G45 mobo, AMD Athlon II x4 3.0ghx
8gb (4x2gb) G.SKill Eco DDR3 1333
HIS Radeon 6950 2gb
530w Rosewill PSU
4x 120mm LED fans, 1x 200mm LED fan

Card runs at about 70c when at load during games, runs at about 90c when using furMark, but this isn't always a realistic measure

Also, the card requires 2x 6-pin PCIe power connectors - I have one PCIe 6-pin from my PSU hooked up, and I then took the 6-pin part of an 8-pin connector (they are split at 6-2, I assume so you can subsequently use either the 6 or 8). Does this matter? Or should I use the double 4-pin molex to 6-pin PCIe adapter that came with the card?


May be your CPU bottlenecks your GPU. U should upgrade your CPU... AMD Phenom II suits your system rig... Then you will see the performance increase.. And about the power requirement there should not be any problem........
m
0
l
!