Sign in with
Sign up | Sign in
Your question

BSOD when 5770 Crossfire Activates

Last response: in Graphics & Displays
Share
June 23, 2011 3:29:17 PM

Morning all! I've had two Radeon HD 5770 installed in my computer for about a month now and have had no problems. ATI Catalyst has been downloaded and has the latest version running (11.6). I don't think, however, that any game I've been playing has activated crossfire yet.... until yesterday. Tried running Witcher 2 and Crysis 2 with crossfire on. During the startup screens of both games all three of my monitors flicker many times, go black, flicker some more then BSOD. I've played Crysis 2 before but always in windowed mode and I found out yesterday that crossfire will never activate in windowed mode. Both games work fine in windowed mode. When I turn crossfire off in Catalyst, I can run both games in fullscreen no problem. I know that my PSU is too low, only having an SLI ready 525W, but is that a possible cause for the BSOD crash? I'm looking at a 750W right now on Newegg- www.newegg.com/Product/Product.aspx?Item=N82E1681713900...

Is this a good enough replacement? Any info anyone has is greatly appreciated - thanks!
a b U Graphics card
June 23, 2011 3:58:36 PM

Yep, it is. A friend has 2 4850's in XFire with the same PSU. The 4850 has similar power requirements as the 5770, so you'll be fine.

Now, the BSOD could be due to more factors than just power (but your intuition seems correct IMO). Check temperatures if you can.

Cheers!
m
0
l
June 23, 2011 4:10:04 PM

Thanks for the info! I'm not a pro - but temps seem to be running ok - between 50-55c.
m
0
l
Related resources
a b U Graphics card
June 23, 2011 6:53:02 PM

Yep, those are very good temps.

Cheers!
m
0
l
June 25, 2011 12:40:40 AM

Every time I start a game that utilized crossfire in fullscreen the screen flickers and I get BSOD. I just rebuilt my system today to incorporate a new Corsair 750W crossfire rdy power supply so I know i have enough power. Here are my specs:

AMD Phenom II X4 955 Processor 3.2GHz
4 Gigs PC6400 (2GBx2) RAM
Windows 7 64bit
MSI R5770 Hawk Radeon HD 5770 1GB
MSI R5770-PMD1G Radeon HD 5770 1GB
MSI 790XT-G45 Crossfire rdy motherboard

All built in a COOLER MASTER HAF X Full Tower case with a Cool Master Hyper 212+ Heatsink and fan on CPU. The case runs uber cool and nothing has been overclocked - believe me temp is not an issue. Upon crashing my cpu is at 26C and my GPU is at 36C.

I am at my wits end on this problem. I've I start any of the games (witcher 2 or crysis 2) in windowed mode (even with crossfire active) it works fine - only fullscreen is when it crashed.

If i turn crossfire off I can play the games fine fullscreen and windowed. I learned that crossfire only works in fullscreen so it's definetly a crossfire issue. Please help!!!
m
0
l
June 25, 2011 12:47:33 AM

also - both cards perform correctly when installed independently.
m
0
l
June 25, 2011 9:21:07 AM

Well I'll post the solution just in case this can help anyone in the future. After troubleshooting this all day I found that when I disabled my other monitors (3 running total) and just kept the main one active, crossfire in fullscreen worked perfectly. solved. That still shouldnt be an issue though... I'm starting to wish I went with nVidia.
m
0
l
a b U Graphics card
June 25, 2011 2:25:31 PM

You need an Nvidia card. They are completely idiot proof.
m
0
l
July 30, 2011 7:37:12 AM

Hey, I had the almost the same issue, but I managed to 'fix' it (live with it you may say xD). The main difference is that I have 2 monitors.

Now I got the 11.7 drivers installed.

The fix is simple, but very hard to figure out. Go to the now called "AMD VISION Engine Control Center" (let's call it CCC) -> desktop managment -> creating and arranging desktops.

There you should see your screens. You should see that every monitor has an identifier (1,2 and 3). The trick is that crossfire + fullscreen only works on monitor 1. When I used fullscreen on my monitor 2 I had a lot of BSODs. I don't know exactly how you can change the numbers, I did it by plugging in and out the cables, by trial and error. Then if you want to have choices, you can save every desirable configuration using presets.

I hope this helps you :) .
m
0
l
July 30, 2011 7:45:12 AM

I went through the same, my solution is a bit different, because I don't need to disable the other monitors. I will quote me from another post.

Quote:
The fix is simple. Go to the now called "AMD VISION Engine Control Center" (let's call it CCC) -> desktop managment -> creating and arranging desktops.

There you should see your screens. You should see that every monitor has an identifier (1,2 and 3). The trick is that crossfire + fullscreen only works on monitor 1. When I used fullscreen on my monitor 2 I had a lot of BSODs. I don't know exactly how you can change the numbers, I did it by plugging in and out the cables, by trial and error. Then if you want to have choices, you can save every desirable configuration using presets.

I hope this helps you :) .


I hope this helps people xD.
m
0
l
a c 272 U Graphics card
July 30, 2011 2:50:45 PM

This next topics has been merged by Mousemonkey
  • BSOD in Crossfire
    m
    0
    l
    !