Sign in with
Sign up | Sign in
Your question
Closed

Dell vostro 1510 graphics card issues

Last response: in Graphics & Displays
Share
June 24, 2011 10:05:08 AM

Hello,

I'm having a vostro 1510. Couple of days back i got two BSODs, after restarting my system it was working fine. But some days later, I got some white band and pink patches in my lcd display. I've connected it to an external monitor and the same bands and patches appeared there too. I ran the diagnostic cd provided by dell and found out that my Fan speed is incorrect and there is also an issue with my Video memory. (Nvdia 8400 GS)

Is there any problem with my graphic card? or is it just because of my faulty Fan?

Best solution

a b U Graphics card
June 24, 2011 12:23:13 PM
Share

uIt's a faulty VGA chip on the mobo for sure, hence the corruption on both lcd and vga output.

Call dell and ask for a replacement under the consumer rights act due to them selling you a board with a manufacturing fault.

1000's of the 8 series Nvidia chips had faults where they would overheat and the solder balls in the chip died.

If they wont replace it then you need a new machine, best to stay clear of vostro's also, it's the cheapest line they do and they are plagued with faults.
July 1, 2011 5:15:00 AM

@plasmastorm: Thank you for replying, Dell has asked me to replace my motherboard with a new one which is again having Nvdia G force 8400Gs. And I have to pay them 28,000/-Rs which is equivalent to 650$. :-(
Related resources
Anonymous
a b U Graphics card
July 7, 2011 2:05:57 PM

arunsankar23 said:
Hello,

I'm having a vostro 1510. Couple of days back i got two BSODs, after restarting my system it was working fine. But some days later, I got some white band and pink patches in my lcd display. I've connected it to an external monitor and the same bands and patches appeared there too. I ran the diagnostic cd provided by dell and found out that my Fan speed is incorrect and there is also an issue with my Video memory. (Nvdia 8400 GS)

Is there any problem with my graphic card? or is it just because of my faulty Fan?

Anonymous
a b U Graphics card
July 9, 2011 10:29:35 AM

hi, I had a very similar problem 2 days ago. instead of pink patches.. it showed yellow patches. 1 day after the problem occured, my computer died (after about 5 reboots). so really. try doing the back up and checking for a new laptop. as i dont think it is worth it for a replacement.
July 19, 2011 3:48:08 AM

Best answer selected by arunsankar23.
a c 168 Î Nvidia
a c 271 U Graphics card
July 19, 2011 12:52:04 PM

This topic has been closed by Mousemonkey
!