Sign in with
Sign up | Sign in
Your question
Solved

ASUS HD4870 DK 1G Dual Monitor Problem

Last response: in Graphics & Displays
Share
June 24, 2011 5:14:50 PM

Hi,

i am having a problem or glitch of some sort when i enable dual monitors... here is my setup before i go further

ASUS ATi Radeon HD4870 DK 1G GDDR5 @ 815/1000 (latest drivers 11.6)
Windows 7 x64 (latest updates)
i7 920 @ 3.6GHz
12gb Corsair ddr3 @ 1600MHz (using x.m.p.)


Connected to my video card:
- Monitor (Samsung SyncMaster 2253BW) connect via DVI (on white dvi plug)
- TV (Samsung LN32C550) connected via HDMI (on yellow dvi plug, using DVI to HDMI adapter)


Ok.. now the problem i am having is a frequent screen tearing or jumping (the whole image doesn't jump fully.. its like the lower end of the image kind of gets separated from the top end by doing a jump, tearing apart, leaving a black area in between the two parts, and then coming back making image ok again. sorry lol hard to describe it) on my TV and only on my tv (monitor doesn't experience this).. this only happens when i have BOTH screens enabled.. either by Cloning/duplicate or Extending doesn't really matter.

now if i set my TV to be the only monitor, having my monitor disabled, the tearing does not happen and everything is perfect..

this never happened in the past... not sure if its a driver issue since this happened a few drivers ago but I'm finding it frustrating that i can't use both screens without having my TV getting the screen tearing/jumping issue... :( 

Anyone having the same problem as me? Let me know thanks!

Thanks,
Sam
a b U Graphics card
June 24, 2011 10:06:31 PM

Uhm... I have a 4890 on my Rig, so I'll do the check too. I recently upgraded to 11.6 cata.

At first glance, yeah, could be a driver issue. Have you checked inside the catalyst control center for any options about your problem?

Cheers!

PS: I'll update when I get home, which should be in around 2 hours from now.
m
0
l
June 24, 2011 10:56:14 PM

I already checked in the CCC but found absolutely nothing.. changed around bunch of settings such as resolutions, refresh rates, color depth... reduce DVI frequency, alternate dvi operation mode, overclocked, factory clocks... and nothing has worked.. except for setting my TV as primary and disabling my monitor.. basically disabling dual monitors..

but i gotta note that this was happening to me before catalyst 11.6, just not sure exactly when..

this could be totally unrelated but.. it could be also around the same time where i started experiencing a mouse lag issue happening at the top right corner of my screen with cursor shadow enabled... not sure tho.. anyways..
i know that AMD was working on that fix (the mouse lag thing) and they have fixed it in 11.6 and thought maybe it would fix this issue as well but it hasn't, not for me anyways.. :( 

Let me know what you come up with

Thanks,
Sam
m
0
l
Related resources

Best solution

June 25, 2011 4:54:42 AM

So it does when both displays are at the same resolution and refresh rate?
Have you tried switching the ports on the card and see if it'll do it on the monitor then?
Maybe you could try uninstalling CCC/drivers and let Windows 7 load it's own default drivers and see if it still does it. Or just completely uninstalling everything CCC and reinstalling it again if you haven't tried that yet.

My Sapphire TOXIC 4870 1GB card isn't doing it with my dual Syncmaster T240HD's, but they're both DVI also. Just trying to figure out other things to try so you can attempt to narrow it down.
Share
June 25, 2011 5:24:31 AM

yup both displays are same resolution/refresh rate.. i even tried changing resolution on TV just to see if it would change anything.. but nope.

I was actually thinking of that... uninstalling and reinstalling CCC drivers and test if that would help.. maybe something not functioning right or is conflicting with a previous version of a CCC driver...

ill test that out and keep you posted!

Thanks,
Sam
m
0
l
a b U Graphics card
June 25, 2011 5:30:31 AM

Well, my Panasonic TV (1080p) and my Samsung BX2450 work fine together. The TV attached with the HDMI and the Samsung with the DVI to HDMI.

I have your same config, even swapped things around a bit, but don't notice any flickering or noise on neither screen =/

Have you tried switching the adapter around? Cables?

Cheers!
m
0
l
June 25, 2011 5:50:29 AM

Best answer selected by blade86sam.
m
0
l
June 25, 2011 5:55:18 AM

thanks arson, i uninstalled the drivers and let it install the basic driver, doing that.. CCC was not available and therefore my card was back to its default clocks... 750/900

i did the test with dual monitors n launched a 3D application, loading the 3D clocks.. and no issue!

i then decided lets reinstall 11.6.. i did and put my clocks back to 815/1000.. issue is back!

so that got me thinking.. hmm lets try just setting overdrive to default.. well what do you know.. issue is gone..

i then did experimenting with the clocks to see which was causing the major issue.. and it turned out to be the memory clocks... Odd i say since it used to work fine in the past...

So i then set my clocks to 850/900 and up till now that issue is not appearing!

Thanks,
Sam

P.S. I am still finding it strange that it only happens when i do dual monitors, at least in a Monitor/TV setup... :na: 
m
0
l
June 25, 2011 7:07:34 AM

Welcome, I'm glad it worked out for ya. Sucks that it does it when you OC though. I wonder if mine would react the same way? I've never OC'd mine before lol. Might try it tonight before I go to bed.
m
0
l
June 25, 2011 3:34:26 PM

yea it does suck... cause i've had it at those clocks almost at the same time i bought the card, roughly 2yrs now and i never experienced that issue until recently (about 3months ago)...

but it could be the memio temps.. i know they should b roughly +5-10C higher then the others but mine is supposedly +15-20C ... that could be the reason why. so i might end up taking the fan off and apply some arctic silver 5 on the gpu n see wat that changes afterwards

But hey, let me know what happens when you overclock via ati's overdrive, if you ever do overclock :)  hehe.

Thanks,
Sam

P.S. MY MEMIO Temp...

m
0
l
!