System doesn't recognize Galaxy Geforce GTS 450

I just built a new computer, bought all the stuff from Newegg.ca, so i can return the card if needed.
the problem is that i bought the Galaxy Geforce GTS 450 graphics card (along with the motherboard, ram, processor, and HDD), installed everything in the computer, booted up for the first time, installed windows 7 and all the drivers for everything but the graphics card (everything else worked perfectly), but my system won't recognize the graphics card. The driver install CD that came with it says that i do not have an nvidia-ready card; i tried (just in case) to download the drivers from the nvidia website, but it also says that i do not have an nvidia graphics card.

My specs:
Motherboard: ASUS M4A78LT-M LE
RAM: 4gb
Processor: AMD Athlon II x2 255 3.2 GHz
PSU: Antec 500w (EA-500D)

i'm not sure why it isn't working, googloed it but couldn't find anything.
might be DoA?

thanks in advance
9 answers Last reply
More about system doesn recognize galaxy geforce
  1. I'm having the same problem.
    My specs:
    asus m4n98td evo
    galaxy gts 450
    650w psu
    When I try to load a game it crashes and restarts; sometimes the computer never gets past the welcome screen! I put in a gt 430 to see if that works and it's working fine. Also installed older drivers, no luck. If someone has a solution please tell me how to fix it, this is a nightmare! Thanks!
  2. Cmoore said:
    I just built a new computer, bought all the stuff from Newegg.ca, so i can return the card if needed.
    the problem is that i bought the Galaxy Geforce GTS 450 graphics card (along with the motherboard, ram, processor, and HDD), installed everything in the computer, booted up for the first time, installed windows 7 and all the drivers for everything but the graphics card (everything else worked perfectly), but my system won't recognize the graphics card. The driver install CD that came with it says that i do not have an nvidia-ready card; i tried (just in case) to download the drivers from the nvidia website, but it also says that i do not have an nvidia graphics card.

    My specs:
    Motherboard: ASUS M4A78LT-M LE
    RAM: 4gb
    Processor: AMD Athlon II x2 255 3.2 GHz
    PSU: Antec 500w (EA-500D)

    i'm not sure why it isn't working, googloed it but couldn't find anything.
    might be DoA?

    thanks in advance



    right click my computer
    select manage
    select device manager
    look at display adapter
    if it says generic VGA
    then

    Do a windows update to get the WDDM driver for the card
    and then install the Nvidia drivers

    assuming you have Windows 7
    goto to start menu
    then all programs
    then Windows Update
    it should find the Microsoft WDDM driver
    after MS driver installs
    then restart
    and install Nvidia driver

    let me know if this works
  3. BeastyBoss said:
    I'm having the same problem.
    My specs:
    asus m4n98td evo
    galaxy gts 450
    650w psu
    When I try to load a game it crashes and restarts; sometimes the computer never gets past the welcome screen! I put in a gt 430 to see if that works and it's working fine. Also installed older drivers, no luck. If someone has a solution please tell me how to fix it, this is a nightmare! Thanks!



    You need to start your own question thread
    it is not polite to "hijack" somebody else's thread
    I will look for it
    :)
  4. I'm not hijacking his thread. No one was responding to it so I decided to give some backup to show that I am having the same exact problem as well.
  5. Hey I wasnt being mean LOL

    Did you try updating your DirectX?
    especially with Windows 7 you should do the latest DX9 update
    since alot of games still use it

    http://www.microsoft.com/download/en/details.aspx?id=35

    with Win7 it has great DX11 but the DX9 needs updating
    Might help

    BTW I didnt want to see you getting in trouble with the mods :)
  6. Actually I think I have found a solution.
    I had a gt 430 in my computer since the gts 450 wasn't working, and the gt 430 was working fine. Since the gt 430 uses the same nvidia drivers as the gts 450, i decided to swap them out without uninstalling nvidia drivers. And Ta Da! Now my galaxy gts 450 is working fine! So if you have an extra 400 series graphics card try putting it into your motherboard, install the drivers for that card, turn off your computer, swap that card back out for the gts 450, and see if that works. I really think it should work because it worked for me ;)
  7. lol just kidding, it's crashing again. At least it actually started up though. I tried to install nforce drivers again to see if that fixed it, but no luck.
  8. OH MY GOODNESS I HAVE ACTUALLY FOUND A SOLUTION OH MY GOD I'M SO HAPPY HAHAHAHA!!!
    Go to galaxytech website (the guys who make the graphics card i'm using)
    download graphics driver from their site
    and it should work!!! And i'm not joking this time this one actually worked
  9. I keep fooling myself. I think it's working, but then it stops a bit later. I think it's time for a new graphics card :/
Ask a new question

Read More

Graphics Cards Geforce Graphics