Sign in with
Sign up | Sign in
Your question

Spdif passthrough for games

Last response: in Components
Share
November 27, 2011 3:41:18 AM

Hello,
I have a home theater system which I connect from my computer through SPDIF optical cable. I have the following mother board and inbuilt sound card - Gigabyte 880GM - USB3, sound card - Realtek 892ALC which has Dolby Digital Live. I have managed to passthrough audio using AC3 filter when playing through Media player classic every processing is done by the AVR. But I want that from games too, the passthrough is not happening for games, for which I want the sound to be processed by AVR not sound card. Be it 5.1 or 2.1 I want complete passthrough. Is it possible to do?
November 28, 2011 5:10:45 AM

which OS do you use? it does not nessessarily have to be pass-through unless you want the raw signal. digital output would still be decoded and converted by your AVR. perhaps you can try the normal digital out rather then SPDIF pass through?
m
0
l
November 28, 2011 6:26:42 PM

Welcome to the world of SPDIF; hence why I HATE it with a passion...

The only way a soundcard does nothing is in the case of SPDIF In->SPDIF Out. Every other audio path will at least go through some of the soundcards processing, be it hardware or driver level.
m
0
l
Related resources
November 29, 2011 5:41:34 AM

erly_Cuylers said:
which OS do you use? it does not nessessarily have to be pass-through unless you want the raw signal. digital output would still be decoded and converted by your AVR. perhaps you can try the normal digital out rather then SPDIF pass through?


I am using Windows7 64bit home edition.

What is normal digital out?
m
0
l
November 29, 2011 5:44:47 AM

gamerk316 said:
Welcome to the world of SPDIF; hence why I HATE it with a passion...

The only way a soundcard does nothing is in the case of SPDIF In->SPDIF Out. Every other audio path will at least go through some of the soundcards processing, be it hardware or driver level.

Yes there is an option to check SPDIF In->SPDIF Out in realtek audio control panel tab. That is checked too. Still nothing comes. Please help to find a solution.
m
0
l
November 29, 2011 7:01:17 AM

digital output is still carried through the SPDIF Toslink. typicly you have to specify you want "pass-through" at the apllication level. I was suggesting you use digital out put without "pass-through. unless I'm mistaken digital output will be decoded and converted by your AVR.
m
0
l
November 29, 2011 9:29:52 AM

SPDIF passthrough should ONLY be checked if you want to pass through an input from the SPDIF INPUT port directly to the SPDIF OUTPUT port. Otherwise you'll get a null output...

The only thing you should have to do is enable the SPDIF output as the default output device from the windows control panel. That should at least result in the output to the AVR...
m
0
l
November 30, 2011 9:31:32 AM

I have unchecked SPDIF In->SPDIF Out checkbox. Still no improvement. I can increase or decrease the volume while gaming whereas it is not possible when playing audio through Media player classic, that means processing is done by the AVR, but is it not happening while gaming....
m
0
l
November 30, 2011 1:22:52 PM

Depends on how things are set up. Even using SPDIF output, you still go through the soundcards driver layer, and theres nothing you can do about that. I suspect that using AC3 filter for media player is the primary reason why you are getting different behavior between WMP and games.
m
0
l
December 1, 2011 10:41:26 AM

gamerk316 said:
Depends on how things are set up. Even using SPDIF output, you still go through the soundcards driver layer, and theres nothing you can do about that. I suspect that using AC3 filter for media player is the primary reason why you are getting different behavior between WMP and games.

But if I do not use AC3, then music quality is too bad and I can tell that processing is done not only by the AVR but the sound card too. Volume bar also works in windows and applications. To use AVR it is recommended to use AC3 filter and do some modification, if not used sound is pathetic. I think I should not uninstall this. There must be a solution for gaming....
m
0
l
December 1, 2011 11:32:10 AM

^^ Nope. AC3 is basically a plugin for music playback software, but theres no way to get it to work for games. Hence, you are getting different behavior between the two.
m
0
l
December 1, 2011 12:13:18 PM

gamerk316 said:
^^ Nope. AC3 is basically a plugin for music playback software, but theres no way to get it to work for games. Hence, you are getting different behavior between the two.

I don't want AC3 to use for games. Just the processing to be done only by the AVR not sound card, and it is not happening. Gaming sound though AVR is way too bad.... no solution getting....
m
0
l
December 1, 2011 2:10:52 PM

^^ Thats, again, the downside to using SPDIF: Crappy audio quality.

Can you connect to the AVR via analog? Or connect directly to the soundcard?
m
0
l
December 2, 2011 7:42:14 AM

gamerk316 said:
^^ Thats, again, the downside to using SPDIF: Crappy audio quality.

Can you connect to the AVR via analog? Or connect directly to the soundcard?

I think no, no analog cable is provided too. The speakers has 2 naked wires(red & black) which can be inserted to AVR. But not any thing like 3.5mm jack....
m
0
l
December 2, 2011 11:04:02 AM

^^ Well, you could buy a cheap RCA to TRS converter cable, which would allow direct hookup to the soundcard...

What I *think* may be happening, is using AC3 filter may be doing teh opposite of what you think, and making the soundcard do more work cleaning up the signal, resulting in a better sounding audio output. Since AC3 filter can't be used outside media programs, however, audio produced in games is being sent with only minimal enhancement, resulting in lower quality audio.

Connecting to the soundcard via analog would remove the AVR from the equation, allowing us to figure out where exactly the audio quality problem lies.
m
0
l
December 3, 2011 3:31:17 AM

it's still my best guess that the basic configuration for alto123's setup is incorrect.

alto123 if you would please look at your

1. HD Audio Manager

2. Windows 7 Sound Settings

and tell us everything you have checked and set including SPDIF settings and output device?

also you may want to check your Games's sound settings set it to digital if possible game's are not my strong suit but it may just not be possible to output any given game through SPDIF. have you tried other games?

cheers, erly
m
0
l
December 4, 2011 2:04:42 AM

Ok, telling about my sound settings -
In HD Realtek audio manager: Digital output(optical) [2nd tab] is made as default through Set Default Device. In default format Doly Digital Live (5.1 surroung) is choosed from dropdown.
In windows sound under playback tab Realtek Digital Output(Optical) is ticked as green. In it properties under Supported formats DTS Audio & Dolby Digital both are checked which is under Encoded Formats. 44.1 KHz, 48.0 KHz, 96.0 KHz checked which are under Sample Rates (192.0khz is not checked as Test sound produced nothing so unchecked it).
That is it. Nothing more has been done.

One thing to note that Black Ops has digital audio option to choose from and it is selected as audio settings. Still......
m
0
l
December 5, 2011 10:06:20 PM

Click on Start>Control Panel>Hardware and Sound>Sound.

tell me what each device is listed under the playback tab and which is set as default (with the little green check mark).

erly
m
0
l
December 6, 2011 2:47:08 AM

Quote:
In HD Realtek audio manager: Digital output(optical) [2nd tab] is made as default through Set Default Device. In default format Doly Digital Live (5.1 surroung) is choosed from dropdown.


That should force all 5.1 audio to Dolby standard. But again, thats still being done driver side, so you are still going to go through some soundcard audio processing.

Quote:

In windows sound under playback tab Realtek Digital Output(Optical) is ticked as green. In it properties under Supported formats DTS Audio & Dolby Digital both are checked which is under Encoded Formats. 44.1 KHz, 48.0 KHz, 96.0 KHz checked which are under Sample Rates (192.0khz is not checked as Test sound produced nothing so unchecked it).
That is it. Nothing more has been done.


This shouldn't matter; playback only informs windows of what can be played back at the other end of the chain, but if DDL is already forced, this shouldn't matter. I would disabled 96KHz though, as Dolby is incapable of encoding to that high a bitrate via DDL.

Only other thing that you should have to do is make sure windows is configured for 5.1 speaker output.
m
0
l
December 8, 2011 11:22:32 AM

gamerk316 said:


Only other thing that you should have to do is make sure windows is configured for 5.1 speaker output.


How to do that please clarify?
m
0
l
December 8, 2011 1:56:17 PM

Via Windows Control Panel; make sure the audio output in the sounds section is set to 5.1. Thats the only thing I can think of that could be causing the problem at this point...
m
0
l
December 9, 2011 2:32:33 AM

alto123 said:
Hello,
I have a home theater system which I connect from my computer through SPDIF optical cable. I have the following mother board and inbuilt sound card - Gigabyte 880GM - USB3, sound card - Realtek 892ALC which has Dolby Digital Live. I have managed to passthrough audio using AC3 filter when playing through Media player classic every processing is done by the AVR. But I want that from games too, the passthrough is not happening for games, for which I want the sound to be processed by AVR not sound card. Be it 5.1 or 2.1 I want complete passthrough. Is it possible to do?



First and foremost, what receiver do you have? That will determine what you can and can not do.

Also AC3 is an audio format, the source audio must support it. For MPC it's a plugin, but for video games the game software must be programed to use it, I doubt you'll find many. In the games themselves you must enable DDL or some form of environmental audio effects, otherwise you'll just get 2 channel PCM coming out. Your sound card also needs to support whatever format the game is wanting to use for 3D positional audio, it's usually EAX these days. If the card does not support EAX or the game's not handing over it's audio data in a 3D compatible format, then you'll just get 2-channel PCM.

This has absolutely nothing to do with digital SPDiff / Coax / HDMI / 6 channel analog connections. Its the audio source not passing 3D environmental data to the sound drivers. If you connect using 5~7 channel RCA wires you will still only get 2-channel audio, your sound drivers will employ software to determine a pseudo-environmental effect. If you employ digital (coax / SPDiff) connections then whatever source audio will be passed to the receiver, then it will use it's hardware to perform the environmental effects. Setting "DDL" in your audio control panel will have absolutely NO EFFECT on games unless the games support the audio format.

Let me do some research on your audio CODEC but I'm still thinking the problem lies with the games audio sourcing.
m
0
l
December 9, 2011 3:05:53 AM

Ok just got done looking up your audio CODEC and there could be a few solutions.

First what drivers do you have loaded, were they off the motherboard's CD or did you go to Realtek and get it from them.

http://www.realtek.com/downloads/downloadsView.aspx?Lan...

I would trust them directly from realtek as it should have all the options and formats enabled by default.

Also what is your default setting under windows sound playback?

Control Panel -> Sound -> Playback Tab -> Digital Output -> Properties -> Advanced

Should be a list of multichannel settings. If it only shows 2-channel settings then your card doesn't support creating multichannel digital I/O streams on it's own. At this point it's entirely up to your game to send it's signal in Dolby / DTS / WMA Pro or whatever format your card and receiver support. If the game doesn't use any of the supported formats then your stuck using the RCA cables or using 2-channel PCM then having your stereo DSP's do the environmental processing. There is also software that intercepts DirectSound calls and encodes it from 5.1 PCM to 5.1 AC3 or DTS. Realktek use's 3D SoundBack and it's available on their driver website.

Also are you using Windows 7 or Windows Vista? This is an issue because as of Vista Microsoft is forcing everyone to use the universal windows audio control rather then letting programs directly talk to hardware. This could be an issue if your game tries to speak EAX and doesn't know to translate it through the audio center first.
m
0
l
December 9, 2011 11:15:57 AM

^^ Paladin, his chipset has DDL support, so 5.1 via SPDIF shouldn't be a problem. DDL does NOTHING but convert a 5.1 PCM stream to Dolby format, so as long as the game can output standard 5.1, he should have no troubled getting 5.1 audio via SPDIF.

Though you MAY have stumbled onto the root problem: What games are you trying to send 5.1 from? Under the new audio architecture [starting with Vista], Directsound is a 2.0 software API. If the game is old enough, you will not be able to output 5.1 using any connection type. [I believe Realtek has a seperate "3d soundback" driver that fixes this though...]. This shouldn't be affecting any modern games though, but it could be part of the problem...
m
0
l
December 9, 2011 8:10:52 PM

erly_Cuylers said:
Click on Start>Control Panel>Hardware and Sound>Sound.

tell me what each device is listed under the playback tab and which is set as default (with the little green check mark).

erly


Under playback tab - Speakers, Realtek Digital Output, Realtek Digital Output(Optical) is listed and Realtek Digital Output(Optical) is with a green tick mark.
m
0
l
December 9, 2011 9:18:02 PM

palladin9479 said:
Ok just got done looking up your audio CODEC and there could be a few solutions.

First what drivers do you have loaded, were they off the motherboard's CD or did you go to Realtek and get it from them.

The one provided with motherboard driver.

palladin9479 said:

Also what is your default setting under windows sound playback?

Control Panel -> Sound -> Playback Tab -> Digital Output -> Properties -> Advanced

Dolby digital Live(5.1 surround) is selected


palladin9479 said:

Also are you using Windows 7 or Windows Vista? This is an issue because as of Vista Microsoft is forcing everyone to use the universal windows audio control rather then letting programs directly talk to hardware. This could be an issue if your game tries to speak EAX and doesn't know to translate it through the audio center first.

I am using Windows 7 64bit
The receiver I am using is Harman Kardon 134.
m
0
l
December 10, 2011 12:45:54 AM

gamerk316 said:
^^ Paladin, his chipset has DDL support, so 5.1 via SPDIF shouldn't be a problem. DDL does NOTHING but convert a 5.1 PCM stream to Dolby format, so as long as the game can output standard 5.1, he should have no troubled getting 5.1 audio via SPDIF.

Though you MAY have stumbled onto the root problem: What games are you trying to send 5.1 from? Under the new audio architecture [starting with Vista], Directsound is a 2.0 software API. If the game is old enough, you will not be able to output 5.1 using any connection type. [I believe Realtek has a seperate "3d soundback" driver that fixes this though...]. This shouldn't be affecting any modern games though, but it could be part of the problem...



I realized this after I had posted. I was referencing the "DDL" as being "DDL passthrough" where the audio chip is just relaying the DDL / DTS audio data instead of encoding it. Nicer cards / chipsets do have the ability to encode from 5.1 PCM DDL / DTS. I use HDMI for everything so I haven't had to mess with this for ages.
m
0
l
December 10, 2011 12:50:23 AM

alto123 said:
The one provided with motherboard driver.


Dolby digital Live(5.1 surround) is selected



I am using Windows 7 64bit
The receiver I am using is Harman Kardon 134.


Ok that answers lots of questions. Your audio chip is capable of encoding 5.1 PCM into DDL and will do so if it's handed the proper data.

Which means the problem almost certainly lies within the software producing the sound data. Look into that "3D back" software I mentioned above, it could be that your game can't find any EAX or other hardware based 3D sound chip and is defaulting to DirectX 3D sound emulation. That just takes the sound data and creates a stereo two channel sound stream that tries to sound like 5.1.
m
0
l
December 11, 2011 4:51:29 AM

gamerk316 said:


Though you MAY have stumbled onto the root problem: What games are you trying to send 5.1 from? Under the new audio architecture [starting with Vista], Directsound is a 2.0 software API. If the game is old enough, you will not be able to output 5.1 using any connection type. [I believe Realtek has a seperate "3d soundback" driver that fixes this though...]. This shouldn't be affecting any modern games though, but it could be part of the problem...


5.1 or 2.1, want the sound only to be processed by the AVR. I am running black ops that has the option of choosing digital(optical) or speakers, but did not help either.
m
0
l
December 12, 2011 2:12:47 AM

go to Control Panel -> Sound -> Playback Tab and tell us which one has the green check on it?

I'm still covinced this is a configuration problem, just some simple check or click, here or there. it's just been so long since ive used Windows I forgot how to run it through my head.

cheers
m
0
l
December 12, 2011 9:12:55 AM

erly_Cuylers said:
go to Control Panel -> Sound -> Playback Tab and tell us which one has the green check on it?



Under playback tab - Speakers, Realtek Digital Output, Realtek Digital Output(Optical) is listed and Realtek Digital Output(Optical) is with a green tick mark.


One thing I want to ask, if I use HDMI for games what will happen? Will the sound directly come out of the speakers without being processed or nothing will come out?
m
0
l
December 14, 2011 11:18:09 AM

Hello gamerk316, erly_Cuylers, palladin9479
please respond to my issue posted above.
m
0
l
December 14, 2011 11:29:57 PM

Depends on if the HDMI on your GPU is pass-through or a real audio device.
m
0
l
December 15, 2011 10:04:51 AM

palladin9479 said:
Depends on if the HDMI on your GPU is pass-through or a real audio device.

GPU I have - ATI Radeon 5770, it has HDMI (manual says it can handle 7.1) . So is it possible to bitstream/passthrough to AVR?
m
0
l
December 15, 2011 11:22:29 AM

alto123 said:
Under playback tab - Speakers, Realtek Digital Output, Realtek Digital Output(Optical) is listed and Realtek Digital Output(Optical) is with a green tick mark.


Thats the problem. Select "speakers", and then configure the driver software to use SPDIF output. Do not use the optical port as the default output.

For whatever reason, when "Speakers" are not selected as the default output device, the SPDIF port is limited to two channels. I forget why this occurs though...Hence why you have the set Speakers as the default, then configure the software to use the SPDIF output port.
m
0
l
December 16, 2011 9:52:44 AM

gamerk316 said:
Thats the problem. Select "speakers", and then configure the driver software to use SPDIF output. Do not use the optical port as the default output.

For whatever reason, when "Speakers" are not selected as the default output device, the SPDIF port is limited to two channels. I forget why this occurs though...Hence why you have the set Speakers as the default, then configure the software to use the SPDIF output port.


Could u pls elaborate how to do it?
m
0
l
December 16, 2011 11:34:54 AM

^^ For a realtek? No idea offhand, though theres probably an option for spdif output somewhere in their driver control panel to use the SPDIF output as the default.

Its the same deal with my ASUS cards; if I select the SPDIF output from the Windows control panel, even if I enable DDL from the ASUS drivers, I only get 2.0 as output. If I select Speakers from the Windows control panel and select the use the SPDIF output from the ASUS drivers, then I get 5.1 via DDL.
m
0
l
December 17, 2011 12:28:45 AM

in reading through this thread I've noticed I started repeating myself. this is because of my limited knowledge of the way these things work plus, maybe I was being a little bit lazy. so I am sorry for the lack or repeating of replies here.

the thing is, I think all three of us is trying to figure how to get it to work, just to see if it works. to get you setup with the lesser of two evils and are perhaps ignoring your initial request of setting it up where processing is only done by the AVR. we know what you want but it is not necessarily possible. if you try the configurations we suggest and noting happens, it may be flat out that its not possible with games.

I have a couple of last suggestions. try this as far as how to setup your speakers and choose 5.1 as default.

try an output other than Dolby Digital Live, just try different configurations till you find the one that works. as far as processing being done exclusively by the AVR I don't think it's possible. at least in your case you may have to settle for less.

don't take it from me though, I'm no expert, just a fellow squid who has been to hell and back with this stuff. so I know it's frustrating. however I am unable to find a solution for you.

good luck, erly
m
0
l
December 17, 2011 6:59:33 AM

Ok, let me check the settings thoroughly....
however, 1 thing I do want to know that is ATI Raedon 5770 HDMI is capable of bitstreaming/pass-through, and processing to done totally by the AVR?
Is there any settings to do for it in Windows??
m
0
l
December 19, 2011 1:10:08 AM

alto123 said:
Ok, let me check the settings thoroughly....
however, 1 thing I do want to know that is ATI Raedon 5770 HDMI is capable of bitstreaming/pass-through, and processing to done totally by the AVR?
Is there any settings to do for it in Windows??



Short answer, yes.

All the ATI card with HDMI have actual 7.1 CODEC's on them. There is no analog output but it will output 7.1 via the HDMI connector. No need for pass-through. Inside windows sound config set the Ati card's digital output as the default sound device. You may have to download the audio drivers from AMD's webpage as few OEM's include them.
m
0
l
December 19, 2011 10:38:39 AM

palladin9479 said:
Short answer, yes.

All the ATI card with HDMI have actual 7.1 CODEC's on them. There is no analog output but it will output 7.1 via the HDMI connector. No need for pass-through. Inside windows sound config set the Ati card's digital output as the default sound device. You may have to download the audio drivers from AMD's webpage as few OEM's include them.


therefore sound processing will be done by the AVR only, isn't it?....
m
0
l
December 19, 2011 3:06:14 PM

alto123 said:
therefore sound processing will be done by the AVR only, isn't it?....


The sound should be passed over the HDMI connection to the receiver and from there processed into whatever sound environment you have.
m
0
l
!