Sign in with
Sign up | Sign in
Your question

I have a serious problem with crossfire 5770s

Last response: in Graphics & Displays
Share
June 26, 2011 3:41:14 AM

I have a ASUS P8P67 LE motherboard that is crossfirex ready.
I have an intel i5 2500k
An 850watt power supply and
2 Ati 5770 graphics cards

I have installed them both correctly, and i connected the crossfire cable.





These are my two 5770 in gpu z.

The problem is that no matter what i do, I have no option or mention of crossfire in ccc. It is like crossfire doesn't exist, and thus i can't enable the crossfire.

I have reinstalled my drivers dozens of times, I have swapped the graphics cards, I have even taken one out- installed just one card and than added the second a little later. No matter what I do I have no option to enable crossfire.

What am I doing wrong? This sucks because I just bought this card and now think it was a complete waste. This is scaring me away from ever trying crossfire again. Please help!!! I'm desperate.
a b ) Power supply
June 26, 2011 3:53:25 AM

But i think it shouldnt be able to display such settings such as CF because its a very generic driver.
I think you should not worry about it too much.

I display only engine control centre.
m
0
l
Related resources
June 26, 2011 3:56:00 AM

What? I don't understand. I want to run the two ati 5770s in crossfire and GPU-z is stating that crossfire is disabled. On top of that everywhere on the web says you have to enable crossfire in ccc, but I have no option for that. I bought a second 5770 for what seems to be nothing.
m
0
l
a b ) Power supply
June 26, 2011 4:00:32 AM

ooo.
Well yes you need to enable CF in ccc.I dont know how.
m
0
l
a c 88 ) Power supply
a c 96 V Motherboard
June 26, 2011 4:27:53 AM

Try a different CF cable? Your board has the slots farther apart then normal, perhaps the one you have is bad?
m
0
l
June 26, 2011 5:12:40 AM

yeah it would be smart to eliminate that as a possibility even though they are sometimes a pain in the arse to get your hands on
m
0
l
June 26, 2011 5:31:23 AM

I had a similar problem when I added my 2nd 5770 in April. The option for crossfire did not appear until I did a complete uninstall/reinstall of CCC. The latest version out right now is 11.6 - make sure you get that. Upon rebooting after the reinstall a window will pop up and say that crossfire is detected and confirm that you want to enable it. Make sure your crossfire bridge cable is attached as well. Good luck!
m
0
l
June 26, 2011 11:04:09 AM

I have totally reinstalled ccc maybe 6 times, no luck.

Where do i get another crossfire cable
m
0
l
a c 88 ) Power supply
a c 96 V Motherboard
June 26, 2011 11:40:43 AM

From a friend to test it. You'll need the longer 3 slot one however not the normal 2 slot distance one however.
m
0
l
June 26, 2011 12:37:29 PM

i have no friends that game, and why a longer cable if the shorter one fits?
m
0
l
a c 88 ) Power supply
a c 96 V Motherboard
June 26, 2011 1:17:23 PM

Shorter one shouldn't fit. You have an extra slot between your PCIe 16x slots. You need one that can span 3 slots, not 2.
m
0
l
!