Sign in with
Sign up | Sign in
Your question
Closed

V-sync like tearing on television HDMI-out Radeon 6950

Last response: in Graphics & Displays
Share
June 29, 2011 12:03:23 AM

As I'm watching videos on my 46 inch lcd tv on my duplicate monitor setup, I notice tearing consistently in the same spot about in the bottom quarter or third of the screen. This tearing is not visible on my 22 inch LCD computer monitor. . My PC monitor is connected DVI out and my TV is connected through HDMI. My video card is a Radeon 6950 2GB, let me know if you need additional details.

Are there any settings I can use/tweak to fix this?
June 29, 2011 10:12:00 AM

Note: I have just discovered that disabling my computer monitor completely eliminates the tearing. .why is this? I would like to find a work around as I need both to work at the same time.
Score
0
June 29, 2011 10:17:49 AM

Ok, even more bizarre. . I just disabled one my PC monitor and the tearing disappeared from the TV but when I enabled the monitor the tearing was present in the exact same position on the monitor as it was on the tv.

Anyone have any guess as to what might be causing this or how to fix it?
Score
0
Related resources
September 12, 2011 9:58:30 AM

I know this is an oldish post but I get the exact same issue with the same card on my 52" LG tv, it doesn't tear on the primary monitor but I get a horizontal line about two thirds of the way down on the secondary screen regardless of whether it's my 24" screen or the TV. has anyone had any luck resolving this?
Score
0
September 27, 2011 4:34:43 PM

I guess everyone is too preoccupied with squeezing that extra 4mhz out of their GPU overclock or telling everyone which components are best for generic user's "new gaming rig" to help out.

I discovered a partial work around the problem, if you go to desktop and right click selecting screen resolution you can disable your PC monitor and that seems to get rid of the tearing. This defeats the purpose of a dual viewing setup but if the idea is to watch your high res content on a much larger screen like in my situation it works out fine. Oddly when you tinker with disabling your PC monitor vs your television the tearing will switch displays if you choose to keep both on.

If anyone else would like to contribute additional insight, into the cause of the problem or a full fix that doesn't require disabling a display that'd be welcome. .that is of course if you're bored with that new full diamond Northbridge heatsink and pure silver CPU water block filled with ultra thermally conductive unicorn's blood you've been discussing for 52 pages.
Score
0
December 4, 2011 5:30:18 AM

I desperately hope that this thread isn't dead.

I've been experiencing this exact problem on my HDTV (HDMI out to 42" LED panel from Radeon HD 5870). When cloning the display and firing up a full screen game, I get consistent tearing in a fixed position in the bottom third of the screen. I have noticed that games that use triple buffering do not exhibit this problem, but enabling/disabling vsync generally has no effect..

I recently setup a 5.1 surround system with a receiver (HDMI -> receiver -> HDMI out to TV). Now when I clone the display, I see the tearing on my primary monitor (DVI). When I switch the audio receiver off, my primary monitor flashes and the tearing instantly stops.
Score
0
March 7, 2012 6:59:29 PM

I'm running Windows 7 x64 with cloned displays: a Samsung P2770HD connected through HDMI and another Samsung SyncMaster 2243 connected through a VGA cable.

The issue appeared on the designated secondary display, which is automatically set based on the Preferred Display settings in Catalyst CC. So if you set one of the two a preferred display, you will encounter this annoying line on the other one.

I got rid of it from the desktop by disabling Aero for Windows. This doesn't help games, which still show a visible tearing. I have forced the Vsync On and enabled Triple Buffering from CCC but to no use. Also note that this is by no means a vendor exclusive issue, as it was encountered on both ATI and Nvidia, so I presume vendor drivers can be ruled out.

If anyone has any clue about this irritating problem, feel free to contribute because I searched through almost all the threads that deal with "the line" (it's like an abnormal warping of the video signal, probably slowly braking the fabric of the universe, so this is URGENT) and people don't have a permanent solution. Based on what I've read and seen, I think this has to do with Windows handling duplicate displays.
Score
0
March 7, 2012 7:10:28 PM

I have gotten rid of this problem by making the following changes:

- Ensuring that my primary monitor (DVI) is the preferred display
- Changed pixel format on the secondary display (TV, HDMI) to 4:2:2

I can play any game with no tearing (provided vsync is enabled), including games without triple-buffering that previously exhibited the dreaded "line" near the bottom of the screen about 2/3 of the way down.
Score
0
March 15, 2012 3:57:48 AM

Pixel format? What is that? I have an nVidia card (GTX 460) and I haven't seen an option like that.

Just to corroborate with everyone else, my tearing happens at a static location on my TV when both TV and PC monitor are enabled (cloned). Disabling my monitor and enabling only the TV prevents the tearing. But I would like to see both displays without any tearing.

There is some wierdness with my monitor, a Samsung SyncMaster 2433. I see at least one other poster has this same monitor. Under Screen Resoluton > Advacned > Monitor, I have options of 59 Hz and 60 Hz, but regardless of what I choose, every time I open this window it is sitting at 59 Hz. Meanwhile, in the nVidia control panel the ONLY option available is 60 Hz. Go figure. So I was suspicious there was a 1 Hz difference between displays causing the tear, but since everyone seems to have the same tear I'm not sure this is part of the problem. Unless *everyone* here has a 59 Hz monitor and 60 Hz TV??

My tear can appear at different parts of the screen when I change modes/resolutions etc., but doesn't change position just over time.

So anyone know how to fix without pixel format, or can direct me to this setting using an nVidia card/nVidia control panel?

nVidia GeForce GTX 460 ->
DVI cable -> Samsung SyncMaster 2433 (PC monitor)
DVI to HDMI cable -> LG 47" 120 Hz (television)
Score
0
April 25, 2012 5:23:41 AM

I was having this same problem with a persistent screen tear (Samsung monitor in DVI and Samsung TV in HDMI) after upgrading my Radeon 5770 to a 7850, but Outrigger047's suggestion of changing the HDMI pixel format to 4:2:2 seems to have fixed the problem for me. I'm not sure how to do that with nVidia though.
Score
0
!