[SOLVED] DX 11 Cursor Issues

I'm going to try to be as thorough as possible at the start but I'm about to go crazy looking for an answer to this. I primarily play WoW and Crysis 2, both of which support dx11. When Wow officially supported it, I decided to try it out to see what all the fuss was about. After enabling it, I was getting this weird effect where when I hovered my mouse over buttons or objects, it would not register clicks or show tooltip info. I realized though that if I offset the mouse vertically and horizontally by about 6 inches, I would then be able to click the button I was trying to click. So my mouse was not directly over the item I wanted to click, but nearly half a foot away. This obviously makes the game unplayable in dx11. I reverted back to dx9..

So the crysis 2 dx11 patch drops and Im thinking "Let's give it a try." Of course, same issue. On top of that, my screen would revert to 720p windowed mode. I would have to find the right spot on the screen (very far from the actual buttons) to select 1920x1080, fullscreen, and dx9 option in order to change it back.

So...why in the (pick your favorite curse word here, I've used them all trying to figure this out) is this happening and why is no one else having this issue?? I have done a general google search (found other issues in other games, some similar to mine, but not exactly). Nothing in WoW forums, nothing in Mycrysis forums, nothing in nvidia forums.

In my mind, dx11 isn't THAT worth it really - I mean the games are still very much enjoyable without dx11, but still I have a gtx580 and I would like to see it work hard for once! :lol:

NOTE: all settings in nvidia control panel are set to default, leaving 3d apps to determine the level of quality. Nothing has been forced on (I initially thought that might be the issue) and of course, I have the most recent drivers. Also, I play on a 32" Insignia led lcd TV. Overscan off, game mode on, aspect ratio wide, adaptive contrast off, dynamic contrast ratio on, connected via HDMI.

Finally, system specs (that matter):
Core i5-750
Asus P7P55D PRO
EVGA GTX 580
8gig RAM
750W PSU
Windows 7 Ultimate
Both games are installed on an SSD
2 answers Last reply
More about solved cursor issues
  1. Reminds me of an issue I had when I tried playing GTA3:VC on win7. I could use a sniper rifle ok and kill people, but unless I was RIGHT next to the guy, using a machine gun/pistol would cause me to shoot up and to the right. Turns out in that game there is a setting for wide screen. I turned that on thinking that would cause me to see the widescreen options. (before when I played it on XP I had my old CRT monitor.) Turns out that widescreen setting only stretches what it renders. Turning it off and leaving the resolution at 1680x1050 fixed my problem. I would try changing any similar settings in the game, and possibly the overscan on the TV. Might also want to try a regular monitor and not a TV.
  2. I finally figured this one out, I wanted to document my findings in hopes this thread will help another person. My display was set to be sized 150% larger, due to my screen size. I don't remember ever setting it this way, however I have had my rig on this monitor/tv for almost 2 years now and may have done it on day one, not remembering this. The solution was to set it back to default, 100% size. Do this by:

    -Control Panel (view by: small icons)
    -Display
    -Set to 100%
    -Apply

    DX11 is alive in working in both games listed above!
Ask a new question

Read More

Nvidia World Of Warcraft Graphics