D-Link Wireless usb adapter issues

Ok, heres my problem. I work for a large car dealership, and the mechanics need some computers to access a device on a wireless subnet of the dealership. Most of them have laptops, but the one computer in question is a desktop. It is an acer aspire x1301 dual core running windows 7 pro x64, 4GB Ram. We did have it wired into the wireless router, but it got moved so i had to switch it to wireless. I tried to find a wireless card, but i was informed that because of the size of the case, there would be no wireless card small enough. So i bought this d-link usb adapter. It worked fine for the first few days, but then it started randomly disconnecting from the wireless signal. The signal strength varies between 70 and 80 %. Ive tried ip release/renews, nothing. I also tried uping the DHCP lease time, nothiing, I tried disabling the firewall, didnt help. So, today i ran a chkdsk, sfc /scannow(this came up with a corrupt log file) and ive also reset the winsockets(netsh winsock reset catalog) && (netsh int ip reset reset.log hit) but im not too optimistic about this solution. Im at my wits end. Any help would be greatly appreciated. My router is a TP-Link TR-WD1043ND operating on channel 11 in b/g/n mixed. unsecured (for customers with ipods/iphones/blackberrys/whatever
Thanks

-Josh
5 answers Last reply
More about link wireless adapter issues
  1. first of all get a second router for public access if you value you companies data. Just change the LAN IP to 192.168.254.1 of the second router and connect the WAN/internet port to the main router.

    secure your main router. also try a different channel. keep cordless phones away. set it to N-only. if there is an option of 20/40Hz try 20Hz.

    make sure the router is elevated

    which D-Link wireless adapter are you using?
  2. There is no company data on this particular subnet. This network is only for the mechanic shop. The supernet has only 2 usable ip addresses left (for now, change is coming) so installing a second router is out of the question. (Mandated by my superiors) There are no cordless phones in the whole building. The adapter im using is a Wireless N 150 DWA-125. I will try these other settings changes and fill you in

    EDIT: changed to channel 2, Switched to 20 Hz(what does this do?), switched to N only, router cannot be elevated due to the lengths of cords already connected
  3. this did not help
  4. try the G-only.

    I never could get a N-150 to work no matter who the manufacture was
  5. i ended up just buying ~40 yards of ethernet cable to connect to the router. Thanks for the help
Ask a new question

Read More

Connectivity Wireless USB Adapter Wireless Networking