Sign in with
Sign up | Sign in
Your question
Solved

NIC "dies", is revived when PSU is reset

Last response: in Networking
Share
October 19, 2010 11:09:20 PM

The NIC on my Asus P7P55D-E LX has a habit of "dying" randomly with no apparent cause. While dead, my system finds no problem with the hardware but I cannot connect to the internet or my router or any networks for that matter. Windows seems to think that the cable is faulty, but I've established that this is not the case.

However, once I hit the switch on my PSU, wait a few seconds, and start my computer back up, the NIC is fine again... until it dies again, anyway. A normal computer restart does not fix the problem; only a complete power restart.

I've tried resetting the NIC via Windows, installing driver updates from both Asus and Realtek, checking the router/cable, and fiddling around with the BIOS, but the only thing that seems to work is simply cutting the power entirely for a few seconds from the PSU. I want a permanent solution, but my technical knowledge is limited.

It is a little difficult to search for this kind of problem online. Could someone help me?

Here are my system details, if it is relevant:
- Windows 7
- i5 760 processor
- DDR3 2x2GB RAM
- Asus P7P55D-E LX mobo
- 750W PSU

Best solution

Anonymous
October 19, 2010 11:17:03 PM

Look in the BIOS or Windows Power Settings -- or look at the Properties of the NIC in Device Manager. Somewhere there will be mention of turning off to save power -- disable that.
Share
October 20, 2010 7:52:29 PM

That seems to have done the trick. I was afraid that there was some physical damage to the hardware.

With such a simple solution, it makes me think I just didn't look hard enough. :p 

Anyway, thank you!
m
0
l
Related resources
October 20, 2010 7:52:40 PM

Best answer selected by janeglasser.
m
0
l
October 25, 2010 5:19:06 PM

janeglasser said:
That seems to have done the trick. I was afraid that there was some physical damage to the hardware.

With such a simple solution, it makes me think I just didn't look hard enough. :p 

Anyway, thank you!

That is one way of doing the trick, by not allowing system shutting down the nic card in the first place.
Another way is trying to load a newer nic driver which will allow nic being shutdown when system goes to sleep but at the same time allow the nic card being completely woke up and online ready.

I just experienced a similar problem on my new Asus PC. I tried the same workaround before loading the new driver to fix the problem.
m
0
l
!