Sign in with
Sign up | Sign in
Your question
Solved

How to make Xonar 7.1 work with my Radeon HD5700 on Windows 7

Last response: in Components
Share
December 1, 2011 2:29:38 PM

I have a HTPC build with Windows7 (64bit) running on it. I have ATI Radeon HD 5700 Series on Gigabyte X58A-UD3R motherboard. The current set up is to have both audio and video going through HDMI out. I recently installed ASUS Xonar DS 7.1 to get the exclusive audio out from S/PDIF. However, after much tries, I have not been able to get it working (the audio will never come out through Optical S/PDIF and will pass through HDMI only). I did an extensive research on internet forums and found out that the only way it could work is somehow disable audio to come out through Radeon board (which forces it to go through HDMI). Could anyone tell me how could I make it work?
a b $ Windows 7
December 1, 2011 5:15:32 PM

Simple: Go to the Windows control panel and set the default sound output device to the Xonars Optical output. Then, from the Xonar control panel, select to use SPDIF as the output.
m
0
l
December 1, 2011 5:37:33 PM

I tried that many times and when do test, it does show the green bar going up but no sound output.. :pfff: 
m
0
l
Related resources
a b $ Windows 7
December 1, 2011 6:45:00 PM

That means the problem is probably driver side. Can you post a Screenshot of your driver control panel?
m
0
l
December 2, 2011 6:23:12 PM

How do I take a screenshot of driver control panel, could someone explain to me on where do I see the Driver Control Panel?
m
0
l
December 6, 2011 1:27:58 AM

Sorry, it took me a while to understand, but finally here are the driver details:


m
0
l
a b $ Windows 7
December 6, 2011 2:39:39 AM

I meant that ASUS Driver software that you should have installed; something like:



[this one is for a different card, but the control panel is mostly the same for all of ASUS' cards]
m
0
l
December 6, 2011 3:17:45 AM

m
0
l
a b $ Windows 7
December 6, 2011 11:35:57 AM

Nothing looks too bad; I recommend reducing Audio Channel to 6 channels, as SPDIF is incapable sending any 8-channel signals, but that shouldn't be causing any issues with DTS encoding...[I think?]. Aside from that, everything looks in order...

Also, try disabling GX mode; its possible the Directsound wrapper is causing some compatability problems.
m
0
l
December 8, 2011 10:57:58 PM

I tried the recommendations and it seems to have not changed anything, still not getting sound out from S/PDIF.
m
0
l
a b $ Windows 7
December 9, 2011 11:08:19 AM

Ok then, lets go back to basics then: Disable DTS interactive and send only PCM signals out [44.1 or 48KHz]. Does THAT work?
m
0
l
December 20, 2011 2:32:41 PM

gamerk316 said:
Ok then, lets go back to basics then: Disable DTS interactive and send only PCM signals out [44.1 or 48KHz]. Does THAT work?

Sorry was away from my home and could not test it earlier.

I tried that and no result. I am not sure if this is a problem on my A/V Receiver where we need to get the audio input through optical instead of HDMI or is it a problem from my PC where audio is not coming out through optical cable. I do not know a way to determine whether audio indeed is coming out through my optical cable(S/PDIF), could you suggest me a way to test that please?
m
0
l

Best solution

a b $ Windows 7
December 21, 2011 12:37:42 AM

Lets go back a few steps and try this:

1: In the Windows Control Panel:

Set the Default Output Device to "Speakers" (ASUS Xonar DS Audio Device). Do NOT set the default device to SPDIF out (yes I know; its counter-intuitive)

2: In the ASUS Driver Control Panel, set the following settings:

A: Audio Channel: 2 Channel
B: Sample Rate: PCM 44.1 KHz
C: Analog Out: 2.1 Speakers (this shouldn't matter though...)
D: SPDIF Out: Checked (PCM)
E: 7.1 Virtual Speaker Shifter: Unchecked

I'm basically looking to see if a standard PCM signal gets outputted properly.

If this fails, you can give the Xonar Unified Drivers a shot; I've heard good things about them, though haven't seen the need to use them yet...
Share
December 26, 2011 2:08:32 PM

Best answer selected by atl999.
m
0
l
December 26, 2011 2:19:50 PM

gamerk316, Thanks for your help. It is working now as desired. There was a learning on my part too for my Pioneer VSX-1120k. For most part, it was issue with my A/V receiver. Just for the benefit for others who may have similar issue, beside selecting the OPT-1, 2,3 option in the control panel of receiver for the HDMI mode, you also need to set the SIGNSEL(press numeric key 4 on the remote) and select DIGITAL, default is HDMI and receiver will continue to be on the HDMI Audio mode.

Now, on gain of sound quality with this change (from HDMI to S/PDIF using Xonar), I am not that satisfied. I eventually found what settings gamerk316 has also suggested produces the best results. The virtualization and other settings make the sound output little harsh and artificial.

Now that I have my optical output working, does anyone else have anything to suggest for improving the audio output with Xonar sound card?
m
0
l
!